LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   /etc/rc.d/rc.hald missing (http://www.linuxquestions.org/questions/slackware-14/etc-rc-d-rc-hald-missing-4175446016/)

Ratmonkey 01-17-2013 08:02 AM

/etc/rc.d/rc.hald missing
 
Trying to get my iPhone to connect with Amarok on Slackware 14. Installed usbmuxd and libimobiledevice, but at the end of libimobiledevice install, I got "chroot: failed to run command '/etc/rc.d/rc.hald': No such file or directory. I did some searching and didn't find much that was helpful on the forums or Google. I did find an rc.hald file I think for version 11 from Alian Bob's site, but not sure what I would do with it? Can I simply place that in the rc.d directory?

http://taper.alienbase.nl/mirrors/sl...em/hal/rc.hald

Thanks.

Didier Spaier 01-17-2013 08:18 AM

No more hal in Slackware 14.0, so rc.hald would do nothing anyway.

Where/how did you get/install usbmuxd and libimobiledevice? And what makes you think those are necessary?

Stephen Morgan 01-17-2013 08:20 AM

That script just starts hald, which is no longer included in Slackware, as of the most recent version.

Ratmonkey 01-17-2013 08:24 AM

Didier,

http://slackbuilds.org/repository/14...imobiledevice/

When I plug my iPhone in, it is seen as a camera. Amarok doesn't even know it's there. Googling it, I found that I needed libimobiledevice... are there other suggestions on how to get it working?

Didier Spaier 01-17-2013 08:33 AM

Quote:

Originally Posted by Ratmonkey (Post 4872179)

OK then, you should first report the problem to the maintainer of the SlackBuilds, as he is certainly aware that hal is not included in Slackware 14.0.

Or you could stop by #slackbuilds on IRC where you may get an even faster answer.

When doing so, post the end of the build log where you see the error messages (on IRC you could use pastebin.com to paste it and then include the link to it in your message).

Ratmonkey 01-17-2013 08:33 AM

Or is it that it is no longer needed for the package to work? Maybe I'll try a reboot =P

Didier Spaier 01-17-2013 08:41 AM

Following file: http://slackbuilds.org/slackbuilds/1...vice/doinst.sh is obsolete. Maybe a reboot will be enough. In any case please report to the SlackBuild's maintainer so he make the needed update.

Ratmonkey 01-17-2013 08:55 AM

I'm going to mark this thread as solved, since rc.hald is not a part of Slackware 14. I'll start a second thread related to my issues with my iPhone.

Thanks.


All times are GMT -5. The time now is 05:23 PM.