LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-30-2013, 04:26 PM   #1
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
/etc/modprobe.d/blacklist.conf not working


Well not completely!

I have blacklisted snd_pcm_oss so that the sound works in youtube videos (flashplayer-plugin).

But it still loads and I have to use rmmod before I can watch any videos.

The odd thing is that the other items that are blacklisted are not loaded, so why is this module not behaving?

samac
 
Old 03-30-2013, 04:31 PM   #2
PJM
LQ Newbie
 
Registered: Dec 2007
Location: Poland
Distribution: Slackware, Slax, Gentoo
Posts: 2

Rep: Reputation: 1
Take a look maybe at the /etc/rc.d/rc.alsa file.
 
1 members found this post helpful.
Old 03-30-2013, 04:42 PM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,380

Rep: Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913
When libkmod was introduced the default behaviour of modprobe changed. It now ignores the blacklist unless you specify the "-b" option. rc.alsa hasn't been updated to reflect this yet. I reported it to Pat a while back, so hopefully this will be fixed in current at some point.. In the mean time, just add the -b option to the modprobe commands in your rc.alsa.
 
1 members found this post helpful.
Old 03-30-2013, 04:46 PM   #4
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Original Poster
Rep: Reputation: 137Reputation: 137
OK that looks promising, I have edited it, now rebooting.

samac
 
Old 03-30-2013, 04:53 PM   #5
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Original Poster
Rep: Reputation: 137Reputation: 137
All fixed now, thank you GazL.

samac
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] /etc/modprobe.d/blacklist in RHEL 4.5 linux_beginer Linux - Newbie 3 04-03-2011 01:11 AM
[SOLVED] getting blacklist.conf Gerwar Linux - General 2 01-06-2011 03:59 PM
modprobe doesn't work; why is modprobe.conf deprecated in slack 12? aquilolumen Slackware 13 08-26-2007 02:05 AM
?Odd bug. modprobe.blacklist~ behaves as modprobe.blacklist arubin Slackware 1 11-05-2006 07:08 PM
modprobe.conf -- not working. RoaCh Of DisCor Suse/Novell 11 07-14-2005 10:39 PM


All times are GMT -5. The time now is 01:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration