-   Slackware (
-   -   /etc/modprobe.d/blacklist.conf not working (

samac 03-30-2013 05:26 PM

/etc/modprobe.d/blacklist.conf not working
Well not completely!

I have blacklisted snd_pcm_oss so that the sound works in youtube videos (flashplayer-plugin).

But it still loads and I have to use rmmod before I can watch any videos.

The odd thing is that the other items that are blacklisted are not loaded, so why is this module not behaving?


PJM 03-30-2013 05:31 PM

Take a look maybe at the /etc/rc.d/rc.alsa file.

GazL 03-30-2013 05:42 PM

When libkmod was introduced the default behaviour of modprobe changed. It now ignores the blacklist unless you specify the "-b" option. rc.alsa hasn't been updated to reflect this yet. I reported it to Pat a while back, so hopefully this will be fixed in current at some point.. In the mean time, just add the -b option to the modprobe commands in your rc.alsa.

samac 03-30-2013 05:46 PM

OK that looks promising, I have edited it, now rebooting.


samac 03-30-2013 05:53 PM

All fixed now, thank you GazL.


All times are GMT -5. The time now is 07:57 AM.