LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-17-2012, 07:00 AM   #1
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: Slackware 14.1
Posts: 393

Rep: Reputation: 30
/etc/fsatb to mount windows7


I think I mistook the installation instructions when I installed slackel. For the option to automatically mount windows partition i entered /fat-c. When I open dolphin it states cannot enter folder /fat-c.

How do I rectify my fat-c issue so that I can mount my windows partition?

this is my etc/fstab

Code:
/dev/sda6        swap             swap        defaults         0   0
/dev/sda8        /                ext4        defaults         1   1
/dev/sda9        /home            ext4        defaults         1   2
/dev/sda3        /fat-c           ntfs-3g     fmask=177,dmask=077 1   0
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,users,rw,umask=00 0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
 
Old 09-17-2012, 07:58 AM   #2
jstg
Member
 
Registered: Apr 2006
Distribution: Slackware
Posts: 35

Rep: Reputation: 21
To mount my XP partition all I have is:

Code:
/dev/sda1  /mnt/xp  ntfs noauto,user,uid=jstg 0 0
But take what I have with a grain of salt or what have you. It works for me, doesn't mean it's right.
 
Old 09-17-2012, 08:10 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,190

Rep: Reputation: Disabled
Quote:
Originally Posted by flebber View Post
I think I mistook the installation instructions when I installed slackel. For the option to automatically mount windows partition i entered /fat-c. When I open dolphin it states cannot enter folder /fat-c.

How do I rectify my fat-c issue so that I can mount my windows partition?

this is my etc/fstab

Code:
/dev/sda6        swap             swap        defaults         0   0
/dev/sda8        /                ext4        defaults         1   1
/dev/sda9        /home            ext4        defaults         1   2
/dev/sda3        /fat-c           ntfs-3g     fmask=177,dmask=077 1   0
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,users,rw,umask=00 0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
Your fmask and dmask will only grant access to /fat-c to the root user. Other users will not have access.
Let me repeat the information which Slackware gives you when you decide what to do with NTFS partitions:

Code:
"fmask=177,dmask=077" "Root has read/write access, users have no access (ntfs-3g)"
"fmask=333,dmask=222" "Everyone has read only access (built-in kernel ntfs driver)"
"fmask=133,dmask=022" "Everyone has read access, but only root can write (ntfs-3g)"
"fmask=111,dmask=000" "All users can read/write to any file (ntfs-3g)"
Also note that Slackel is not Slackware! I have no idea if they have the same installer as Slackware has. Perhaps you never even saw the above information...

Perhaps you should try asking in a Slackel forum next time?

Eric
 
1 members found this post helpful.
Old 09-17-2012, 04:38 PM   #4
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: Slackware 14.1
Posts: 393

Original Poster
Rep: Reputation: 30
I did see this
Quote:
"fmask=177,dmask=077" "Root has read/write access, users have no access (ntfs-3g)"
"fmask=333,dmask=222" "Everyone has read only access (built-in kernel ntfs driver)"
"fmask=133,dmask=022" "Everyone has read access, but only root can write (ntfs-3g)"
"fmask=111,dmask=000" "All users can read/write to any file (ntfs-3g)"
I misread it initially, I have updated it in the fstab and it all works, Thank You.

Slackel uses the slackware installer and is based on Slackware-Current.

Slackel describes itself as from its website.
Quote:
Slackel is a Linux distribution and LiveCD based on Slackware and Salix. It is fully compatible with Slackware and Salix but the difference is that it includes the current version of Slackware and the latest version of KDE in the repository. Thus users of Slackware and Salix can benefit from the Slackel repositories, to use the latest version of KDE.
http://www.salixos.org/forum/viewtopic.php?f=25&t=3495
Quote:
Would you like to have a Slackware-based distro which informs about updates happened to Slackware 'Current' and update your system with one click? In the end you will end up with Slackware stable. The latest Slackel has been synchronized with the Slackware repositories and has become 'rolling-release'.
And from a later response about packages in the above post.
Quote:
Slackel as well Salix repos, do not include a Slackware repository. They include a "ghost" repository that only holds the dependency info and diverts all traffic to a real Slackware repository.
If there are any new packages added or updated in a real slackware repository, the PACKAGES.TXT file is created again with dependency info from those .dep files.
Take a look at http://www.slackel.gr/repo/x86_64/slack ... CKAGES.TXT and http://www.slackel.gr/repo/x86_64/slack ... CKAGES.TXT. All packages of slackware current repository are there.

Last edited by flebber; 09-17-2012 at 04:39 PM.
 
Old 09-18-2012, 11:20 PM   #5
greema
LQ Newbie
 
Registered: May 2007
Posts: 5

Rep: Reputation: 0
You don't have to enter a folder to mount windows partitions at installation time.
You can remove the line about windows from fstab if you did it or comment it
Slackel automatically will mount windows partitions and you can see them from dolphin.
 
Old 09-19-2012, 12:13 AM   #6
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,876
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
You can always unmount or comment out the Windows partition from being mounted at boot.

Code:
Change:
/dev/sda3        /fat-c           ntfs-3g     fmask=177,dmask=077 1   0

To:
#/dev/sda3        /fat-c           ntfs-3g     fmask=177,dmask=077 1   0
Reboot, then edit fstab to display (from my own system settings):

Code:
/dev/sda3        /windows           ntfs-3g     fmask=111,dmask=000 1   0
Before rebooting, check the /fat-c directory and make sure it's empty, then:

Code:
cd /
rm -rf fat-c
mkdir ntfs-c
 
Old 09-19-2012, 12:24 AM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 12,668

Rep: Reputation: 1683Reputation: 1683Reputation: 1683Reputation: 1683Reputation: 1683Reputation: 1683Reputation: 1683Reputation: 1683Reputation: 1683Reputation: 1683Reputation: 1683
a bit odd in the naming
Quote:
/fat-c ntfs-3g
so the FAT folder IS in fact a NTFS partition???????
and NOT a fat32 partition ????
 
Old 09-19-2012, 12:47 AM   #8
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: Slackware 14.1
Posts: 393

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by John VV View Post
a bit odd in the naming

so the FAT folder IS in fact a NTFS partition???????
and NOT a fat32 partition ????
I called it /fat-c only because that's the example given in the installer says that. Changing the fmask and dmask options to this and rebooting sorted it.
Code:
/dev/sda3        /fat-c           ntfs-3g     fmask=111,dmask=000 1   0
 
  


Reply

Tags
slackel, slackware, slackware -current


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] fedora 16 grub1.99 and windows7 siickboii Linux - Laptop and Netbook 30 05-06-2012 08:52 PM
Xbuntu10.04+Windows7 MaGicMaX Linux - Newbie 2 06-24-2010 07:49 PM
no last line on /etc/fsatb gaff_in Red Hat 1 04-08-2008 10:46 PM
Accidentaly deleted fsatb file jychin Linux - Newbie 6 05-11-2006 01:34 AM
The 6th column of "/etc/fsatb"? faezeh Fedora 4 03-22-2005 09:18 AM


All times are GMT -5. The time now is 09:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration