LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-22-2009, 12:14 AM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Rep: Reputation: 519Reputation: 519Reputation: 519Reputation: 519Reputation: 519Reputation: 519
/etc/bluetooth/asound.conf in 12.2


How is /etc/bluetooth/asound.conf regenerated with each reboot?

Why?

Why is /etc/asound.conf forced to a sym link to /etc/bluetooth/asound.conf?
 
Old 08-23-2009, 02:09 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
I wasn't able to recreate either the asound.conf file regenerating in /etc/bluetooth on my 12.2 machine here, but to be fair I made quite a few Bluetooth-related changes on it. I thought it would be a function of BlueZ when it starts up, but that doesn't seem to do it. Are you running any sort of software or scripts that might be attempting to auto-detect BT audio devices?

As for the linking of the asound.conf file, this was sort of a compromise made on Patrick's side. When I submitted the BlueZ scripts to Pat for 12.2, I mentioned that the asound.conf file he was currently putting in /etc/bluetooth was supposed to be going into /etc, so that ALSA could pick up any BT audio devices. I suggested either putting it into /etc where it was intended as a .new, or at least putting a README in /etc/bluetooth explaining what the user would have to do if he wanted Bluetooth audio to work.

Neither of these would have been ideal for a few reasons, so Pat decided to instead just symlink it to the file in /etc/bluetooth in the package's install script. I suppose the idea was that this would work out of the box, rather than having to deal with a .new file on a fresh install.
 
Old 08-23-2009, 02:59 PM   #3
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Original Poster
Rep: Reputation: 519Reputation: 519Reputation: 519Reputation: 519Reputation: 519Reputation: 519
Quote:
Are you running any sort of software or scripts that might be attempting to auto-detect BT audio devices?
None that I am aware. I do not have the bluetooth rc.d script enabled. I saw nothing in the udev rules that would do this.

I seem to recall disabling udev and rebooting. The overwrite did not occur. I also notice no overwriting in Current/13.0.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth headset, Alsa - no soundcard in /proc/asound/cards (but headset works) simopal6 Linux - Hardware 1 04-29-2009 09:07 AM
asound.conf adrsound advanced config phanohanover Linux - Hardware 0 02-06-2009 10:46 AM
asound request north49er Slackware 1 06-10-2007 03:29 AM
Making progs use definitions in asound.conf? tuxedo-notebook Linux - Hardware 4 03-20-2006 02:16 PM
Need help for ALSA Sound /etc/asound.conf or .asoundrc tho_x_tran Linux - Hardware 0 08-09-2004 02:34 PM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration