LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Errors in rc.inet1 for a while now (http://www.linuxquestions.org/questions/slackware-14/errors-in-rc-inet1-for-a-while-now-4175426959/)

schmatzler 09-12-2012 06:31 PM

Errors in rc.inet1 for a while now
 
I'm running Slackware -current for some months now. After some upgrades in the past I got errors at boot:

Code:

/etc/rc.d/rc.inet1: line 54: /sbin/ifconfig: No such file or directory
/etc/rc.d/rc.inet1: line 58: /sbin/route: No such file or directory

I never cared about these messages, since everything is working fine. But now that Slackware is near a new stable release I'm starting to think that this is a problem on my end.

How can I fix these errors?

shadowsnipes 09-12-2012 06:40 PM

That is very strange. Did you try to ls both of the files? Are they there? It's not a profile/path issue since the full path is there. Is your /sbin on a network partition that isn't up when the script it run (not a good idea)?

schmatzler 09-12-2012 06:49 PM

The files were not there so I did some digging and found out, that the net-tools package was not installed.

Strange thing is, that a "slackpkg install-new" did not show that package either. And I don't know how it got removed.

But nevermind - Slack is running without any problem again ;)

ruario 09-13-2012 04:39 AM

Quote:

Originally Posted by schmatzler (Post 4778943)
the net-tools package was not installed.

Strange thing is, that a "slackpkg install-new" did not show that package either. And I don't know how it got removed.

net-tools existed in previous Slackware releases (e.g. 13.37), so it is not a new package. Hence why "slackpkg install-new" wouldn't find it.

Ignoring testing/ and extra/, these are the newly added packages that install-new would offer to those using slackpkg to upgrade their distro:

Code:

wget -qO- http://mirrors.slackware.com/slackware/slackware-current/ChangeLog.txt | grep "Added\.$" | grep -v -e "^testing/" -e "^extra/"
Quote:

Originally Posted by schmatzler (Post 4778943)
And I don't know how it got removed.

Weird, perhaps you used slackpkg to remove something else and your remove command matched part of the net-tools name so was listed as one of the package to remove and you didn't notice it?

shadowsnipes 09-13-2012 09:09 PM

Quote:

Originally Posted by schmatzler (Post 4778943)
The files were not there so I did some digging and found out, that the net-tools package was not installed.

Strange thing is, that a "slackpkg install-new" did not show that package either. And I don't know how it got removed.

But nevermind - Slack is running without any problem again ;)

That'd do it.

Next time you upgrade you might just want to use a loop similar to the one in UPGRADE.TXT instead of using slackpkg. That way you can be sure you aren't missing any packages you might need from the full install. You can still create exceptions in your loop so that you don't install software you don't need...or just removepkg them afterwards.


All times are GMT -5. The time now is 07:55 AM.