LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   errors building kernel 2.6.29-1 in slackware-current about not defined BITS_PER_LONG (http://www.linuxquestions.org/questions/slackware-14/errors-building-kernel-2-6-29-1-in-slackware-current-about-not-defined-bits_per_long-718349/)

leptom 04-10-2009 09:58 PM

errors building kernel 2.6.29-1 in slackware-current about not defined BITS_PER_LONG
 
Hi,
I'm using slackware-current. I follow change log at slackware-current and then update my system. In the last update I changed to the latest kernel (2.6.29-1) and works very well but when I tried to recompile came the problems:

https://gist.github.com/a7bf5fbe1d47eaf3198c

Before I was using kernel 2.6.27.7(compiled by me) because 2.6.28 didn't works with my sound card (but I could compile it too without problems).

I have installed all packages about kernel*.tgz

Any pointer to solve it?

Thanks

NOTE: I wrote a link because there're too much error lines

niels.horn 04-11-2009 08:33 AM

Have you changed anything in the sources, or are you just recompiling with a different CONFIG?

I compiled the 26.6.29.1 kernel w/o problems yesterday.

leptom 04-11-2009 05:57 PM

Quote:

Originally Posted by niels.horn (Post 3505444)
Have you changed anything in the sources, or are you just recompiling with a different CONFIG?

I compiled the 26.6.29.1 kernel w/o problems yesterday.

I tried to recompile with different CONFIG and with the original CONFIG.
I'm afraid that something in my include dir is wrong :-S

niels.horn 04-11-2009 06:39 PM

Quote:

Originally Posted by leptom (Post 3505820)
I'm afraid that something in my include dir is wrong :-S

Surely a possibility. BITS_PER_LONG is set in the include files according to the architecture and HIGHMEM settings if I remember correctly.

I presume - as you compiled kernels before - that you followed the usual steps (there are several guides here on this forum).

Are you compiling from /usr/src/linux or any other path?

leptom 04-11-2009 07:38 PM

Quote:

Originally Posted by niels.horn (Post 3505854)
Surely a possibility. BITS_PER_LONG is set in the include files according to the architecture and HIGHMEM settings if I remember correctly.

I presume - as you compiled kernels before - that you followed the usual steps (there are several guides here on this forum).

Are you compiling from /usr/src/linux or any other path?

I'm compiling from /usr/src/linux.

I do:
- make menuconfig
- modify kernel options
- make and strange error

(the same steps that others times)

I'm dowloading the kernel from kernel.org, I'll tell you.
========================

I removed kernel headers and sources, I reinstalled it again.Now it's working ok!

Thanks for your time Niels

niels.horn 04-11-2009 08:25 PM

Quote:

Originally Posted by leptom (Post 3505892)
I do:
- make menuconfig
- modify kernel options
- make and strange error

Did you do "make mrproper" or "make clean" before these three steps?
- "make clean" cleans most from previous compilations, but leaves the .config file
- "make mrproper" cleans some more, including the .config file (so save it before)

Not sure if this will solve it, but it might be worth a try.

leptom 04-11-2009 08:32 PM

Quote:

Originally Posted by niels.horn (Post 3505908)
Did you do "make mrproper" or "make clean" before these three steps?
- "make clean" cleans most from previous compilations, but leaves the .config file
- "make mrproper" cleans some more, including the .config file (so save it before)

Not sure if this will solve it, but it might be worth a try.

First time I didn't a make clean because It was recently installed. Others I did make clean and make mrproper.

You don't worry about it, removing and reinstalling again kernel sources and headers solved the problem.

Thanks :-)


All times are GMT -5. The time now is 08:30 AM.