Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 12-23-2003, 04:28 PM   #1
Registered: Sep 2003
Location: the ugly southeast
Distribution: Slackware 9.1
Posts: 53

Rep: Reputation: 15
Error with sound after recompiling kernel and adding acpi patch

I patched my kernel with ACPI4linux and following the compile, I boot into kde and I get a sound device failure, saying the sound devicd /dev/dsp doesn't exist. After the recompile the patch still isn't noticed by the system. Where did I go wrong recompiling the kernel. I followed the kernel install guide for newbies. thread.
Old 01-03-2004, 06:07 PM   #2
Registered: Jan 2003
Location: In front of my computer in Oregon, USA
Distribution: Slackware
Posts: 198

Rep: Reputation: 31
It might be that ACPI support is conflicting with your card.
My modem and sound won't work without ACPI support.
I donno.
Old 01-04-2004, 01:19 AM   #3
Registered: Apr 2002
Location: Windsor, ON, CA
Distribution: Ubuntu
Posts: 740

Rep: Reputation: 32
That's kind of weird. Just a thought: Does it work as root? I remember with Slack 7.1 /dev/dsp was only accessable by root, and I got that message and I had to chmod 666 /dev/dsp to get it to work (as it should be too!)
Old 01-04-2004, 05:09 AM   #4
Registered: Nov 2003
Distribution: Slack 10.0 /
Posts: 63

Rep: Reputation: 15
I get the same error everytime I recompile a kernel, it's nothing unusual, it is because the alsa driver and devices no longer exist because after recompiling the kernel you have to rebuild the modules (video, audio, net whatever). The simplest solution is to download the latest alsa (1.0.0rc2 I think) and install it, and don't forget to run the command ./snddevices to add the necesary sound devices to /dev.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting Error After Recompiling Kernel springshades Linux - General 3 05-02-2005 04:21 AM
No sound after recompiling kernel hylke Slackware 7 01-27-2005 05:15 PM
Kernel recompiling error on SuSE 9.1 yuun Linux - Software 2 09-12-2004 10:44 PM
slack9.1: no sound after recompiling kernel carboncopy Slackware 10 11-22-2003 03:46 AM
ACPI patch and kernel compile error crisponions Linux - Laptop and Netbook 3 10-29-2003 06:52 PM

All times are GMT -5. The time now is 10:35 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration