LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-11-2007, 02:59 PM   #1
brooky9999
Member
 
Registered: May 2006
Location: Marlow, UK
Distribution: Slackware 12.2
Posts: 232

Rep: Reputation: 30
Error opening mixer on Slack 10.2 with 2.6.20.2


Hi,

I've recently rebuilt my laptop and now my sound doesn't work. When I add:

Code:
aumix -v 80 -w 80
to rc.local to set the volume, I get:

Code:
aumix: error opening mixer
lspci:

Code:
001:e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
dmesg:

Code:
ALSA device list:
  #0: Intel ICH6 with STAC9750,51 at 0xdfebfe00, irq 16
When I try to run aumix interactively, nothing happens.

The kernel config is exactly the same as before I rebuilt it, and the sound worked then (I took a copy of the .config file).

Have I forgotten to install something / missed something else?



Mark.
 
Old 06-11-2007, 05:47 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
First of all, you do not need to manually load any volume settings from rc.local. Slackware already does that in the boot scripts using ALSA's configuration states. Once you get it setup the way you want, you save the state and then at boot the system will always load it back up.

aumix really has nothing to do with what you want right now. That is just a basic mixer application. You need to run "alsaconf", which probes the system for sound hardware, finds the proper modules, and then configures them to be loaded correctly at boot time.

After that, you can use a mixer (like aumix or alsamixer) and set the volume levels to where you want them. Finally, run "alsactl store" to save that as the default configuration.
 
Old 06-12-2007, 07:15 AM   #3
brooky9999
Member
 
Registered: May 2006
Location: Marlow, UK
Distribution: Slackware 12.2
Posts: 232

Original Poster
Rep: Reputation: 30
Hi ms3fgx,

Thank you for your post.

My bad, I made a mistake. My (despite what I said) kernel wasn't configured correctly, and the OSS sounds and mixer weren't enabled as modules. Once I recompiled my kernel all was well.

Thanks for the tip about aumix / rc.local though :-)


M.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couldn't open mixer device /dev/sound/mixer laurentwahl Linux - General 8 05-17-2005 08:15 PM
Couldn't open mixer device /dev/sound/mixer arctic123 Linux - Newbie 4 09-22-2004 09:39 AM
i ajdust my alsa mixer and every time i reboot my pc the mixer change what to do ? SlackwareMan Linux - Newbie 1 07-30-2004 01:39 AM
couldn't open mixer device /dev/sound/mixer wangcity Linux - General 8 02-01-2004 07:17 AM
Gnome mixer error Bodycount Linux - Software 2 11-29-2003 05:46 PM


All times are GMT -5. The time now is 11:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration