LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-07-2008, 06:40 AM   #1
buf
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Rep: Reputation: 0
Unhappy Error on installing the kernel source (Slackware 12.1)


Well, finally today I started the installation of the new Slack. Since I am not so brave to make an upgrade, I chose to make a clean, fresh installation. But during the installation there were a couple of errors, corrupted packages or bad media, you know how it looks sometimes. One as regarding amarok, the other one emacs and the third one was kernel source. Now I am opening /usr/src and see only one rpm folder and thats all. And I found this coz I wanted to install madwifi. Now I have no idea what to do. How can I install this manually? I am looking at the packages in the DVD but can't find it...
 
Old 05-07-2008, 06:44 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
But during the installation there were a couple of errors, corrupted packages or bad media, you know how it looks sometimes.
Be that as it may, don't make us guess... be specific. If the errors are important enough to mention, quote them.

It sounds like your DVD files are corrupt - I take it you have a working slackware installation?
Personally, I'd reburn the ISO at a slower speed and start again... however, to install a package manually you must first download it and utilise your package manager (I didn't know slackware used rpms...)
 
Old 05-07-2008, 06:50 AM   #3
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
The kernel source package is in the slackware/k directory on the DVD/CD 2/mirrors. You can install packages with either pkgtool or installpkg.

Not exactly sure why you have a directory named "rpm" in /usr/src - the kernel source package doesn't have that directory in it.
 
Old 05-07-2008, 07:07 AM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
When you have errors while installing Slackware, that means your
installation media is corrupt.

Slackware-12.1 has:
Code:
mingdao@silas:~$ ls -l /usr/src/
total 8
lrwxrwxrwx  1 root root   14 2008-05-06 18:54 linux -> linux-2.6.24.5/
drwxr-xr-x 20 root root 4096 2008-05-01 02:13 linux-2.6.24.5/
drwxr-xr-x  7 root root   40 2003-10-29 14:08 rpm/
Indeed it sounds as if your DVD is corrupt. Check it with these commands:
Code:
To check the md5sum of a burned CD/DVD.

echo $(( $(ls -l /path/to/image.iso | awk '{ print $5 }') / 2048 ))
and use the block count with this command below:
dd if=/dev/hda bs=2048 count=2003361 | md5sum
NB: Change hda to your DVD drive, and 2003361 to the number
output by the first command. The DVD should have this as it's md5sum:
Code:
4ce6240a9ebc2ca923af11bb92a34d37  slackware-12.1-install-dvd.iso
Since you did a fresh install to begin with, you're best at this point
just to install it fresh again. Don't leave any of your corruption behind.

You can get a Slackware-12.1 madwifi package from Alien Bob's repository.

In fact, you'd do well to get all the extra packages you can from him.

Last edited by Bruce Hill; 05-07-2008 at 07:11 AM.
 
Old 05-07-2008, 07:11 AM   #5
buf
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Simon Bridge View Post
Be that as it may, don't make us guess... be specific. If the errors are important enough to mention, quote them.
No, not important, just mentioned them. The important error was about the kernel source. And i can't say more than that - corrupt package or bad media.
First time i burnt the dvd, i used K3b. it stayed until copyright in the very beginning adn that was it. After that i used a windows machine to burn a dvd again. maybe ill try again. right now i decided to try again with installing and be sure about the path. now i know it's
Code:
/k/kernel-source-2.6.24.5-smp-noarch-2.tgz
So, İ'm gonna try from there to install and if not, i'll burn a new dvd.
Yes, İ have this rpm folder, later i'll post what exactly it contains.

Last edited by buf; 05-07-2008 at 07:14 AM.
 
Old 05-07-2008, 07:24 AM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
No need to post what the /usr/src/rpm/ directory contains.
All Slackers have it and can ls their own box.

Your media is bad ... plain and simple. You should first
check the md5sum of the iso image you downloaded like this:
Code:
mingdao@silas:/server2/ftp/pub/Linux/Slackware/slackware-12.1-iso$ md5sum slackware-12.1-install-dvd.iso
4ce6240a9ebc2ca923af11bb92a34d37  slackware-12.1-install-dvd.iso
If it's good, burn a DVD and check it's md5sum. When you get
a good DVD, then and only then, do your reinstall. You do
not know for certain what all is bad. And all the errors
are important, not just the one about the kernel source.
 
Old 05-07-2008, 07:42 AM   #7
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Check your download md5sum before burning then..

When using K3B to burn discs I always select "verify written data" in the Settings dialogue. This will test read the burnt disc and compare the md5 sum with that calculated from the image file. You should also compare this with the published md5sum from the image source (mirror site). That way you know your download was OK and your burn is ok.

It's surprising how many times this fails for me. Oddly enough Roxio under Windows gives me much better results but that may be just my hardware.

Attempting to install with bad media is madness and will lead to hours of frustration.

Obviously I'd use Bruce's check before burning the disc to save wasting discs but checking K3B's sum with the source sum from the mirror is a double check of this. It also, as stated, checks the burn process. May as well take advantage of any information to hand.
 
Old 05-07-2008, 08:11 AM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Just a heads up ... what K3B checks is the md5sum of the ISO image.
So K3B could burn a good DVD of a corrupt ISO image.

You need, as bgeddy said, to get the official MD5SUM from Slackware
and check your ISO against it.
 
Old 05-07-2008, 08:16 AM   #9
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,190

Rep: Reputation: 547Reputation: 547Reputation: 547Reputation: 547Reputation: 547Reputation: 547
Agreed. Verify that you have an error-free ISO and then burn a new installation DVD. You shouldn't get errors like that on a clean install. Don't waste your time.
Start over.

Last edited by hitest; 05-07-2008 at 08:18 AM.
 
Old 05-07-2008, 08:25 AM   #10
buf
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
The image is fine, checked the md5sum. But something is wrong with my DVDs. 4 I already tried, 4 giving errors. K3B gave error on verifications, as well as Nero. Since I really doesn't like Nero, I guess I'll try once again with Ashampoo. If not...I'll have to buy new empty DVDs anyway.
 
Old 05-07-2008, 08:28 AM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Hey, burn like a man ... use the CLI.
Code:
growisofs -dvd-compat -Z /dev/hdc=slackware-12.1-install-dvd.iso
Replace /dev/hdc with your DVD burner. You could also post the
output from the K3B bad burn ...
 
Old 05-07-2008, 09:33 AM   #12
buf
LQ Newbie
 
Registered: Apr 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Installed like a man and succeeded! Fresh and new installation now! Thanks you guys!

Last edited by buf; 05-07-2008 at 10:00 AM.
 
Old 05-07-2008, 09:38 AM   #13
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Spot on! Glad you got it working!
 
Old 05-07-2008, 09:57 AM   #14
symatic
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 242

Rep: Reputation: 32
Just on a side note. If you buy garbage media(not saying you did), lower the burn speed and it should work with k3b. But being a man works more often I have seen.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get kernel-source is installing the wrong kernel source. JordanH Ubuntu 10 07-08-2005 05:42 PM
apt error, messed up after tried installing kernel-source-2.6.8 microsoft/linux Debian 1 06-17-2005 12:38 AM
Error installing nVidia-driver-missing kernel-source? anemic Debian 6 12-17-2004 11:52 AM
Kernel source error installing OSS inca88 Linux - Software 1 08-10-2004 06:20 PM
slackware kernel source install (kernel 2.6.6) ? LinuxOG Slackware 22 06-06-2004 04:34 PM


All times are GMT -5. The time now is 03:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration