LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-30-2012, 05:22 PM   #1
mariner53
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Rep: Reputation: 0
Error in "make gconfig" while trying to add Net Adapter drive


I recently bought a D-Link DQE-530T network adapter as the onboard adapter failed. I downloaded the latest linux drive from the D-Link site and followed the instructions to create a patch to add the driver module to the Kernel. I am running Slackware 13.37 with the 2.6.37.6-SMP kernel. When I run "make gconfig" to add the module I get the following error:

bash-4.1# make gconfig
scripts/kconfig/gconf Kconfig
drivers/net/Kconfig:3764: file 'drivers/net/arcnet/Kconfig' is already sourced from 'drivers/net/Kconfig'
make[1]: *** [gconfig] Error 1
make: *** [gconfig] Error 2

I get the same error with menuconfig and xconfig.

I would appreciate any help with letting me know what I am doing wrong.

Thanks
 
Old 01-30-2012, 06:13 PM   #2
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
You don't need to patch the kernel, the skge module that works with your card is already in config

Undo the patch or reinstall the source, then enable it (as module)
Network Device Support > Ethernet (1000 Mbit) > New SysKonnect GigaEthernet support (SKGE)

But I am sure it was enabled as default in stock slackware kernel

(edit)
Yes it was
Code:
grep -i skge /boot/config-generic-smp-2.6.37.6-smp
CONFIG_SKGE=m
# CONFIG_SKGE_DEBUG is not set
So your card should be recognised automagically at boot

try /sbin/lsmod
see if skge module is loaded

Last edited by Cedrik; 01-30-2012 at 06:24 PM.
 
Old 01-30-2012, 10:54 PM   #3
mariner53
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Cedrik, thanks for the input I kept looking for a module named SK98LIN, which the D-Link info referred to, not the skge.

The module is loading now, but I don't seem to have any eth devices so it is not binding to anything. I reran netconfig and it worked ok. But when I run "ifconfig eth0" it tells me no such device exists. Same with running "ethtool eth0"

Everything was working OK till we lost power last night an the onboard lan connection blew out. But, I would think I should still find an eth entry in the /root/dev directory.

Thanks
 
Old 01-31-2012, 04:16 AM   #4
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Maybe it is eth1 (as you have onboard LAN)
(use dmesg to figure out, you could also disable onboard LAN in bios I think)
 
Old 01-31-2012, 10:37 AM   #5
mariner53
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Cedrik, I turned the onboard lan off via the Bios as soon as I found out it was shorted out. I looked at dmesg to see it it had anything:

bash-4.1# dmesg |grep eth
bash-4.1#

I also ran lspci

bash-4.1# lspci
03:02.0 Ethernet controller: D-Link System Inc Device 4302 (rev 10)
03:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)

The readme in the linux directory on the CD that came with the adapter reads:
This is the Linux device driver released for RealTek Ethernet controllers, which are listed as following.
1. RTL8169S/SB/SC (Gigabit Ethernet with PCI interface)
2. RTL8168B (Gigabit Ethernet with PCI-Express interface)
3. RTL8101E (Fast Ethernet with PCI-Express interface)

And says to unpack the enclosed tarball. The problem was that there was no tarball to unpack or the necessary files to create a module.
When I called D-Link support they pointed me to their website from which I downloaded a tarball that says it is for the SK98LIN (skge) adapter.

There is an R8169 entry in config-generic-smp-2.6.27.6-smp;
CONFIG_R8169=m
CONFIG_R8169_VLAN=y
but modprobe will not load it.
bash-4.1# modprobe R8169
FATAL: Module R8169 not found.

So I am not sure of the next step from here.

Thanks
 
Old 01-31-2012, 11:26 AM   #6
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Weird, I checked make xconfig in my kernel source and it said skge is the module for this card
(my netcard use this module as well, mine is onboard Marvell Technology)
You can see module suggested in lspci with -k option
Code:
/sbin/lspci -k
Now if you want to test with R8169 module, try:

unload skge module if it is loaded (check /sbin/lsmod)
Code:
/sbin/rmmod skge
load r8169
Code:
/sbin/modprobe r8169

But modprobe it should have been handled by udev at boot...

Maybe there is conflict with skge module, blacklist it could help
Code:
echo "skge" >> /etc/modprobe.d/blacklist.conf

Last edited by Cedrik; 01-31-2012 at 11:33 AM.
 
Old 01-31-2012, 01:05 PM   #7
mariner53
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
lspci -k didn't give anything

bash-4.1# lspci -k
02:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
Subsystem: Giga-byte Technology Device b000
Kernel driver in use: pata_jmicron
03:02.0 Ethernet controller: D-Link System Inc Device 4302 (rev 10)
Subsystem: D-Link System Inc Device 4302
03:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
Kernel driver in use: firewire_ohci
Kernel modules: firewire-ohci

so I ran lspci -vvv to get everything I could.

bash-4.1# lspci -vvv
03:02.0 Ethernet controller: D-Link System Inc Device 4302 (rev 10)
Subsystem: D-Link System Inc Device 4302
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64 (8000ns min, 16000ns max), Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 12
Region 0: I/O ports at de00 [size=256]
Region 1: Memory at fbeff000 (32-bit, non-prefetchable) [size=256]
[virtual] Expansion ROM at d8200000 [disabled] [size=128K]
Capabilities: [dc] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
 
Old 01-31-2012, 01:37 PM   #8
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Did you try to modprobe r8169 ? (and unload skge before) ?
 
Old 01-31-2012, 03:56 PM   #9
mariner53
LQ Newbie
 
Registered: Mar 2008
Posts: 12

Original Poster
Rep: Reputation: 0
Yep I unload skge and loaded r8169, but still no joy in Mudville.

lspci -k still does not show any info and the is no eth# anywhere.

And I am still having the issue with the "make gconfig" that I had to start this thread.
 
Old 01-31-2012, 04:06 PM   #10
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Did you try a netconfig after loading the r8169 module ?

Forget about the kernel config issue, it is probably caused by incompatible patch with kernel source

The modules for netcard are already compiled and installed
 
Old 01-31-2012, 04:13 PM   #11
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
FWIW, there is a linuxquestion HCL entry for this card
http://www.linuxquestions.org/hcl/sh...p?product=2711

It seems the skge module is the one to use with 2.6 kernel...
There are mixed reviews

One suggest to use a modproble alias for skge

You could try that
Code:
echo "alias eth0 skge" > /etc/modprobe.d/netcard.conf
Then try to load the skge module again
Code:
/sbin/modprobe skge
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does "make gconfig" work for you? I get GTK Critical errors. rivercat Linux - Kernel 3 12-19-2011 01:56 PM
LFS6.3 - Ch5.4.1 "/bin/sh sort not found" error at "make bootstrap" ubyt3m3 Linux From Scratch 2 06-23-2008 12:09 AM
upgrade to kernel 2.6.16.1 : "make bzImage" print "parse error" math_physics Red Hat 2 06-29-2007 11:04 PM
a error happen when "make install" a drive zhenguohui Linux - Wireless Networking 1 04-20-2006 08:07 AM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 03:31 PM


All times are GMT -5. The time now is 12:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration