LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-25-2003, 10:57 AM   #1
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Rep: Reputation: 21
Error Couldn't open mixer device....


When opening Gnome I get this error...
---------------------------------------------------------------
Couldn't open mixer device /dev/sound/mixer
---------------------------------------------------------------
This box has no sound card.

How can I stop this error?
Running Slack 9
 
Old 05-25-2003, 01:41 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Try:

chmod 666 /dev/sound/mixer*
 
Old 05-25-2003, 01:56 PM   #3
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
There is no /dev/sound/mixer.........???
 
Old 05-26-2003, 01:35 PM   #4
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
Any ideas on which config file may be responsible for loading this device?
 
Old 07-09-2003, 03:08 PM   #5
LunarBeam
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
Try removing the Volume Control applet from your panel, if it's there.
 
Old 07-09-2003, 03:25 PM   #6
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
You can always disable sound from the control center too I think (I'm not too familiar with GNOME)..ie: turn off sound events and such...
 
Old 07-10-2003, 01:42 AM   #7
scottwest2
Member
 
Registered: Jun 2003
Distribution: Mac OS X 10.5.7, Athlon 64 X2 4200+, 2GB Ram, nVidia GeForce 9400 GT 1GB --- Ubuntu 9.04 Jaunty x64
Posts: 58

Rep: Reputation: 16
do what tcaptain said by disabling the sound server
 
Old 07-10-2003, 09:11 PM   #8
bunhead
LQ Newbie
 
Registered: Jun 2003
Location: Toronto, Canada
Distribution: slackware
Posts: 20

Rep: Reputation: 0
Is there a sound card installed?

Do you have a sound card installed in this machine? If not then just point the /dev/mixer to /dev/null

BTW I don't have a /dev/sound directory at all. You may want to check your sound path under gnome. I don't know where that is I don't use gnome
 
Old 07-10-2003, 11:09 PM   #9
ceh383
Member
 
Registered: May 2003
Location: The Left coast, USA
Distribution: Slackware_64 13.37
Posts: 183

Original Poster
Rep: Reputation: 21
I didn't have a sound card installed. The only way I found to fix this was to install one.......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couldn't open mixer device /dev/sound/mixer laurentwahl Linux - General 8 05-17-2005 09:15 PM
couldn't open mixer device /dev/sound/mixer pitts68 Linux - Newbie 4 11-15-2004 09:03 AM
Couldn't open mixer device /dev/sound/mixer arctic123 Linux - Newbie 4 09-22-2004 10:39 AM
couldn't open mixer device /dev/sound/mixer wangcity Linux - General 8 02-01-2004 08:17 AM
Couldn't open mixer device /dev/sound/mixer Dabria Linux - Hardware 2 07-29-2003 12:50 PM


All times are GMT -5. The time now is 01:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration