LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Error compiling barry with desktop gui (http://www.linuxquestions.org/questions/slackware-14/error-compiling-barry-with-desktop-gui-4175494459/)

vdemuth 02-10-2014 02:46 PM

Error compiling barry with desktop gui
 
Hi all. So trying to compile Barry with the desktop gui enabled and getting the error below.

My Google fu is failing me as I can't find a link anywhere to libxml++-2.6.

Anyone got a link or package that meets this requirement?




Code:

checking for BARRY... yes
checking for GLIB2... yes
checking for LIBXMLPP... no
configure: error: Package requirements (libxml++-2.6) were not met:

No package 'libxml++-2.6' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.


55020 02-10-2014 03:24 PM

Well, er, how about this? http://slackbuilds.org/repository/14.../libxml%2B%2B/ ... not forgetting the listed deps ;)

If for some reason that's too new for the package you are building, work backwards through the versions here:
http://ftp.gnome.org/pub/GNOME/sources/libxml++/

vdemuth 02-10-2014 03:52 PM

Erm, how is that libxml++-2.6

Quote:

SlackBuilds Repository
14.1 > Libraries > libxml++ (2.36.0)

libxml++ is a C++ wrapper for the libxml XML parser library. Its original
author is Ari Johnson and it is currently maintained by Christophe de
Vienne and Murray Cumming. It is released under the LGPL version 2 or
above.


Oh hang on. Ignore me. having a bad night. Sometimes I just forget the crazy numbering system Linux uses where larger numbers are smaller than smaller numbers and vice versa

Thanks for the pointer. Told you my Google fu had failed :(


All times are GMT -5. The time now is 02:53 AM.