LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Epson WP-4015 installation on Slackware 14.1 (http://www.linuxquestions.org/questions/slackware-14/epson-wp-4015-installation-on-slackware-14-1-a-4175493450/)

aloisius-a 02-02-2014 11:36 AM

Epson WP-4015 installation on Slackware 14.1
 
Hi guys,
Recently I installed Slackware 14.1 and now I am trying to install an Epson WP-4015 network printer.
I downloaded from the Epson site the relative full feature driver (epson-inkjet-printer-201113w-1.0.2-1lsb.3.2i486.rpm) an converted it into a Slackware package with the utility rpm2targz.
Subsequently I detarred the package obtaining a folder, named opt, which contains the folder epson-inkjet-printer-201113w, that I copied into the /opt folder.
Then, using CUPS, I installed the printer with its ppd file but, when I try the command “Print test page”, nothing is printed and I obtain the answer:
“/opt/epson-inkjet-printer-201113w/cups/lib/filter/epson_inkjet_printer_filter failed”.

I have to put in evidence that, following cups help I defined as permissions for the previous file.
I don't understand the problem and any help will be welcomed.

ljb643 02-02-2014 04:11 PM

You could try enabling CUPS debug so you get more information in your log file. But first, try running the filter from the shell command line, no arguments, as a regular user:
Code:

$ /opt/epson-inkjet-printer-201113w/cups/lib/filter/epson_inkjet_printer_filter
You should get back a message like "Insufficient arguments". However, I suspect you will get something else, such as "no such file or directory" (even though you type it correctly). This indicates the loader isn't there, and is a known issue with this Epson driver.

If so, try this as root:
Code:

# ln -s ld-linux.so.2 /lib/ld-lsb.so.3
And try running the filter again.

aloisius-a 02-03-2014 01:20 PM

I tried to run the filter from the shell command line and, as you suspected, got the response “no such file or directory”.
Then I created the symbolic link with the command
# ln -s ld-linux.so.2 /lib/ld-lsb.so.3
and tried running the filter again. This manner I obtained the response
“The printer URI is incorrect or no longer exists”

I tried also to ping the printer and saw the printer replies.
I also run the CUPS command
# lpstat -p -d
and got the reply
printer Home_WP-4015 disabled since Mon 03 Feb 2014 07:25:21 PM CET -
The printer URI is incorrect or no longer exists.
no system default destination

ljb643 02-03-2014 04:41 PM

OK, progress (although I can't see how it is possible to get that message "printer URI is incorrect or no longer exists" message from running the filter with no command arguments).

How is the printer connected? Sounds like wired network, and ping works. Good. (I can't find WP-4015 at epson.com so I'm not sure what that can do.)

What is the CUPS printer URI (which it is complaining about above)? You can get this from the CUPS web interface (Printers, printer name, Connection: ...), or use this command:

Code:

$ lpstat -v Home_WP-4015

aloisius-a 02-04-2014 09:49 AM

Hi,
your advice was good because I found there was an error in the DNS, so the address resolution was not correct.
I fixed this problem and all things go well.
Thank you

ljb643 02-04-2014 07:22 PM

You're welcome. By the way, if your printer has a static IP address (which is highly recommended), you might consider using its IP address rather than its hostname in your CUPS printer URI. It removes DNS as a possible point of failure for printing.


All times are GMT -5. The time now is 06:27 AM.