LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Entering passphrase on LUKS partition with USB (http://www.linuxquestions.org/questions/slackware-14/entering-passphrase-on-luks-partition-with-usb-716650/)

brooky9999 04-03-2009 03:18 PM

Entering passphrase on LUKS partition with USB
 
I've encrypted my root partition using LUKS.

I've built my initrd and added support for ext3 and USB for my keyboard and mouse, using the following command:

Code:

mkinitrd -k 2.6.29 -m ext3:ehci_hcd:uhci_hcd:usbhid -f ext3 -r /dev/cryptvg/root -C /dev/hda2 -L
Immediately after coming up with the prompt for entering the LUKS passphrase, I get the output for having found the USB mouse and keyboard. This makes a mess of the prompt.

I can still enter the password and the partition unlocks and boots perfectly.

I know this is more of a cosmetic problem, but it would be nice if someone knew the answer.

Any help appreciated,


Mark.

GazL 04-03-2009 03:30 PM

maybe you could add a short sleep to the init script in /boot/initrd-tree prior to the call to cryptsetup to allow your modules time to initialise. Once you've made your customisations you just have to re-run mkinitrd without any parameters and it'll rebuild the initrd.gz from the modified initrd-tree.

brooky9999 04-08-2009 03:14 AM

Hi GazL,

Would this be a case of adding something like:

Code:

sleep 10
to /boot/initrd-tree/init before re-running mkinitrd?

If so, whereabouts in the file should I add it?

Many thanks,


M.

GazL 04-08-2009 04:31 AM

Yep, that's what I was getting at. The cryptsetup command is what't used to unlock the luks devices, so if you search for that and put your sleep on the line before it, hopefully that should do the trick.

Remember not to specify any options on the mkinitrd when you re-run it for the second time, or it may end up rebuilding your /boot/initrd-tree again and undoing your changes. I'd also suggest that whenever your playing with the initrd you make a copy of your old initrd.gz file and have a second lilo entry pointing to it, just incase you make a mistake with your edit and your new initrd.gz becomes unbootable.

Normally, I'd be a little more helpful and provide you with an example, but I've just bought a new PC and I haven't got around to putting Slack on it yet and transfering my old system across. (I'm using Vista and Opera at the moment, and actually finding it isn't half as bad as people make out... I think I've lost my inner-penguin!)

brooky9999 04-09-2009 02:29 AM

Hi GazL,

After a bit of trial and error, we have success.

In /boot/initrd-tree/init I entered:

Code:

sleep 5
between:

Code:

# Load a custom keyboard mapping:
if [ -n "$KEYMAP" ]; then
  echo "${INITRD}:  Loading '$KEYMAP' keyboard mapping:"
  tar xzOf /etc/keymaps.tar.gz ${KEYMAP}.bmap | loadkmap
fi

and:

Code:

if [ "$RESCUE" = "" ]; then
  # Initialize RAID:
  if [ -x /sbin/mdadm ]; then
    /sbin/mdadm -E -s >/etc/mdadm.conf
    /sbin/mdadm -A -s
  fi

Many thanks for your help,


M.

Ilgar 04-09-2009 03:37 AM

I also experience the same thing, but it changes every time I compile a new kernel. Nowadays the prompt doesn't get messed up, who knows what will happen next time :).

GazL 04-09-2009 04:11 AM

Quote:

Originally Posted by brooky9999 (Post 3503242)
Many thanks for your help,
M.

You're welcome. I'm glad you got it sorted.

This sounds like a change that the Slackware Devs really ought to incorporate into the stock build. Anyone with a USB keyboard who chooses to use LUKS is likely to encounter this same issue.

brooky9999 04-09-2009 04:22 AM

Yeah thanks, I'll take a look at them.

Take it easy,


M.


All times are GMT -5. The time now is 11:21 PM.