LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2013, 01:09 AM   #1
ecoslacker
LQ Newbie
 
Registered: Feb 2011
Location: Mexico
Distribution: Slackware
Posts: 17

Rep: Reputation: 0
Unhappy Enabling resume from hibernation in Slackware on a laptop with Ubuntu and Windows 8


A few weeks ago I bought an Asus X401A laptop with Windows 8 and installed Ubuntu 12.10 (64 bits) on it as dual boot. When I get bored I installed Slackware 14.0 (64 bits) by following the instructions on http://docs.slackware.com/howtos:sla..._uefi_hardware (using a USB bootdisk).
At finish I created a elilo.conf an put this code on it:

Code:
# cat /mnt/sda1/EFI/slackware/elilo.conf 
prompt
timeout=50
default=huge

image=bzImage
  label=huge
  read-only
  root=/dev/sda10
Reboot and the system was still using GRUB (so noob to know why), I think elilo is not being used but I'm not even sure of that. Just enter to Ubuntu and run "boot-repair" and now I'm using grub to select my OS at starting.

All works fine now but I want to enable resume from hibernation on Slackware and can't figure out how to do it. I used LILO before and I like it, and never use GRUB before.

So, do I need to configure GRUB or elilo?

I use Slackware as my main distribution and I need a little Windows at work, so I don't care about Ubuntu and grub if they need to be removed.

This is my EFI partition:

Code:
# tree /mnt/sda1/EFI/
/mnt/sda1/EFI/
|-- ASUS
|   |-- BCD.LOG
|   |-- BCD.LOG1
|   |-- BCD.LOG2
|   |-- X301A.BIN
|   |-- X301A1.BIN
|   |-- X401A.BIN
|   |-- X401A1.BIN
|   |-- X501A.BIN
|   |-- X501A1.BIN
|   |-- bcd
|   |-- bcd_backup
|   |-- en-US
|   |   |-- ASBOOT.tag
|   |   |-- ASBOOT.tag.LOG
|   |   |-- ASBOOT.tag.LOG1
|   |   `-- ASBOOT.tag.LOG2
|   |-- es-ES
|   |   |-- ASBOOT.tag
|   |   |-- ASBOOT.tag.LOG
|   |   |-- ASBOOT.tag.LOG1
|   |   `-- ASBOOT.tag.LOG2
|   |-- pt-BR
|   |   |-- ASBOOT.tag
|   |   |-- ASBOOT.tag.LOG
|   |   |-- ASBOOT.tag.LOG1
|   |   `-- ASBOOT.tag.LOG2
|   `-- pt-PT
|       |-- ASBOOT.tag
|       |-- ASBOOT.tag.LOG
|       |-- ASBOOT.tag.LOG1
|       `-- ASBOOT.tag.LOG2
|-- Boot
|   |-- bkpbootx64.efi
|   `-- bootx64.efi
|-- Microsoft
|   `-- Boot
|       |-- BCD
|       |-- BCD.LOG
|       |-- BCD.LOG1
|       |-- BCD.LOG2
|       |-- BOOTSTAT.DAT
|       |-- Fonts
|       |   |-- chs_boot.ttf
|       |   |-- cht_boot.ttf
|       |   |-- jpn_boot.ttf
|       |   |-- kor_boot.ttf
|       |   |-- malgun_boot.ttf
|       |   |-- malgunn_boot.ttf
|       |   |-- meiryo_boot.ttf
|       |   |-- meiryon_boot.ttf
|       |   |-- msjh_boot.ttf
|       |   |-- msjhn_boot.ttf
|       |   |-- msyh_boot.ttf
|       |   |-- msyhn_boot.ttf
|       |   |-- segmono_boot.ttf
|       |   |-- segoe_slboot.ttf
|       |   |-- segoen_slboot.ttf
|       |   `-- wgl4_boot.ttf
|       |-- Resources
|       |   |-- bootres.dll
|       |   |-- en-US
|       |   |   `-- bootres.dll.mui
|       |   |-- es-ES
|       |   |   `-- bootres.dll.mui
|       |   |-- pt-BR
|       |   |   `-- bootres.dll.mui
|       |   `-- pt-PT
|       |       `-- bootres.dll.mui
|       |-- bg-BG
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- bkpbootmgfw.efi
|       |-- boot.stl
|       |-- bootmgfw.efi
|       |-- bootmgr.efi
|       |-- bootx64.efi
|       |-- bootx64.efi.grb
|       |-- cs-CZ
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- da-DK
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- de-DE
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- el-GR
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- en-GB
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- en-US
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- es-ES
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- et-EE
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- fi-FI
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- fr-FR
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- hr-HR
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- hu-HU
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- it-IT
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- ja-JP
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- ko-KR
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- lt-LT
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- lv-LV
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- memtest.efi
|       |-- nb-NO
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- nl-NL
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- pl-PL
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- pt-BR
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- pt-PT
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- qps-ploc
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- ro-RO
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- ru-RU
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- sk-SK
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- sl-SI
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- sr-Latn-CS
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- sv-SE
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- tr-TR
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- uk-UA
|       |   |-- bootmgfw.efi.mui
|       |   `-- bootmgr.efi.mui
|       |-- zh-CN
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       |-- zh-HK
|       |   |-- bootmgfw.efi.mui
|       |   |-- bootmgr.efi.mui
|       |   `-- memtest.efi.mui
|       `-- zh-TW
|           |-- bootmgfw.efi.mui
|           |-- bootmgr.efi.mui
|           `-- memtest.efi.mui
|-- slackware
|   |-- BOOTX64.EFI
|   |-- bzImage
|   |-- elilo.conf
|   `-- initrd.img
`-- ubuntu
    `-- grubx64.efi
Thanks!
 
Old 04-30-2013, 03:30 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
Usually all you have to do is to add an option to the kernel command line in your boot-loader's config file:
Code:
resume=/path/to/your/swap-partition
Since you boot with Grub you have to add it in Grub's config file, but it will be overwritten the next time Ubuntu thinks it has to update the boot-loader configuration. It is possible to make that persistent with writing a script for Grub, but I have next to no knowledge about grub 2, so I would recommend to look into the documentation how to do that.
 
Old 05-04-2013, 02:05 AM   #3
ecoslacker
LQ Newbie
 
Registered: Feb 2011
Location: Mexico
Distribution: Slackware
Posts: 17

Original Poster
Rep: Reputation: 0
I started in Ubuntu and edited this file:

Code:
sudo nano /etc/default/grub
Put this line:

Code:
GRUB_CMDLINE_LINUX="resume=/dev/sda9"
Where sda9 is my swap partition. Next run this:

Code:
sudo grub-mkconfig -o /boot/grub/grub.cfg
Edit /boot/grub/grub.cfg and put this in the slackware menu entry:

Code:
linux /boot/vmlinuz root=/dev/sda10 resume=/dev/sda9 quiet
It works and now I can resume from hibernation. sda10 is my Slackware root partition. I now this configuration is not permanent but I'm ok with that.
 
  


Reply

Tags
grub, hibernation, slackware, ubuntu, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Measure the time it takes to resume after hibernation linkaran Linux - General 3 03-10-2013 08:48 AM
Network Can't be reloaded after resume from hibernation snowweb Linux - Networking 2 09-16-2012 09:53 PM
Ubuntu 11.10 - problems with hibernation, resume from it firekage Ubuntu 2 05-27-2012 04:38 AM
File to wakeup the system for hibernation like resume.sh ?? sanketdangi Ubuntu 3 01-16-2010 11:25 AM
[SOLVED] Suspend/Hibernation resume problems with ATI graphics card. defensorfedei Linux - Laptop and Netbook 5 10-13-2009 03:14 AM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration