LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-03-2007, 12:48 AM   #1
Nem
Member
 
Registered: Mar 2007
Location: United States
Distribution: Slackware 11.0
Posts: 88

Rep: Reputation: 15
Enabling DRI on Radeon Linux Driver. ati radeon 9200


Hi all,
I'm currently am trying to get dri enabled on
my ati radeon 9200 card.I had dri enabled when I used the 8.28.8 driver from ati for the card,but I'm sick of the driver because of crashing, being unstable,and unable to play urban terror still.I had this same question a while ago on enabling dri,but I only enabled dri with the ATI Proprietary Linux x86 Display Driver.

link here:http://www.linuxquestions.org/questi...ule+dri+-found

I uncommented the line:

Load "dri"

in xorg.conf and restarted X but the system locks
up and the screen is black, so I have to reboot.
I ran modprobe on dri and this is what I get.

Code:
# modprobe dri
FATAL: Module dri not found.
This is my /var/log/Xorg.0.log
Link:http://pastebin.ca/532576

The log was so long I had to post it in pastebin!

I don't know,
I tried googling on dri on radeon and didn't have
much luck finding info on enabling it.
Am I screwed? I would get a nvidia card, but not on this box I got. I do have a onboard intel 865 chipset
video card in my box, and I thought maybe if I try remove the ati card, start the pc, run xorgconfig
and set the i801 driver and enable dri. Who knows
maybe I could get more FPS than the ati card! I could
only get 244 FPS with the radeon driver currently.
Can you toss me some ideas, or should I just
try rather invest in a nvida video card?

Thanks,
Nem
 
Old 06-03-2007, 07:44 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Use the 8.36.5 driver from Ati then configure your xorg.conf file, here is a sample to use as an example;

Code:
Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Synaptics" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
	Load  "dri"
	Load  "extmod"
	Load  "glx"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "off"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

 ### Comment all HorizSync and VertSync values to use DDC:
	Identifier   "Monitor0"
	ModelName    "LCD Panel 1280x800"
	HorizSync    31.5 - 90.0
	VertRefresh  59.9 - 60.1
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "fglrx"
	Option	    "Centermode" "off"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x800" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection

Section "Extensions"
	Option	    "Composite" "False"
EndSection
Take notice of the "AIGLX" and the "Extensions" sections.
 
Old 06-03-2007, 01:28 PM   #3
jmcustiel
LQ Newbie
 
Registered: Jun 2007
Location: Montevideo, Uruguay
Distribution: Slackware 11.0
Posts: 12

Rep: Reputation: 0
I don't use the driver form ati, i actually do this (SLACKWARE 11.0):

First: load the radeon module in /etc/rc.d/rc.modules.
this enables agpgart and drm.

Second: edit /etc/X11/xorg.conf, use radeon driver in device section , and load DRI in modules section.

Third: startx.
 
Old 06-03-2007, 01:50 PM   #4
Road_map
Member
 
Registered: Jan 2007
Distribution: Slackware
Posts: 341

Rep: Reputation: 31
Quote:
Originally Posted by Lenard
Use the 8.36.5 driver from Ati ...
ATI Proprietary Linux x86 Display Driver 8.28.8 is the last version who support ATI Radeon 9200 card. See http://ati.amd.com/support/drivers/l...ous-linux.html
 
Old 06-03-2007, 03:01 PM   #5
Nem
Member
 
Registered: Mar 2007
Location: United States
Distribution: Slackware 11.0
Posts: 88

Original Poster
Rep: Reputation: 15
The problem guys,
is I'm trying to get dri working with the radeon linux driver.Not the ATI Proprietary Linux x86 Display Driver.

Lenard: I tried the the "AIGLX" and the "Extensions" sections before with the 8.28.8
driver and it didn't help getting the driver to work better.

jmcustiel: I already tried that too and I just get
a locked up machine and a black screen.

I'm just sick of the ATI Proprietary Linux x86 Display Driver,and just want to get dri enabled with
the radeon linux driver.Maybe then the video card
might work better and I could play urban terror!
 
Old 06-03-2007, 05:23 PM   #6
jmcustiel
LQ Newbie
 
Registered: Jun 2007
Location: Montevideo, Uruguay
Distribution: Slackware 11.0
Posts: 12

Rep: Reputation: 0
You have a strange problem, try uninstalling the ati driver and then load the linux drivers: first modprobe radeon to enable drm, then load dri in xorg.conf.

The Ati driver didn't work for me, i uninstalled it and tried with linux driver and it works fine, i have an asus A9250+ with ati radeon 9250 chipset.

Good luck!
 
Old 06-03-2007, 09:05 PM   #7
Nem
Member
 
Registered: Mar 2007
Location: United States
Distribution: Slackware 11.0
Posts: 88

Original Poster
Rep: Reputation: 15
This is really weird.
I uninstalled the proprietary ati driver and
ran modprobe radeon , but I get this error.
Code:
# modprobe radeon
WARNING: Error inserting drm (/lib/modules/2.6.17.13/kernel/drivers/char/drm/drm.ko): Cannot allocate memory
FATAL: Error inserting radeon (/lib/modules/2.6.17.13/kernel/drivers/char/drm/radeon.ko): Unknown symbol in module, or unknown parameter (see dmesg)
I can set the radeon driver by running xorgconfig
but I just can't get dri enabled.
I have all the modules installed for my kernel
and source for the kernel so thats not the problem.
 
Old 06-03-2007, 09:46 PM   #8
ubergeek42
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware 11
Posts: 17

Rep: Reputation: 0
Did you compile your own kernel? I don't know what exactly is wrong with your configuration, but I can offer up my settings, maybe they will help.

Note:I have dual monitors, but just look at the relevant information.
Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" LeftOf "Screen0"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	ModulePath   "/usr/X11R6/lib/modules"
	FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
	FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
	FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
	FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
	FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
	FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
	Load  "glx"
	Load  "extmod"
	Load  "xtrap"
	Load  "record"
	Load  "dbe"
	Load  "dri"
	Load  "freetype"
	Load  "type1"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option       "XkbModel"  "pc104"
	Option       "XkbLayout"  "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "ExplorerPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	HorizSync   48.38
	VertRefresh 60.0
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "VSC"
	ModelName    "PF815"
	HorizSync    30.0 - 117.0
	VertRefresh  50.0 - 180.0
	Option	    "DPMS"
EndSection

Section "Device"
	Identifier  "Card0"
	Driver      "trident"
	VendorName  "Trident Microsystems"
	BoardName   "TGUI 9660/938x/968x"
	BusID       "PCI:0:16:0"
EndSection

Section "Device"
	Identifier  "Card1"
	Driver      "ati"
	VendorName  "ATI Technologies Inc"
	BoardName   "RV280 [Radeon 9200 SE]"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 16
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes	"1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Card1"
	Monitor    "Monitor1"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes	"1600x1200" "1024x768"
	EndSubSection
EndSection

Section "DRI"
	Mode 0666
EndSection
I compiled everything that was required into my kernel(no modules).
The ones that I think are most important are:
Device Drivers->Character Devices->agpgart
Device Drivers->Character Devices->agpgart->Your agp chipset.
Device Drivers->Character Devices->Direct Rendering Manager
Device Drivers->Character Devices->Direct Rendering Manager->ATI Radeon
 
Old 06-03-2007, 10:47 PM   #9
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current with KDE 4.8.5
Posts: 300

Rep: Reputation: 35
Wink ATI Radeon with "normal" radeon driver

Hi there

This might be useful for you It was useful for me.

As you can see, it's from my Radeon 7000. I don't know if it works for other Radeons, but I guess it does.

From my xorg.conf, only the interesting sections
Code:
Section "Module"
    Load        "dbe"  	# Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise DGA
    EndSubSection
    Load        "type1"
    Load        "freetype"
    Load        "glx"
    Load        "dri"
EndSection

Section "Device"
    Identifier  "ATI Radeon 7000/VE"
    Driver	"radeon"
    Option	"DPMS"
    Option	"AGPMode" "4"
    Option	"AGPFastWrite" "on"
    Option	"EnablePageFlip" "on"
    #VideoRam    65536
EndSection

Section "DRI"
    Mode 0666
EndSection
Now from my kernel config (only the lines that matter) I have an ATI card and an Intel mainboard. It didn't work with only the AGP_ATI activated and not the AGP_INTEL so I guess AGP depends on your mainboard's chipset and not on your video card. I have both activated just in case...:
Code:
CONFIG_AGP=y
CONFIG_AGP_ATI=y
CONFIG_AGP_INTEL=y
CONFIG_DRM=y
CONFIG_DRM_RADEON=y
That's pretty much all. You *should* have accelerated graphics after this.
 
Old 06-03-2007, 11:47 PM   #10
Nem
Member
 
Registered: Mar 2007
Location: United States
Distribution: Slackware 11.0
Posts: 88

Original Poster
Rep: Reputation: 15
Okey seems like I got dri enabled.
How I did it,I ran xorgconfig and
and restarted X, then I ran modprobe radeon and it ran fine and restarted X again.
Then I modified my xorg.conf.
Here it is.
Code:
Section "Module"
   Load        "dbe"    # Double buffer extension

  SubSection  "extmod"
  Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

    Load        "type1"
    Load        "freetype"
    Load        "glx"
    Load        "dri"

EndSection


# Files section.  This allows default font and rgb paths to be set

Section "Files"

    RgbPath     "/usr/X11R6/lib/X11/rgb"



    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath   "/usr/X11R6/lib/X11/fonts/cyrillic/"

#    ModulePath "/usr/X11R6/lib/modules"

EndSection

# Server flags section.


Section "ServerFlags"


EndSection
# Input devices

# Core keyboard's InputDevice section


Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "kbd"

    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc104"
    Option "XkbLayout"  "us"

EndSection



# Core Pointer's InputDevice section

Section "InputDevice"

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "Auto" # Auto detect
    Option "Device"      "/dev/mouse"

    Option "ZAxisMapping"   "4 5 6 7"

    Option "Emulate3Buttons"

EndSection


# Monitor section

Section "Monitor"

    Identifier  "E173FP"

    HorizSync   31.5 - 64.3

    VertRefresh 56-76

EndSection



# Graphics device section


Section "Device"
    Identifier  "Standard VGA"
    VendorName  "Unknown"
    BoardName   "Unknown"


  Driver     "vga"

EndSection

# Device configured by xorgconfig:

Section "Device"
    Identifier  "ATI"
    Driver      "radeon"
    Option      "EnablePageFlip" "on"
    Option      "AGPMode" "4"
    Option      "VBERestore"    "true"
    Option      "AGPFastWrite"  "true"
    VendorName  "ATI Technologies Inc"
    BoardName   "RV280 [Radeon 9200 PRO]
    BusID       "PCI:1:0:0"
EndSection



# Screen sections

Section "Screen"
    Identifier  "Screen 1"
    Device      "ATI"
    Monitor     "E173FP"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection


# ServerLayout sections.


Section "ServerLayout"


    Identifier  "Simple Layout"



    Screen "Screen 1"



    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

 Section "DRI"
    Mode 0666
 EndSection

Section "Extensions"
        Option      "Composite" "False"
EndSection
Then I restarted X and now dri works!
I think what helped is ubergeek42's xorg.conf
file.I added
Code:
VendorName  "ATI Technologies Inc"
    BoardName   "RV280 [Radeon 9200 PRO]
    BusID       "PCI:1:0:0"
I think thats what got it going.Then to make
everything start up, I added

/sbin/modprobe radeon

to my /etc/rc.d/rc.modules
and it seems like dri is starting up as you see
here.
Code:
ame of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20041207 x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 6.4.1
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle,
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, GL_ARB_window_pos,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_compiled_vertex_array, GL_EXT_convolution, GL_EXT_copy_texture,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_histogram,
    GL_EXT_packed_pixels, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_stencil_wrap, GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
    GL_ATI_blend_equation_separate, GL_ATI_texture_env_combine3,
    GL_ATI_texture_mirror_once, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_MESA_window_pos,
    GL_NV_blend_square, GL_NV_light_max_exponent, GL_NV_texture_rectangle,
    GL_NV_texgen_reflection, GL_OES_read_format, GL_SGI_color_matrix,
    GL_SGI_color_table, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x30 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
This is glxgears
Code:
$ glxgears
3472 frames in 5.0 seconds = 694.333 FPS
3481 frames in 5.0 seconds = 696.034 FPS
3483 frames in 5.0 seconds = 696.417 FPS
3489 frames in 5.0 seconds = 697.607 FPS
3473 frames in 5.0 seconds = 694.554 FPS
3483 frames in 5.0 seconds = 696.575 FPS
3482 frames in 5.0 seconds = 696.267 FPS
3481 frames in 5.0 seconds = 696.160 FPS
I don't get why my FPS is like of low.
I thought I would get at least 1000 FPS
with the radeon driver and dri enabled.
What option can I add to get more or
what option to remove to get more out the
card?

Thanks
 
Old 06-04-2007, 02:35 PM   #11
ubergeek42
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware 11
Posts: 17

Rep: Reputation: 0
Well you beat me, I get around 500fps with mine, which is about what I expected, it's not that great of a card.
 
Old 06-04-2007, 05:36 PM   #12
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Ahh......... a little experiment for you guys.

Start glxgears from an xterm session wait about 15 seconds and completely cover the three gears with the xterm window and wait again for 15 seconds. Your FPS should be more then double while the gears are covered.
 
Old 06-05-2007, 04:08 PM   #13
ubergeek42
LQ Newbie
 
Registered: Jun 2005
Distribution: Slackware 11
Posts: 17

Rep: Reputation: 0
But what does that proove? That it can draw really fast when it doesn't actually have to draw?
So what if my fps jumps to over 8 thousand, its not indicative of anything, since its not actually drawing anything on the screen.
 
Old 06-05-2007, 04:33 PM   #14
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Use sauerbraten or one of the free quake3 mods to benchmark.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI RADEON 9200 Driver on kernel 2.6.14.6 deftone` Linux - Hardware 3 06-30-2006 04:11 AM
fglrx-driver vs ATI kernel driver for ATI Radeon 9200 in Debian Debian_Poland Debian 3 02-01-2006 01:10 PM
Ati Radeon 9200 SE (xorg 6.8.0) driver (HELP please!) apinta10 Slackware 22 10-11-2005 03:22 AM
ATI Radeon 9200 driver installation queries Jimsta Linux - Hardware 0 01-17-2005 01:06 AM
ATI Radeon 9200 vedio card driver please windyang12 Linux - Hardware 4 09-22-2003 07:43 AM


All times are GMT -5. The time now is 08:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration