LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-02-2005, 02:10 PM   #1
ShoCkwave
Member
 
Registered: Mar 2004
Location: Turkey
Distribution: Ubuntu
Posts: 38

Rep: Reputation: 15
Enabling DMA Problems.


When I try the command line option hdparm -d1 /dev/hda

I get the error Operation Not Permitted. I think it is because of kernel I newly installed 2.6.10 but dunno which options to choose. I selected every option thats related to my hard disk and DMA.

What else can affect that?

P.S: I built no scsi, raid support.
 
Old 02-02-2005, 02:12 PM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
in the ide section of the kernel config, make sure your chipset is enabled (look for your specific chipset).
 
Old 02-02-2005, 02:17 PM   #3
paulicat
LQ Newbie
 
Registered: Sep 2003
Location: Canada
Posts: 13

Rep: Reputation: 0
Under ATA/ATAPI/MFM/RLL Support -> , look for and click Generic PCI bus-master DMA support (BLK_DEV_IDEDMA_PCI) then look for -> Use PCI DMA by default when available (IDEDMA_PCI_AUTO) make sure this is checked....
 
Old 02-02-2005, 03:31 PM   #4
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
Look for your chipset in the ATA section and build it in. I had this issue recently when I recompiled and found myself with super-slow PIO mode.
 
Old 02-02-2005, 09:01 PM   #5
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Re: Enabling DMA Problems.

Quote:
Originally posted by ShoCkwave
When I try the command line option hdparm -d1 /dev/hda

I get the error Operation Not Permitted. I think it is because of kernel I newly installed 2.6.10 but dunno which options to choose. I selected every option thats related to my hard disk and DMA.

What else can affect that?

P.S: I built no scsi, raid support.
With respect to others who haveposted before me. Did you try the command as root? Just wondering.
 
Old 02-02-2005, 09:06 PM   #6
DaWallace
Member
 
Registered: Feb 2004
Location: Southern Maine, United States
Distribution: Slackware Ubuntu Debian FreeBSD
Posts: 418

Rep: Reputation: 31
it's not likely that it wasn't considering that it isn't in the path of normal users..
 
Old 02-03-2005, 12:45 AM   #7
ShoCkwave
Member
 
Registered: Mar 2004
Location: Turkey
Distribution: Ubuntu
Posts: 38

Original Poster
Rep: Reputation: 15
Re: Re: Enabling DMA Problems.

Quote:
Originally posted by carboncopy
With respect to others who haveposted before me. Did you try the command as root? Just wondering.
Yes,

I did this command as root. Its my own laptop.

----EDIT

After adding Intel PIIXn Chipset Support it enabled DMA on my harddisks.
Thx alot.

Last edited by ShoCkwave; 02-03-2005 at 01:21 AM.
 
Old 02-07-2005, 11:29 AM   #8
jrtayloriv
Member
 
Registered: Jun 2004
Location: Inland NW, US
Distribution: Ubuntu
Posts: 365
Blog Entries: 1

Rep: Reputation: 44
The chipset support must also be compiled into the kernel, not as a module, for it to work.

jrtayloriv

http://forums.gentoo.org/viewtopic.p...parm+permitted
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems permanently enabling DMA blastradius Ubuntu 1 10-27-2005 12:07 PM
enabling DMA problems blastradius Ubuntu 11 09-07-2005 01:22 AM
Enabling DMA DeadlyMuffin Slackware 4 07-19-2004 09:24 PM
problems enabling dma in kernel 2.6-test11 snoble Linux - Hardware 10 12-09-2003 01:20 PM
Enabling DMA bizzikid Linux - Newbie 4 08-06-2003 05:56 AM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration