LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Enabling DMA on my /dev/hda (http://www.linuxquestions.org/questions/slackware-14/enabling-dma-on-my-dev-hda-377566/)

Riddick 10-27-2005 06:37 PM

Enabling DMA on my /dev/hda
 
Dear All,
I consider myself quite experienced, and have been getting always deeper into
Slackware and Linux.
In a recent fsck process, I was told that the DMA on the (only) hard disk on my laptop
was not enabled.

I would like to enable it. I have kernel 2.6.13.4 freshly reconfigured, and I'm quite
sure I have the necessary options for DMA enabled!

Do I need some kernel parameters?

I am on a DELL C600 (P3cm) Laptop, with Slackware 10.2.

Thanks,
Riddick

rkelsen 10-27-2005 06:46 PM

# hdparm -d1 /dev/hda

should do the trick...

killerbob 10-27-2005 07:01 PM

That said... DMA will usually enable itself by default, unless the kernel doesn't have the right IDE driver enabled. You may need to recompile the kernel to enable support for your chipset. Check the results of lspci and make sure that the IDE controller is enabled in your kernel configuration.

Riddick 10-27-2005 07:02 PM

that is done!

Genesee 10-28-2005 12:10 PM

lots more on hdparm here:

http://www.linuxdevcenter.com/pub/a/...29/hdparm.html

Riddick 10-31-2005 03:22 PM

S any news? I tried that command and it didn't work!

OpenCircuit 12-12-2005 07:27 PM

I am having the exact same problem. Any help would be appreciated. I have "Use PCI DMA by default when available" and "AMD and nVidia IDE support" *... not sure what else the problem would be.

using hdparm -d1 /dev/hda says "Operation Not Permitted"

Riddick 12-12-2005 07:30 PM

all in the kernel - check your configuration!

If you have the same laptop as me I can send you my .conf - I can send it
anyway if you like...

Riddick

Matir 12-12-2005 07:38 PM

Can you post the output of lspci so we can determine what kind of IDE controller your laptop uses?

OpenCircuit 12-12-2005 07:41 PM

This is not for a laptop...
output for lspci :
root@Lucid:/home/opencircuit# lspci
00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation MCP2A ISA bridge (rev a3)
00:01.1 SMBus: nVidia Corporation MCP2A SMBus (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP2A USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP2A USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation MCP2A USB Controller (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation MCP2S AC'97 Audio Controller (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP2A PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation MCP2A IDE (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
01:08.0 RAID bus controller: Silicon Image, Inc. PCI0680 Ultra ATA-133 Host Controller (rev 02)
01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:00.0 VGA compatible controller: nVidia Corporation NV36.1 [GeForce FX 5700 Ultra] (rev a1)

unifiedquarks 12-13-2005 07:55 AM

I had the similar problem on hp nx6125 laptop (which has amd processor and ati chipset). enabling dma was not permitting by hdparm. and disk reading was very slow. I compiled 2.6.14 kernel and I checked ati chipset support and unchecked pII intel support from kernel options of devices-->ata section. now dma is working but still very slow. but when i tried the precompiled kernel 2.6.13 from slackware cd, there were no dma and slowness problem.

OpenCircuit 12-13-2005 07:28 PM

Last night after playing around with my kernel settings, I figured why not, enable ati support, and sure enough, works perfectly now.

Thanks all for the info.


All times are GMT -5. The time now is 02:32 PM.