LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-18-2003, 01:49 AM   #1
Linux_Inside
LQ Newbie
 
Registered: Oct 2003
Location: Bogor, Indonesia
Distribution: RedHat, Slackware
Posts: 13

Rep: Reputation: 0
(EE) NVIDIA (0) : Failed to load GLX (what's wrong ???)


I've succeed installing NVIDIA device driver on Slack, but when i test it by activating any screensaver that use 3d or OpenGL, it only shows blank screen....and when i exit X it gives me a warning "Xlib:extension "GLX" missing on display ":0.0".".

So i look at the XFree86.log and there an error "(EE) NVIDIA (0); Failed to load GLX", i've never meet with this kind of problem on other distros, is there something that i miss...or is there something different that i need to now on installing NVIDIA driver on Slack...

Please help..me...

Thanx b4

and sorry about my english...
 
Old 10-18-2003, 02:21 AM   #2
egh128
Member
 
Registered: Mar 2002
Location: Asheville, NC
Distribution: Ubuntu
Posts: 257

Rep: Reputation: 30
I don't know much about your problem, but a quick search of the Slackware forum got me this:

http://www.linuxquestions.org/questi...ed+to+load+GLX
 
Old 10-18-2003, 02:29 AM   #3
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
you have to edit your X config file,i.e,/etc/X11/XF86Config or /etc/X11/XF86Config-4.(see the log file,/var/log/XFree* for that.)
You will need to look for and change this part 'Section "Device"'. It's about half way down. You will need to(which you already may have done) change 'Driver "nv"' to 'Driver "nvidia"'. This will load the drivers when 'x' starts. Now look for the part 'Section "Module"'. delete line like 'Load "dri"' and 'Load "GLcore"'(if they are there) in the same section look for a command 'Load "glx"'. If it is not there,add one there.and now try startx.
--arun
 
Old 10-18-2003, 02:38 AM   #4
Linux_Inside
LQ Newbie
 
Registered: Oct 2003
Location: Bogor, Indonesia
Distribution: RedHat, Slackware
Posts: 13

Original Poster
Rep: Reputation: 0
I've already did that, i've edit my /etc/X11/XF86Config, it shows the NVIDIA splash screen, but still there none of my OpenGL screensavers or 3dgames that works. It's a little bit strange because when i use the OpenGL driver from Mesa everything work (screensaver...etc).

But offcourse everything runs verryy sloooowww....i need to make this driver work because i want to play my 3dgames....

Any other sugestions ...please
 
Old 10-19-2003, 10:33 PM   #5
Linux_Inside
LQ Newbie
 
Registered: Oct 2003
Location: Bogor, Indonesia
Distribution: RedHat, Slackware
Posts: 13

Original Poster
Rep: Reputation: 0
Guys.....thank's for your help i think i've fount the way out...
 
Old 10-20-2003, 03:16 AM   #6
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
Please post how you got around this problem,since it would be usefull to other people later.
 
Old 10-23-2003, 03:19 AM   #7
Linux_Inside
LQ Newbie
 
Registered: Oct 2003
Location: Bogor, Indonesia
Distribution: RedHat, Slackware
Posts: 13

Original Poster
Rep: Reputation: 0
OK... that's all because of my stupidity ....i forgot to uncheck
# Load "glx" on modules part...sorry everyone....


thanx...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 06:51 PM
ati glx load with NVIDIA TuxFreak Fedora 10 01-30-2005 12:51 PM
xserver with Nvidia driver 6629 won't load glx?!?!?!? o_0 Linux - Software 9 12-21-2004 09:58 PM
SOLVED: nVidia fails to load GLX library Ed-MtnBiker Fedora 0 03-26-2004 05:57 PM
failed to load module "glx" mjl3434 Linux - Newbie 2 09-26-2003 07:45 PM


All times are GMT -5. The time now is 04:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration