LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-21-2012, 09:43 PM   #1
Prasanna_Adhikari
Member
 
Registered: Dec 2009
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 0
Editing Lilo


I am having trouble in lilo file. I'm having boot problem. My lilo file is like this:

boot = /dev/sda

image = /boot/vmlinuz
label = Linux
root = /dev/sda7

other = /dev/sda1
label = Windows
table = /dev/sda


I have installed both Windows 7 and Slackware 13.31, when I start my machine, it directly boots Windows 7 without prompting option to choose those two OS.
 
Old 10-21-2012, 10:06 PM   #2
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
What happens when you actually run lilo?
 
Old 10-21-2012, 11:22 PM   #3
Prasanna_Adhikari
Member
 
Registered: Dec 2009
Distribution: Slackware 13.37
Posts: 36

Original Poster
Rep: Reputation: 0
how to run lilo?

Actually I installed both Windows 7 and Slackware 13.37. Slackware in /dev/sda7 and Windows in /dev/sda1
There was message while installing lilo. Which was like this:

Warning: Device 0x0800:Inconsistent partition table, 1st entry
CHS address in PT:0:1:1 --> LBA(63)
LBA address in PT:19-->CHS (0:0:20)
Fatal:Either FIX-TABLE or IGNORE-TABLE must be specified
If not sure, first try IGNORE-TABLE(-p ignore)


After that When I completed installation and restarted my machine, Windows 7 directly started. Later I used BackTrack disk and checked the lilo.conf file, which was like mentioned above.

By the way how to run lilo?
 
Old 10-21-2012, 11:59 PM   #4
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
Boot from the DVD or CD and follow the rescue instructions.

Quote:
In a pinch, you can boot your system from here with a command like:

boot: huge.s root=/dev/sda1 rdinit= ro
Of course, changing root= to point to your root partition. If that is successful than run /sbin/liloconfig to rebuild /etc/lilo.conf. Then run lilo to install the new configuration.

DNA
AKAmrascii
 
Old 10-22-2012, 12:03 AM   #5
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
You simply type lilo at the command prompt, but you need to be up and running first.

BTW that "FATAL" error means lilo did not install that is why Windows is still booting by itself.

Step one is boot into Slackware :-
do this by using the install CD/DVD and on the screen that comes up there are instructions on how to do just that

Step two is work out why lilo hates your hdd partition table, you can post it here by getting the output from "fdisk -l"
 
Old 10-22-2012, 05:37 AM   #6
Prasanna_Adhikari
Member
 
Registered: Dec 2009
Distribution: Slackware 13.37
Posts: 36

Original Poster
Rep: Reputation: 0
Partition Table

root@soul:/# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
224 heads, 19 sectors/track, 73444 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x7b0534cf

Device Boot Start End Blocks Id System
/dev/sda1 * 19 41942879 20971430+ 7 HPFS/NTFS/exFAT
/dev/sda2 41942880 312581807 135319464 f W95 Ext'd (LBA)
/dev/sda5 41942899 125828639 41942870+ 7 HPFS/NTFS/exFAT
/dev/sda6 125828659 209714399 41942870+ 7 HPFS/NTFS/exFAT
/dev/sda7 209714419 229713231 9999406+ 83 Linux
/dev/sda8 229713251 308581167 39433958+ 83 Linux
/dev/sda9 308581187 312581807 2000310+ 82 Linux swap

Last edited by Prasanna_Adhikari; 10-22-2012 at 05:44 AM.
 
Old 10-22-2012, 05:43 AM   #7
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
Quote:
Originally Posted by Prasanna_Adhikari View Post
/dev/sda1
/dev/sda2
/dev/sda5
/dev/sda6
/dev/sda7
/dev/sda8
/dev/sda9
Where is the rest of the output?

It should look like this :-
Code:
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    21000000    10498976+  83  Linux
/dev/sda2   *    21000001   970000000   474500000    7  HPFS/NTFS/exFAT
/dev/sda3       970000001   976773167     3386583+  da  Non-FS data
 
Old 10-22-2012, 05:49 AM   #8
Prasanna_Adhikari
Member
 
Registered: Dec 2009
Distribution: Slackware 13.37
Posts: 36

Original Poster
Rep: Reputation: 0
The output of fdisk -l is like this:

Quote:
Disk /dev/sda: 160.0 GB, 160041885696 bytes
224 heads, 19 sectors/track, 73444 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x7b0534cf

Device Boot Start End Blocks Id System
/dev/sda1 * 19 41942879 20971430+ 7 HPFS/NTFS/exFAT
/dev/sda2 41942880 312581807 135319464 f W95 Ext'd (LBA)
/dev/sda5 41942899 125828639 41942870+ 7 HPFS/NTFS/exFAT
/dev/sda6 125828659 209714399 41942870+ 7 HPFS/NTFS/exFAT
/dev/sda7 209714419 229713231 9999406+ 83 Linux
/dev/sda8 229713251 308581167 39433958+ 83 Linux
/dev/sda9 308581187 312581807 2000310+ 82 Linux swap

Last edited by Prasanna_Adhikari; 10-22-2012 at 05:53 AM.
 
Old 10-22-2012, 08:38 AM   #9
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
Ok some reading later and the ignore option is safe and should work.

Do not use the fix option as it may break your Windows install.

Looks like Windows didn't create it's partition record correctly, out by one sector.
 
Old 10-22-2012, 09:57 AM   #10
Prasanna_Adhikari
Member
 
Registered: Dec 2009
Distribution: Slackware 13.37
Posts: 36

Original Poster
Rep: Reputation: 0
Isn't there any solution then, I don't want to ruin the windows and want to boot slackware without DVD
 
Old 10-23-2012, 04:10 AM   #11
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 227Reputation: 227Reputation: 227
Have you tired running lilo with the "-P ignore" option yet?
 
Old 10-24-2012, 12:11 AM   #12
Prasanna_Adhikari
Member
 
Registered: Dec 2009
Distribution: Slackware 13.37
Posts: 36

Original Poster
Rep: Reputation: 0
-P ignore solved the problem

Thanks mrascii and wildwizard,-P ignore option solved my problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Editing Lilo Kane2002 Linux - General 2 07-07-2004 12:29 AM
No new kernel-option in LILO after editing lilo.conf corwax Debian 3 08-26-2003 09:55 PM
Editing LILO Negativ13 Linux - Newbie 3 12-23-2002 04:10 PM
Editing the Lilo wings9191 Linux - Newbie 1 02-12-2002 06:22 PM
Editing Lilo tmnt_power Linux - General 7 12-02-2001 08:13 PM


All times are GMT -5. The time now is 08:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration