LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-17-2004, 08:47 AM   #1
Magnabrau
LQ Newbie
 
Registered: Jul 2004
Location: Magna, Utah, USA
Distribution: Slackware 10.0
Posts: 7

Rep: Reputation: 0
Editing inittab & rc.4 works, but starts Gnome, not KDE


Hello,

Whee, I'm a Slackware newbie! I was a bit surprised that SW 10 passed my "newbie test": installed without a hitch and I got into a GUI (KDE) at a reasonable resolution, set up my dialup, and got online. This is my first post here.

If I edit /etc/inittab (change runlevel to 4) and comment out the Gnome lines in /etc/rc.d/rc.4, I boot directly into...Gnome! The only way I have been able to get into KDE is to reset to runlevel 3 and run "startx". Is there some other script or process taking over, or what?

Thanks,

John
 
Old 07-17-2004, 09:45 AM   #2
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
Re: Editing inittab & rc.4 works, but starts Gnome, not KDE

Quote:
Originally posted by Magnabrau
Hello,

Whee, I'm a Slackware newbie! I was a bit surprised that SW 10 passed my "newbie test": installed without a hitch and I got into a GUI (KDE) at a reasonable resolution, set up my dialup, and got online. This is my first post here.

If I edit /etc/inittab (change runlevel to 4) and comment out the Gnome lines in /etc/rc.d/rc.4, I boot directly into...Gnome! The only way I have been able to get into KDE is to reset to runlevel 3 and run "startx". Is there some other script or process taking over, or what?

Thanks,

John
If you are booting into runlevel 4 you should be seeing either GDM, KDM, or XDM which with give you a way to log into accounts AND choose which environment you wish to be in. I commented out the GDM lines in rc.4, so my system boots to KDM on bootup. You can log into KDE as root and go to the Control Center and change KDM settings if you wish to log into a specific user on bootup.

I hope this helps!
 
Old 07-17-2004, 12:21 PM   #3
Belerefontis
LQ Newbie
 
Registered: Dec 2002
Distribution: Fedora Core 2
Posts: 17

Rep: Reputation: 0
xwmconfig and choose your favorite one and startx after.
 
Old 07-17-2004, 01:58 PM   #4
Magnabrau
LQ Newbie
 
Registered: Jul 2004
Location: Magna, Utah, USA
Distribution: Slackware 10.0
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for the replies. I already commented out the Gnome stuff in rc.4, and set up users on boot from KDE Control Center. I had also already specified KDE as the enviro. during install, and it was still set when I checked xwimconfig.

I set runlevel back to 4 and I noticed that if I go into "Menu" at the prompt I can select KDE, and it will default to that the next time.

But, I get the following message before I get to the Menu prompt:

"Your login shell is not listed in etc/shells."

What entry do I need in that file?

John
 
Old 07-17-2004, 02:11 PM   #5
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
My /etc/shells file looks like this:

/bin/bash
/bin/tcsh
/bin/csh
/bin/ash
/bin/ksh
/bin/zsh


I did a full install of slackware 10 and this is an unedited file. Did you do a custom install and not install all the shells?

You can change it with the chsh command:

example
johndoe@darkstar:~# chsh
Changing the login shell for johndoe
Enter the new value, or press return for the default
Login Shell [/bin/bash]:
johndoe@darkstar:~#

make sure you have the file /etc/bash or /etc/whatever_shell_you_want


good luck - tw
 
Old 07-17-2004, 02:46 PM   #6
Magnabrau
LQ Newbie
 
Registered: Jul 2004
Location: Magna, Utah, USA
Distribution: Slackware 10.0
Posts: 7

Original Poster
Rep: Reputation: 0
My /etc/shells file is identical to yours, but I have no /etc/bash file. When I run chsh it shows bash as the default. Now what?

John
 
Old 07-17-2004, 04:28 PM   #7
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
I'm sorry - i made a mistake

your bash file should be in /bin, not /etc. (along with the other shells)

check to see if you have /bin/bash

Also, does the error show up logging in as root? or just your user(s)?
Did you do a full install or did you pick and choose?
 
Old 07-17-2004, 05:28 PM   #8
Magnabrau
LQ Newbie
 
Registered: Jul 2004
Location: Magna, Utah, USA
Distribution: Slackware 10.0
Posts: 7

Original Poster
Rep: Reputation: 0
Yes, I have /bin/bash. The error shows up before I log in. It's the first thing you see in the GUI, just before the login screen. Maybe something in one of the boot scripts is calling a shell that's not in /etc/shells (since bash is there, must be something else)?

John
 
Old 07-17-2004, 06:19 PM   #9
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
did you try the chsh command to see which shell you are using?

what is the result of that?

I tried referencing your error by searching for it online
"Your login shell is not listed in etc/shells" - it got many results.

I'm starting to run out of ideas... good luck, and I'll check back.. -tw
 
Old 07-17-2004, 06:53 PM   #10
Magnabrau
LQ Newbie
 
Registered: Jul 2004
Location: Magna, Utah, USA
Distribution: Slackware 10.0
Posts: 7

Original Poster
Rep: Reputation: 0
Talking It's fixed!

Thanks for the help!

I seem to have fixed this. Somewhere along the line while trying to get an automatic boot into KDE, I went into Control Center, Sys Admin, Login Manager, Convenience, and set "enable auto login" to checked. I must have been confused about the text mode login vs. the GUI login (probably still am, need to study this).

Anyway, all is well, and I can move on to the next newbie topic, to be posted soon.

Thanks again.

John
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kdm starts gnome not kde geomatt Slackware 8 04-19-2005 08:35 AM
Problem xinitrc, Gnome starts instead of KDE McCloud Debian 7 09-05-2004 09:03 AM
Problem starting Debian KDE 3.2 - Gnome starts rockee Linux - Newbie 1 03-19-2004 01:02 PM
Switching Runlevels without editing inittab? Korff Linux - General 9 06-02-2003 02:27 PM
install KDE but GNOME starts (may soon lose mind) keirobyn Linux - Software 3 12-17-2001 08:28 PM


All times are GMT -5. The time now is 01:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration