LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-22-2010, 01:00 AM   #1
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 386

Rep: Reputation: 23
e1000e eth0 NIC and kernel 2.6.35.3 under Slackware64


No networking issues when I first installed Slackware 64 13.1, as well as when I compiled a 2.6.34.1 kernel to replace the stock. Now that I have compiled and am running 2.6.35.3, my ethernet connection won't go and obtain an IP address from DHCP as it had done so previously. Did I miss something in this particular kernel release? The funny thing is my wifi connection works fine... isn't it usually the wired that is easier to get working than wireless! I did not change anything pertaining to e1000e and from the looks of it, it is listed under lspci -v and lsmod. Any suggestions?
 
Old 08-22-2010, 03:09 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,137

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
Is it listed under ifconfig? I would also check rc.inet1.conf in /etc/rc.d
 
Old 08-22-2010, 07:53 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,021
Blog Entries: 1

Rep: Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364
Hi,

Try 'ifconfig -a'.
 
Old 08-22-2010, 08:05 AM   #4
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Since it's in lsmod, can you try "dhcpcd eth0" (presuming you are using dhcp and your e1000e is eth0) or just "ifconfig eth0 YOUR_IP_ADDR up" (if you use a static ip address).

Last edited by guanx; 08-22-2010 at 08:10 AM.
 
Old 08-22-2010, 09:22 AM   #5
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 386

Original Poster
Rep: Reputation: 23
ifconfig lists eth0, but with no IP address. I just issued "dhcpcd eth0" and it proceeded by acquiring an IP address from the DHCP server and everything is working from that. However if I take down eth0 with "ifconfig eth0 down" and stop /etc/rc.d/rc.inet1, I get the following when I start /etc/rc.d/rc.inet1

Code:
Polling for DHCP server on interface eth0:
dhcpcd: version 5.2.2 starting
dhcpcd: eth0: waiting for carrier
dhcpcd: timed out
dhcpcd: allowing 8 seconds for IPv4LL timeout
dhcpcd: timed outPolling for DHCP server on interface eth0:
dhcpcd: version 5.2.2 starting
dhcpcd: eth0: waiting for carrier
dhcpcd: timed out
dhcpcd: allowing 8 seconds for IPv4LL timeout
dhcpcd: timed out
After this if I issue "dhcpcd eth0" again, it comes up with an IP address. What gives??
 
Old 08-22-2010, 09:49 AM   #6
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
Yep. I'm getting the same thing.

When I run a "/etc/rc.d/rc.inet1 restart" I still get the no-carrier/timeout message. I haven't tried using dhcpcd directly from the command line yet. My work around was to use "dhclient -4 eth0" instead of dhcpcd.

I'm wondering if there's something under /sys they've removed in .35 that the slackware version of dhcpcd doesn't like.

update: when I run dhcpcd directly from the command line i get:
Code:
root@nix:~# dhcpcd
dhcpcd: version 5.2.2 starting
dhcpcd: no interfaces have a carrier
dhcpcd: forking to background
so mine is at least being consistent.

Last edited by GazL; 08-22-2010 at 09:59 AM.
 
Old 08-22-2010, 10:29 AM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
found this:
http://roy.marples.name/archives/dhc...2010/0218.html

So, update is needed for .35
 
1 members found this post helpful.
Old 08-22-2010, 11:03 AM   #8
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 386

Original Poster
Rep: Reputation: 23
Quote:
Originally Posted by GazL View Post
found this:
http://roy.marples.name/archives/dhc...2010/0218.html

So, update is needed for .35
Good eye/research! Got the 5.2.7 source and the SlackBuild script and like that, it's working without a hitch again! Had to recreate the little diff patch, but other than this is SOLVED! Thanks all, GazL!
 
Old 08-22-2010, 11:25 AM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
Just done the same mate.

What did you change in the diff? from what I saw the 50-ntp.conf shipped with 5.2.7 now includes the slackware ntp restart clause in the if, so unless I'm missing something then it shouldn't be necessary to patch, though I suppose it doesn't hurt to make it slackware specific.

Code:
if type rc-service >/dev/null 2>&1 && rc-service --exists ntpd; then
        ntpd_restart_cmd="rc-service ntpd -- -Ds restart"
elif type invoke-rc.d >/dev/null 2>&1; then
        if [ -x /etc/init.d/ntp ]; then
                ntpd_restart_cmd="invoke-rc.d ntp try-restart"
        fi
        # Debian as a seperate file for DHCP config to avoid stamping on
        # the master.
        [ -e /var/lib/ntp ] || mkdir /var/lib/ntp
        : ${NTP_DHCP_CONF:=/var/lib/ntp/ntp.conf.dhcp}
elif [ -x /etc/rc.d/ntpd ]; then
        ntpd_restart_cmd="/etc/rc.d/ntpd status >/dev/null 2>&1 && /etc/rc.d/ntp
d restart"
elif [ -x /usr/local/etc/rc.d/ntpd ]; then
        ntpd_restart_cmd="/usr/local/etc/rc.d/ntpd status >/dev/null 2>&1 && /us
r/local/etc/rc.d/ntpd restart"
fi

Last edited by GazL; 08-22-2010 at 11:32 AM.
 
Old 08-22-2010, 08:51 PM   #10
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 386

Original Poster
Rep: Reputation: 23
GazL, while I removed that whole section, if you look at that lines you have highlighted in red, you will see that it still needs a little editing. There is no /etc/rc.d/ntpd in Slackware, but instead it is /etc/rc.d/rc.ntpd.
 
1 members found this post helpful.
Old 08-23-2010, 04:49 AM   #11
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
D'oh! I completely missed that!

Well, if it needs changing anyway might as well remove those unneeded if clauses too while I'm about it.

Thanks for putting me right.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL5 network problems using e1000e intel NIC dhart1978 Red Hat 4 06-26-2009 01:02 PM
eth0 : delaying initialization e1000e toakmal Linux - Networking 2 05-15-2009 10:48 AM
Compiling Intel e1000e against new 2.6.27 kernel TheDude05 Linux - Hardware 1 12-03-2008 02:57 AM
Anyone know a step by step way to fix the e1000e nic mobo Intel bug? dwhswebhosting Linux - Hardware 2 11-22-2008 10:35 PM
Help on Inserting New NIC module e1000e into boot.iso for Kickstart sathyanandk Linux - Hardware 2 08-04-2008 12:48 AM


All times are GMT -5. The time now is 09:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration