LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   DVDStyler fails with Slackbuild; and 2ManDVD won't load. (http://www.linuxquestions.org/questions/slackware-14/dvdstyler-fails-with-slackbuild%3B-and-2mandvd-wont-load-920747/)

camorri 12-27-2011 12:23 PM

DVDStyler fails with Slackbuild; and 2ManDVD won't load.
 
I have been using sbopkg to update my slackware 13.37 64 bit system. Two days ago, I looked for updates, and found some.

DVDstyler was at the top of the build queue. It failed to build. I thought sbopkg might have something to do with the problem, so I downloaded the latest slackbuild, and it will not compile either.

The error:

Code:

checking for wxWindows version >= 2.8.7... yes (version 2.8.12)
checking for wxSVG... yes
checking for wxSVG library with FFMPEG support... no
configure: error:
    DVDStyler requires the wxSVG library with FFMPEG support.

I got the latest wxSVG from slackbuilds, since the error is pointing at it.
wxSVG builds and installs without issue. However, DVDstyler still fails, indicating 'no ffmpeg support in wxSVG'

I have no idea how to fix this.

In the process, I discovered 2ManDVD would no longer launch. The error from the command line is:

Code:

2ManDVD: error while loading shared libraries: libavformat.so.52: cannot open shared object file: No such file or directory
Locate shows :

Code:

locate libavformat.so.*
/usr/lib64/libavformat.so.53
/usr/lib64/libavformat.so.53.5.0

I do not know what installs libavformat.so.52 ( or 53 ).

I read some posts, they were too old to be of any value on this problem, however, similar problems have been caused by ffmpeg. For the record, I have
ffmpeg-0.8.7-x86_64_custom-1.sbo installed.

Any suggestions on how to sort this mess?

ponce 12-27-2011 01:02 PM

should be easy :)

about dvdstyler: prior to build wxsvg and dvdstyler, you have to rebuild wxGTK (or wxPython, depends on what you use) with the media library support, and you do this rebuilding it with GConf installed (everything is in the READMEs :) ). Many thanks to Heinz Wiesinger for this hint that let me update dvdstyler (I was stuck :D )

about 2ManDVD: you have updated ffmpeg, so you have to rebuild 2ManDVD to make it link to the new version.

camorri 12-27-2011 02:25 PM

Some success. I got 2ManDVD fixed. I downloaded the latest version, and installed it. I got an error message on launch of the program, it complained about ffmpegthumbnailer, dvdauthor, and exif. I re-installed ffmpegthumbnailer and dvdauthor. I installed exif, never had it installed before. Now 2ManDVD launches without any complaining. One fixed.

DVDStyler, not so good. I installed Orbit2-2.14.19 and then GConf-2.32.4.

I had wxGTK installed, not wxPython for what that's worth. The version I had installed, 2.8.12 is the same as the version on Slackbuilds. I rebuilt it, and did an upgradepkg --reinstall. That ran.

I think I'm missing something, the how to include 'media library support'. I looked at the README's from slackbuilds. Are there more somewhere?

Any way, when I tried to build dvdstyler, I get the original error.

ponce 12-27-2011 02:32 PM

I think you should sync sbopkg to slackbuilds.org latest and try again building wxGTK, seems like you are missing niels' fix (now in the repository).

camorri 12-27-2011 03:04 PM

I uninstalled wxGTK, ran sync, and then reinstalled wxGTK. I installed DVDStyler, to be specific,
Quote:

dvdstyler-2.1b2-x86_64-1_SBo.tgz
. It all worked. Thank-you for your timely assistance.

I have marked the thread solved.

ponce 12-27-2011 03:49 PM

thanks to you for confirming that the slackbuilds work fine :)


All times are GMT -5. The time now is 02:53 AM.