LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Dual monitors not working, need some help! (http://www.linuxquestions.org/questions/slackware-14/dual-monitors-not-working-need-some-help-286928/)

Duffy 02-06-2005 11:35 AM

Dual monitors not working, need some help!
 
Slackware 10.0-Current
2.6.10 Kernel
Latest Nvidia drivers patched to install under 2.6.10
Asus K8V Deluxe (VIA board)
BFG 6800 Ultra (dual DVI)
17 inch LCD as my primary screen
19 inch CRT as my secondary screen


As of right now, my CRT is working fine but my LCD will not display. I want the LCD to be primary and the CRT secondary.

The only reason the twinview stuff is commented out is because even with it not commented out, it doesn't work. If I remember correctly, when I startx with all of the twinview stuff enabled, it gives me an error that there are no useable screens .....



Any suggestions?


Code:

Section "Module"
    Load        "dbe"  # Double buffer extension
  SubSection  "extmod"
    Option    "omit xfree86-dga"  # don't initialise the DGA extension
  EndSubSection
    Load        "type1"
 #  Load        "speedo"
 Load        "glx"
# Load  "v4l"
 Load  "freetype"
EndSection

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"
    FontPath  "/usr/X11R6/lib/X11/fonts/local"
    FontPath  "/usr/X11R6/lib/X11/fonts/misc"
    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath  "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath  "/usr/X11R6/lib/X11/fonts/TTF"
    FontPath  "/usr/local/share/fonts"
    FontPath  "/usr/share/fonts"
    FontPath  "/usr/X11R6/lib/X11/fonts"
    FontPath  "/usr/share/fonts/artwiz"
    FontPath  "/usr/share/fonts/freefont"
    FontPath  "/usr/share/fonts/larabiefonts"
    FontPath  "/usr/share/fonts/tmpTTF"
    FontPath  "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath  "/usr/X11R6/lib/X11/fonts/truetype"
    FontPath  "/usr/X11R6/lib/X11/fonts/ukr"
EndSection

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
EndSection

# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping"  "4 5"
EndSection

# **********************************************************************
# Monitor section
# **********************************************************************

Section "Monitor"
    Identifier  "Monitor0"
    HorizSync  30.0 - 107.0
    VertRefresh  48.0 - 120.0
EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

Section "Device"
    Identifier  "6800U"
    #Driver      "nv"
    Driver      "nvidia"
    Option "NoLogo" "true"
    Option "CursorShadow" "true"
    Option "renderaccel" "true"
#    Option "TwinView" "true"
 #  Option "MetaModes" "1280x1024 +0+0, 1280X1024 -1280+0"
 #  Option "ConnectedMonitor" "CRT,DFP"
 #  Option "SecondMonitorHorizSync" "24.0 - 80.0"
  # Option "SecondMonitorVertRefresh" "60.0"
#    Option "TwinViewOrientation" "LeftOf"
    Option "AllowGLXWithComposite" "true"
EndSection

Section "Screen"
    Identifier  "Screen 2"
    Device      "6800U"
    Monitor    "Monitor0"
    DefaultDepth 24
    Subsection "Display"
        Depth      24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Dual"
    Screen "Screen 2"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
    Option "OffTime" "20"
EndSection


Duffy 02-06-2005 11:45 AM

OK I enabled all the twinview stuff agin except "ConnecetedMonitor" and it WORK EXCEPT now... the CRT is a clone of my LCD..........


:confused:

egag 02-06-2005 11:51 AM

i think you'll need a second " screen " and "monitor" section,
discribing your 2nd monitorsetup.

egag

tw001_tw 02-06-2005 11:56 AM

First you need Xinerama referenced in your xorg.conf


Add this line in your ServerFlags section:

Quote:

Section "ServerFlags"

Option "Xinerama" "true"


There is a working serverlayout:

Quote:

Section "ServerLayout"

Identifier "Simple Layout"
Screen "Screen 1"
Screen "Screen 2" RightOf "Screen 1"
# ADD THE FOLLOWING LINE
Option "Xinerama" "true"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

But - here is a link to a detailed explination.

http://www.linuxquestions.org/questi...32#post1183132

If you get troubles, post back.
-tw

Duffy 02-06-2005 12:19 PM

Quote:

Originally posted by tw001_tw
First you need Xinerama referenced in your xorg.conf


Add this line in your ServerFlags section:





There is a working serverlayout:




But - here is a link to a detailed explination.

http://www.linuxquestions.org/questi...32#post1183132

If you get troubles, post back.
-tw

There is no Screen 1 though

I thought with twinview enabled I would not need, two monitor,device and screen sections ?

Duffy 02-06-2005 12:28 PM

Alright

I got it working without enabling xinerama! I was reading the xorg log file and noticed that both of my montiors were being scanned and the defualt modes were ok. Though metamode could not have any negative values! So now meta mode is "1280x1024,1280x1024,1280x1024,1280x1024"

Bam and it works... again SORTA

My CRT is still my primary monitor ( AKA my taskbar is over there )

tw001_tw 02-06-2005 12:29 PM

Quote:

I thought with twinview enabled I would not need, two monitor,device and screen sections ?
Since I don't have an Nvidia card, I can't speak from experience - you may be right, but I have
gotten the impression (reading/working with other posts here at LQ) that even with Nvidia cards,
Xinerama works - and thus you need 2 monitors, screens & cards.

If it does turn out that you don't, please let me (and others) know what & how.
I'de like to know out of general interest.

-tw

[EDITED:]
glad to hear its working - could you post your working xorg.conf file?

egag 02-06-2005 12:36 PM

yeah...i wanna take a look also....?

egag

Duffy 02-06-2005 12:43 PM

Code:

Section "Module"
    Load        "dbe"  # Double buffer extension
  SubSection  "extmod"
    Option    "omit xfree86-dga"  # don't initialise the DGA extension
  EndSubSection
    Load        "type1"
 #  Load        "speedo"
 Load        "glx"
# Load  "v4l"
 Load  "freetype"
EndSection



# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"
    FontPath  "/usr/X11R6/lib/X11/fonts/local"
    FontPath  "/usr/X11R6/lib/X11/fonts/misc"
    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath  "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath  "/usr/X11R6/lib/X11/fonts/TTF"
    FontPath  "/usr/local/share/fonts"
    FontPath  "/usr/share/fonts"
    FontPath  "/usr/X11R6/lib/X11/fonts"
    FontPath  "/usr/share/fonts/artwiz"
    FontPath  "/usr/share/fonts/freefont"
    FontPath  "/usr/share/fonts/larabiefonts"
    FontPath  "/usr/share/fonts/tmpTTF"
    FontPath  "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath  "/usr/X11R6/lib/X11/fonts/truetype"
    FontPath  "/usr/X11R6/lib/X11/fonts/ukr"
EndSection

#Section "ServerFlags"

#Option "Xinerama" "true"

#EndSection
# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
EndSection

# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping"  "4 5"
EndSection

# **********************************************************************
# Monitor section
# **********************************************************************

Section "Monitor"
    Identifier  "Monitor0"
    HorizSync  30.0 - 107.0
    VertRefresh  48.0 - 120.0
EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

Section "Device"
    Identifier  "6800U"
    #Driver      "nv"
    Driver      "nvidia"
    Option "NoLogo" "true"
    Option "CursorShadow" "true"
    Option "renderaccel" "true"
    Option "TwinView" "true"
    Option "MetaModes" "1280x1024,1280x1024,1280x1024,1280x1024"
    Option "SecondMonitorHorizSync" "24.0 - 80.0"
    Option "SecondMonitorVertRefresh" "60.0"
#    Option "Connectedmonitors" "DFP,DFP"
    Option "TwinViewOrientation" "LeftOf"
    Option "AllowGLXWithComposite" "true"
EndSection

Section "Screen"
    Identifier  "Screen 2"
    Device      "6800U"
    Monitor    "Monitor0"
    DefaultDepth 24
    Subsection "Display"
        Depth      24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Dual"
    Screen "Screen 2"
#    Screen "Screen 2" RightOf "Screen 1"
#    Option "Xinerama" "true"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
#    Option "OffTime" "20"
EndSection

As I said, it works but my CRT is my primary :(


EDIT: in the control center I changed the panel to display on screen 2 and now my taskbard is on my LCD... w00t w00t!

DaWallace 02-06-2005 01:06 PM

I'm pretty sure you can make the lcd the primary by uncommenting connectedmonitors and setting it to "dfp, crt"

Duffy 02-06-2005 01:27 PM

Quote:

Originally posted by DaWallace
I'm pretty sure you can make the lcd the primary by uncommenting connectedmonitors and setting it to "dfp, crt"
Nope. X will not start with "dfp,crt" or "crt,dfp"

But will with "crt-0,dfp-1"

Though when I launch UT2004 the game is half way off the screen on my CRT ( AKA not working right )


All times are GMT -5. The time now is 03:06 AM.