LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   dual display problem with xorg.conf (http://www.linuxquestions.org/questions/slackware-14/dual-display-problem-with-xorg-conf-938237/)

tramni1980 04-05-2012 04:43 AM

dual display problem with xorg.conf
 
1 Attachment(s)
Hello!
I am running Slackware64-13.37. I have a large monitor connected to a laptop and in practice this is a dual display. The problem is that I have to adjust the screen resolution for the large monitor each time when I start kde from its system settings. This is because I have not adjusted the Xorg.conf properly. Could someone give me hint where my mistake is? The Xorg.conf is attached.

Many thanks in advance.

adamk75 04-05-2012 05:23 AM

You should have only one Screen section and one Device section, but keep the two Monitor sections. Change their Identifiers to whatever 'xrandr' reports for the monitor names (ie. LVDS1, VGA1).

Then, in those Monitor sections, put in the PreferredMode for each monitor. Something along the lines of this:

Code:

Section "Monitor"
        Identifier  "LVDS1"
        Option "PreferredMode" "1366x768"
EndSection

Section "Monitor"
        Identifier  "VGA1"
        Option "PreferredMode" "1680x1050"
EndSection

You should get rid of the Modes line in the Display SubSection, too.

Alien Bob 04-05-2012 06:14 AM

Have you considered deleting your xorg.conf altogether? Slackware 13.37 is perfectly capable of auto-configuring X when xorg.conf is absent. I have a laptop with an external monitor connected to it, and use krandrtray in KDE if I need to change anything in the layout.
I have one large desktop split across the two screens.

I have not tried the KDE 4.5.5 of Slackware 13.37 in a long time, but I remember that I had to configure the "native mode" of the two screens, i.e. the monitor's optimal display resolution, every time when I booted up. So the advice by adamk75 (about adding the PreferredMode to xorg.conf) would be good to try out.

The KDE 4.8.2 which I am using nowadays (on slackware-current) works much better in this regard.

Eric

tramni1980 04-05-2012 08:04 AM

adamk74,
Thank you very much for your advice, it worked perfectly. Now I do not have to adjust the resolution every time I log in.


All times are GMT -5. The time now is 03:27 AM.