LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-06-2003, 01:47 PM   #1
virus2099
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware 10
Posts: 26

Rep: Reputation: 15
dropline problems


I am new to slackware and I have recently installed dropline gnome.
When I ran the installpkg command everything seemed to go fine, but
when I try to launch and gnome related application there are no fonts
and when I start gnome there are none there either. I have taken screenshots, they are here: http://www.geocities.com/plus_321/index.html
Also, when I try to compile acidlaunch it still says that I haven't got libxml2, but I believe libxml2 was included with dropline.
 
Old 01-06-2003, 02:40 PM   #2
Notcho Fodder
LQ Newbie
 
Registered: Dec 2002
Location: Nipom, CA
Distribution: Slackware 8.1
Posts: 9

Rep: Reputation: 0
Install Dropline?

Prob a stupid question,... did you install dropline as per the following from a terminal or cli as root or su?

# installpkg dropline-installer-dropline-1.2.4-i386-1.tgz
# dropline-installer --install

Couple of ways to do that but the above is from the dropline site.

Then, xwmconfig (to select the default desktop) select gnome

Then, startx to start gnome.

That was all I did, and I am loving it.
 
Old 01-06-2003, 02:49 PM   #3
virus2099
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
Yes, I was root and did exactly what it said.
I am using kdm for gui login should I perhaps change it to gdm?
 
Old 01-06-2003, 03:59 PM   #4
Notcho Fodder
LQ Newbie
 
Registered: Dec 2002
Location: Nipom, CA
Distribution: Slackware 8.1
Posts: 9

Rep: Reputation: 0
Angry GDM

I don't know about the kdm/gdm gui for login....can't get it working right. I'm still tring to get GDM for users. I startup from cli and then login, then startx.

Try this,
xwmconfig
and verify that gnome is your default. If not, change it.

Not sure but I think use of kdm won't work right with dropline gnome.
 
Old 01-06-2003, 04:48 PM   #5
virus2099
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
Okay, I changed my default to gnome and did init 3 and startx and I still have the same problem.
When I downloaded dropline it went to /var/cache/dropline-installer and when I installed it I ran installpkg on everything except for a text
file called DroplineFiles which looks like a text file listing all of the other packages. Perhaps this has something to do with the problem.
But since I have no idea what to do with it I'm open to suggestions.
 
Old 01-06-2003, 04:53 PM   #6
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Something definitely went wrong when it was installing. Have you tried to unistall and reinstall it at all ??
 
Old 01-06-2003, 05:07 PM   #7
Notcho Fodder
LQ Newbie
 
Registered: Dec 2002
Location: Nipom, CA
Distribution: Slackware 8.1
Posts: 9

Rep: Reputation: 0
We're getting closer

Some browsers will d/l a file to just about anywhere.

I've made a "Downloads" directory and put all my source files and tgz packages in there for safe keeping.

After you find the tgz file, wherever it is, use the slackware package tool to install dropline.

Sounds like you need to use the slackware tool to uninstall and then reinstall dropline. Once you reinstall you can then use the dropline install tool: dropline-install --install.

That should get you where you need to be.
 
Old 01-06-2003, 05:24 PM   #8
virus2099
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
I think that I may have found the problem, I tried to run dropline-installer --install-local and I get an error when it comes to
libglade-dropline-2.0.1-i385-1.tgz
the exact error is:
Cannot install /var/cache/dropline-installer/libglade-dropline-2.0.1-i385-1.tgz:
package does not end in .tgz
Error: Package installation failed.
When I check for this package it is not there. I really do not want to download the entire thing again is there an easier way.
Also, if I do have to download the whole thing again, how do I uninstall the old version.
 
Old 01-06-2003, 05:54 PM   #9
Notcho Fodder
LQ Newbie
 
Registered: Dec 2002
Location: Nipom, CA
Distribution: Slackware 8.1
Posts: 9

Rep: Reputation: 0
I don't have that file either?

I checked for your bad/missing file - I don't have it either. It wasn't part of any of my installation of dropline. I have since run an --update. Wouldn't think it would fail to install a library though.

To remove a package: info removepkg, then

removepkg PKGNAME.tgz
 
Old 01-06-2003, 06:25 PM   #10
figadiablo
Member
 
Registered: Feb 2002
Location: Virginia USA
Distribution: Slackware, CentOS, Fedora
Posts: 342

Rep: Reputation: 30
if this is the only file missing, try downloading the specified file from the dropline ftp, and re run the installation againg.


Figa
 
Old 01-06-2003, 07:11 PM   #11
virus2099
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
I uninstalled all of the packages and downloaded the libglade file
then tried to reinstall. It told me that everything was correctly installed
but I still have the same problem.
 
Old 01-06-2003, 07:38 PM   #12
Notcho Fodder
LQ Newbie
 
Registered: Dec 2002
Location: Nipom, CA
Distribution: Slackware 8.1
Posts: 9

Rep: Reputation: 0
Have you tried this???

have you tried going to dropline.net and posting the same question(s) in the dropline formum.

Dropline is a very specific for Slackware. Perhaps you would get more specific dropline/slackware responses on that forum.

Just a sug.
 
Old 01-06-2003, 07:47 PM   #13
virus2099
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
Yeah, someone there had the same problem as me but either they could not find a fix or did not post it and I replied to their post. I've looked over countless pages and have found nothing.
 
Old 01-07-2003, 11:31 AM   #14
virus2099
LQ Newbie
 
Registered: Jan 2003
Distribution: slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
Could someone who has a working version post of copy of their
XftConfig so I could compare it with mine.
 
Old 01-07-2003, 11:54 AM   #15
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
If your wanting the one from the /etc/X11 directory, here is mine:
Code:
drew@stardust:/etc/X11$ less XftConfig

# Font directories.
dir "/usr/X11R6/lib/X11/fonts/Type1"
dir "/usr/X11R6/lib/X11/fonts/truetype"
dir "/usr/X11R6/lib/X11/fonts/TTF"

#
# alias 'fixed' for 'mono'
#
match any family == "fixed"             edit family =+ "mono";

#
# Check users config file
#
includeif       "~/.xftconfig"

#
# Substitute TrueType fonts for Type1 versions
#
match any family == "Times"             edit family += "Times New Roman";
match any family == "Helvetica"         edit family += "Verdana";
match any family == "Courier"           edit family += "Courier New";

#
# Use Luxi fonts for default faces
#
match any family == "serif"             edit family += "Luxi Serif";
match any family == "sans"              edit family += "Luxi Sans";
match any family == "mono"              edit family += "Luxi Mono";

#
# Alias between XLFD families and font file family name, prefer local
# fonts
#
match any family == "charter"           edit family += "bitstream charter";
match any family == "bitstream charter" edit family =+ "charter";

#
# Alias older name for Luxi fonts
#
match any family == "LuciduxSerif" edit family += "Luxi Serif";
match any family == "Lucidux Serif" edit family += "Luxi Serif";

match any family == "LuciduxSans" edit family += "Luxi Sans";
match any family == "Lucidux Sans" edit family += "Luxi Sans";

match any family == "LuciduxMono" edit family += "Luxi Mono";
match any family == "Lucidux Mono" edit family += "Luxi Mono";
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard problems on dropline gnome on 10.1 Oholiab Slackware 8 03-06-2005 08:56 AM
dropline login problems mdcapt Slackware 4 10-22-2004 10:10 AM
XFCE4 and Dropline Gnome problems Gillibiabtiag Linux - Newbie 2 09-16-2004 06:19 PM
printing problems after dropline upgrade naflan Slackware 2 02-16-2004 10:21 AM
dropline + proxy problems Bahamut Zer0 Linux - Networking 0 11-21-2002 06:03 AM


All times are GMT -5. The time now is 03:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration