LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Dropline GNOME 3.8 - testing packages (http://www.linuxquestions.org/questions/slackware-14/dropline-gnome-3-8-testing-packages-4175459688/)

saxa 04-26-2013 12:24 PM

Dropline GNOME 3.8 - testing packages
 
Hi , i have put up some packages of gnome 3.8 for slackware64-14.0, they are only for x86-64 arch for now. It is work in progress, but i'm writing here to see if somebody can test what is already done.

If you want to test it, install firstly dropline gnome 3.6 with the installer
and then update it with the packages you get from here:

http://www.droplinegnome.org/files/3.8/x86-64/

Please report any problems over here.

Rgds
Saxa

ponce 04-26-2013 01:48 PM

sorry saxa for the question, but can we try it on a virtual machine or does it need and accelerated opengl environment with proprietary drivers like the previous versions (I tried gsb some time ago)?

saxa 04-26-2013 02:11 PM

Yeah, I think it should work on a VM. At least on mine it works.

blackv1rus 04-28-2013 02:18 PM

Are the slackbuilds scripts inside the packages??

saxa 04-28-2013 02:59 PM

Quote:

Originally Posted by blackv1rus (Post 4940660)
Are the slackbuilds scripts inside the packages??

The scripts are included with the packages, but since we did this before there was slackbuilds available, we have our own build system. you can get it from our sf.net page.

Rgds
Saxa

saxa 04-29-2013 03:10 PM

Ok yesterday night i did a bunch of updates if somebody wants the updated version is recommended to download the new packages.
If everything goes well with my time i will put up a testing installer shortly.

Some stuff requires python3 to be added to the distro, let me know your opinions.

ponce 04-30-2013 02:14 AM

Quote:

Originally Posted by saxa (Post 4941389)
Some stuff requires python3 to be added to the distro, let me know your opinions.

if you're looking to add it, have a look at this, it coexist fine with the python in Slackware.

saxa 05-01-2013 12:46 PM

Thx ponce i will definetly look into this script.

saxa 05-04-2013 11:00 PM

Good, lots of stuff is updated. There is also an installer which still is having some troubles because of few packages.
If you gonna use the installer then do not install fontconfig with it as it has a warning in the install phase and it stops the install. After you install everything install that fontconfig package manually.

Installer is here:
http://www.droplinegnome.org/files/3...x86_64-1dl.txz
http://www.droplinegnome.org/files/3...64-1dl.txz.md5

Enjoy.

saxa 05-08-2013 09:13 PM

Just as a notice, I have upgraded to the last xorg-server-1.12.4 stuff from slackware stable tree and it seems it breaks the gnome3.
I'm still investigating why it does not run with this stuff installed, but for now if you want to use gnome 3.8 do not upgrade those 3 or 4 packages.

My xfce stuff runs normally.

Anybody had the same experience ?

Amrod78 05-10-2013 02:09 PM

Quote:

Originally Posted by saxa (Post 4947542)
Just as a notice, I have upgraded to the last xorg-server-1.12.4 stuff from slackware stable tree and it seems it breaks the gnome3.
I'm still investigating why it does not run with this stuff installed, but for now if you want to use gnome 3.8 do not upgrade those 3 or 4 packages.

My xfce stuff runs normally.

Anybody had the same experience ?

I had a similar problem, some gnome3 programs such as gthumb/totem crashed on startup. At first I thought it was a fglrx related problem and I solved
by upgrading the packages from x series with the slack64-current ones.

saxa 05-10-2013 02:33 PM

Hmm, interesting. Many thanks for the tip, will try that.

saxa 05-10-2013 08:33 PM

Ok, today I tried to reinstall the slackwares original xorg-server-1.12.3 packages, but it didnt help, still got nothing. So most probably the fault is somewhere else.

saxa 05-11-2013 09:26 PM

Ok sorted it out or nearly. What solved the problem here was:

Code:

root@machine:~# glib-compile-schemas /usr/share/glib-2.0/schemas
I have also downgraded polkit-gnome but sincerely i don`t think it has to do anything with the problems in running gnome-shell.

saxa 05-18-2013 10:58 PM

Ok just for an update. I put up about 40 new packages of 3.8.2 so re-run dropline-installer and you should be ok. Please report problems.


All times are GMT -5. The time now is 06:46 AM.