LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-01-2014, 05:42 PM   #16
saxa
Member
 
Registered: Aug 2004
Posts: 303

Original Poster
Rep: Reputation: 18

Hi Aman, since the Katja backend in PackageKit is still under development, I know that for now there is no option to check the downloaded packages, therefore I also think that it doesnt resume the download. Probably the best thing would be tyo copy the packages from /var/cache/PackageKit/downloads to a safe place and in case it does not resume
install them at onnce with installpkg *.txz and then run pkcon install dropline again just to install if something is missing.

It is just a guess, probably Eugen can answer you a better answer.

X here is working , is it a full slackware install ?
 
Old 01-01-2014, 05:48 PM   #17
saxa
Member
 
Registered: Aug 2004
Posts: 303

Original Poster
Rep: Reputation: 18
@aman, you can also try to run gnome-session from another WM like XFCE terminal or other.
Or alternatively try to supply a log of what is going on, try to "startx > mylog.txt 2>&1" and post here the log.
 
Old 01-02-2014, 01:53 PM   #18
belka.ew
Member
 
Registered: Jul 2012
Location: Germany / München
Distribution: Slackware
Posts: 51

Rep: Reputation: Disabled
Quote:
Originally Posted by Aman_sRB View Post
Hi,

I really want to test new Dropline for Slackware. But it's seem fail to start X with blinking small terminal box. Not really clear what happened as I only can see like "cannot load ??--x-font-xxx".

Thus, I want to manage all things from beginning by entering command:
- pkcon refresh force
- pkcon get-updates
- pkcon install dropline

It's likely download all PKGs from beginning even same PKG with same version.
Every times we hit pkcon refresh or pkcon install, it's remove all PKGs in cache/PackageKit/downloads;

Is there some way to prevent download PKGs that already exists?
I still have backup of dropline PKGs in another folder. That's because of my connection is limited, base on mobile data.

Thank you for any help
PackageKit empties /var/cache/PackageKit/downloads when daemon packagekitd starts (the daemon starts if you executes any PK command and shutdowns some time later, the time can be set in /etc/PackageKit/PackageKit.conf). It does PK itself, not the backend. So as Sasa said you can copy the packages to some other place. Between refresh and install you can copy them back, thus the packages shouldn't be downloaded again.
Thanks for the hint, maybe I make some option to keep downloaded packages.
And for X problem, as said, it would be useful to see some logs.
 
Old 01-02-2014, 08:10 PM   #19
Aman_sRB
LQ Newbie
 
Registered: Jan 2014
Posts: 3

Rep: Reputation: Disabled
Thank you for reply.

Today I've try to manage it again, but still out of luck. My Slackware version is 14.1 x86_64 with latest XFCE desktop.

First, if I install full dropline, pkcon getting error message: Failed to contact PackageKit: Error calling StartServiceByName for org.freedesktop.PackageKit: GDbus.Error...

Second, X log say:
1. Warning: Could not parse desktop file xscreensaver.desktop
2. Warning: AT-SPI could not obtain desktop path or name
3. Warning: atk-bridge GetRegisteredEvents returned message with unknown signature; (2 lines After, same msg = get_device_event_reply)
4. GDbus.Error... org.freedesktop.login1 was not provided by any .service files
5. failed to connect to colord
6. IBUS-WARNING: connection refused
7. (gnome-shell:2773) JS Error: version none: Typelib file for namespace NetwokManager, version 1.0 not found (js/ui/environment.js:14)


That is some hints and I am sorry cannot provide full log since I am connected now from my phone.
 
Old 01-02-2014, 08:59 PM   #20
Aman_sRB
LQ Newbie
 
Registered: Jan 2014
Posts: 3

Rep: Reputation: Disabled
Hi again

Now xinit only gives one error message: no GSetting schemas on system. I've try reinstall gsettings-desktop... gnome-setting and daemon.

But I have to wait again, pkcon install dropline again remove existing pkgs in cache. As suggestion, I have run refresh, then copy my backed up. first hit pkcon install, it's not removed. It's removed when I triggered pkcon install for sexond time after reinstall PKGd above.

Thanks
 
Old 01-03-2014, 12:05 AM   #21
saxa
Member
 
Registered: Aug 2004
Posts: 303

Original Poster
Rep: Reputation: 18
From the messages you post here, it is clear that you have not installed all the packages. For some reason they got corrupt or in some way skipped by the install process.
If you have a backup of the packages try to download theiy .md5 files and check them with md5sum to see if they are not corrupt. If they are ok, then try to do
"upgradepkg --reinstall --install-new *.txz" in the directory where you have your downloaded packages.
 
Old 01-03-2014, 11:11 AM   #22
DavidSalgueiro
LQ Newbie
 
Registered: Jun 2012
Posts: 5

Rep: Reputation: Disabled
Hello,

I tried it to, but i cannot login, it gaves me an error like this one: http://wocares.com/host/images/516726_sleeperr1.jpg
 
Old 01-03-2014, 11:16 AM   #23
belka.ew
Member
 
Registered: Jul 2012
Location: Germany / München
Distribution: Slackware
Posts: 51

Rep: Reputation: Disabled
Quote:
Originally Posted by DavidSalgueiro View Post
Hello,

I tried it to, but i cannot login, it gaves me an error like this one: http://wocares.com/host/images/516726_sleeperr1.jpg
I see this thing if I login with gdm without suitable video drivers. So missing 3d acceleration could be the problem (in my case nvidia drivers help). Does it work with startx? Another thing, that gnome-shell requires using of UTF-8 (edit lang.sh as described in the first post), but in this case the desktop just exits without errors if I recall correctly.
 
Old 01-03-2014, 11:22 AM   #24
DavidSalgueiro
LQ Newbie
 
Registered: Jun 2012
Posts: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by belka.ew View Post
I see this thing if I login with gdm without suitable video drivers. So missing 3d acceleration could be the problem (in my case nvidia drivers help). Does it work with startx? Another thing, that gnome-shell requires using of UTF-8 (edit lang.sh as described in the first post), but in this case the desktop just exits without errors if I recall correctly.
Humm, my Graphic Card is an obsolete ATI HD 4000, which AMD stops supporting 2 years ago. If that is the problem, i think i cannot do anything.
 
Old 01-03-2014, 11:26 AM   #25
belka.ew
Member
 
Registered: Jul 2012
Location: Germany / München
Distribution: Slackware
Posts: 51

Rep: Reputation: Disabled
Quote:
Originally Posted by DavidSalgueiro View Post
Humm, my Graphic Card is an obsolete ATI HD 4000, which AMD stops supporting 2 years ago. If that is the problem, i think i cannot do anything.
Gnome removed fallback mode in 3.8 or even 3.6. startx could still work, but I'm not sure of it.
 
Old 01-03-2014, 11:30 AM   #26
DavidSalgueiro
LQ Newbie
 
Registered: Jun 2012
Posts: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by belka.ew View Post
Gnome removed fallback mode in 3.8 or even 3.6. startx could still work, but I'm not sure of it.
Can you tell me, how can i go into KDM again? Im a little bit lost in here.
 
Old 01-03-2014, 11:32 AM   #27
belka.ew
Member
 
Registered: Jul 2012
Location: Germany / München
Distribution: Slackware
Posts: 51

Rep: Reputation: Disabled
Quote:
Originally Posted by DavidSalgueiro View Post
Can you tell me, how can i go into KDM again? Im a little bit lost in here.
removepkg gdm

or edit /etc/rc.d/rc.4 and comment the checking for gdm or even better put kdm related code before gdm
 
Old 01-03-2014, 11:35 AM   #28
DavidSalgueiro
LQ Newbie
 
Registered: Jun 2012
Posts: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by belka.ew View Post
removepkg gdm

or edit /etc/rc.d/rc.4 and comment the checking for gdm or even better put kdm related code before gdm
Thank you man! I'll try dropline later, now i've to work.
 
Old 03-15-2014, 10:55 AM   #29
ryanpcmcquen
Member
 
Registered: Apr 2013
Distribution: Slackware
Posts: 85

Rep: Reputation: Disabled
Is there any plan to support Slackpkg+ in the future? There are a lot of nice repos working with it, including the MSB one.
 
Old 03-15-2014, 06:17 PM   #30
saxa
Member
 
Registered: Aug 2004
Posts: 303

Original Poster
Rep: Reputation: 18
To be honest I have no idea how slackpkg+ works. Never played with it. I think that for installing with slackpkg+ we should change our directory structure and I do not know if slack pkg supports an index file for installing in a certain order. Therefore I can not say yes or no, most probaby is no as this would also mean slackpkg+ people changeing something in the way it works now.
Don't take my word as I'm just supposing everything.
 
  


Reply

Tags
dropline, gnome, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set perferred applications in Gnome/Slackware 12/Dropline Gnome ? perry Slackware 3 05-27-2008 04:53 PM
Dropline gnome and included gnome linda Slackware 1 09-01-2004 02:39 PM
dropline-gnome and gnome-look.org linuxnubx Slackware 4 08-23-2004 02:58 AM
What is the difference between Gnome and Dropline Gnome mikieboy Linux - Software 7 07-29-2004 12:52 PM
Difference between Gnome and Dropline-Gnome ?? Necronomicom Slackware 13 06-10-2004 12:16 AM


All times are GMT -5. The time now is 11:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration