LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-04-2013, 01:00 PM   #1
narke
Member
 
Registered: Apr 2010
Posts: 70

Rep: Reputation: 0
dropboxd stops working


I used to run a dropbox daemon got from slackbuilds (Dropbox (store, sync and share files online)). I worked fine for at least two month. But since yesterday, it stopped working. I reported following errors when I launched it from command line:

----------
process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(process:16920): Gdk-CRITICAL **: IA__gdk_cursor_new_for_display: assertion `GDK_IS_DISPLAY (display)' failed

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(process:16920): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(process:16920): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()
-------------

I didn't know what I changed in my system, but the error keeps same even after reinstalled the package.

Does anyone have a clue from above error messages?

Thanks in advance.
-woody
 
Old 04-04-2013, 01:45 PM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,637

Rep: Reputation: 450Reputation: 450Reputation: 450Reputation: 450Reputation: 450
What Slackware version did you use? 14.0 or Current?
What packages did you upgrade in the last few days?
 
Old 04-04-2013, 11:35 PM   #3
narke
Member
 
Registered: Apr 2010
Posts: 70

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by willysr View Post
What Slackware version did you use? 14.0 or Current?
What packages did you upgrade in the last few days?
It's 14.0. How do I know what packages I upgraded in the last few days?
 
Old 04-04-2013, 11:37 PM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
Code:
$ ls -lt /var/log/packages | head
shows the last 10 packages installed/upgraded, assuming you used pkgtools (installpkg/upgradepkg) to do so.
 
Old 04-05-2013, 08:38 AM   #5
narke
Member
 
Registered: Apr 2010
Posts: 70

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by T3slider View Post
Code:
$ ls -lt /var/log/packages | head
shows the last 10 packages installed/upgraded, assuming you used pkgtools (installpkg/upgradepkg) to do so.
Okay, it shows:

-rw-r--r-- 1 root root 4473 Apr 5 00:52 dropbox-1.2.49-x86-1_SBo
-rw-r--r-- 1 root root 2634 Apr 4 21:10 dropbox-client-1.6.0-i386-1alien
-rw-r--r-- 1 root root 85068 Mar 20 16:42 dia-0.97.2-i486-2_SBo
-rw-r--r-- 1 root root 34693 Feb 27 13:22 draftsight-1.2.265-i386-1_SBo
-rw-r--r-- 1 root root 14558 Feb 27 13:18 nas-1.9.3-i486-2_SBo
-rw-r--r-- 1 root root 710 Feb 4 00:07 unrar-4.0.7-i486-1_SBo
-rw-r--r-- 1 root root 6731 Jan 29 09:09 lxrandr-20111224_05a11b1-i486-1_SBo
-rw-r--r-- 1 root root 5785 Dec 13 14:42 freemind-0.9.0-noarch-1_SBo
-rw-r--r-- 1 root root 13958 Dec 4 12:31 wireshark-1.8.2-i486-1_SBo


So, is there a clue? Thanks.
 
Old 04-05-2013, 10:53 AM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
I suggest you uninstall dropbox-1.2.49-x86-1_SBo and dropbox-client-1.6.0-i386-1alien and then install dropbox 2.0.2.
This thread should help. http://www.linuxquestions.org/questi...de-4175455271/
 
Old 04-06-2013, 10:05 PM   #7
narke
Member
 
Registered: Apr 2010
Posts: 70

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by allend View Post
I suggest you uninstall dropbox-1.2.49-x86-1_SBo and dropbox-client-1.6.0-i386-1alien and then install dropbox 2.0.2.
This thread should help. http://www.linuxquestions.org/questi...de-4175455271/
It's the same error after installed 2.0.2 from SlackHacks.
 
Old 04-07-2013, 12:02 AM   #8
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,637

Rep: Reputation: 450Reputation: 450Reputation: 450Reputation: 450Reputation: 450
Did you have another dropbox package running?
I'm using KDE 4.10.2 on -Current and dropbox is running fine here without any problem
 
Old 04-07-2013, 02:45 AM   #9
narke
Member
 
Registered: Apr 2010
Posts: 70

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by willysr View Post
Did you have another dropbox package running?
I'm using KDE 4.10.2 on -Current and dropbox is running fine here without any problem
No. 'ps ax' tells me there is no other dropbox instance. I am running on fluxbox. The strange thing is that it had been working fine for one or two month before the error came in.

Now I am think to install GNOME, probably MATE (a GNOME clone as I know). I want to ask, after that, can I expect to run the official version of dropbox without problem?

Thanks.
-narke
 
Old 04-07-2013, 05:45 AM   #10
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,637

Rep: Reputation: 450Reputation: 450Reputation: 450Reputation: 450Reputation: 450
Yes, i'm using MATE at this moment and i can confirm that dropbox is running fine on MATE as well as in KDE or XFCE
 
Old 04-07-2013, 08:15 AM   #11
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Did you uninstall the dropbox-1.2.49-x86-1_SBo and dropbox-client-1.6.0-i386-1alien packages using removepkg before installing the dropbox 2.0.2 package?
I suspect the cause of your problem is that you were using the dropbox-1.2.49-x86-1_SBo package, then added the dropbox-client-1.6.0-i386-1alien package without removing the dropbox-1.2.49-x86-1_SBo package. As the packages do not have a common name, you probably left older files on your system.
My thought would be:
1. Uninstall the dropbox 2.0.2 package using 'removepkg'.
2. Reinstall the dropbox-client-1.6.0-i386-1alien package using 'upgradepkg --reinstall' and then uninstall using 'removepkg'.
3. Reinstall the dropbox-1.2.49-x86-1_SBo package using 'upgradepkg --reinstall' and then uninstall using 'removepkg'.
4. Reinstall the dropbox 2.0.2 package using 'upgradepkg --install-new'.
 
Old 04-07-2013, 08:27 AM   #12
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,637

Rep: Reputation: 450Reputation: 450Reputation: 450Reputation: 450Reputation: 450
FYI, i don't install dropbox clien from alien or SBo
The one provided in my slackhacks is suffice to do the job without any other components
 
Old 04-07-2013, 09:05 PM   #13
narke
Member
 
Registered: Apr 2010
Posts: 70

Original Poster
Rep: Reputation: 0
Hey, Gurus

I am so happy to report that I found out the cause. It's not because I installed any conflict package, it because I changed locale setting from en_US to zh_CN.GBK. After I set the LAND variable back to en_US, dropboxd (2.02 from SlackHacks) worked w/o problem.

Thanks for all you help! I still hope the future version of dropboxd can be more compatible with other locale settings.

-narke
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Feisty - Sound was working, but mysteriously stops working after reboot. woodsy934 Linux - Software 7 07-04-2011 07:39 PM
__attribute__ ((weak)) suddenly stops working / starts working ta0kira Programming 3 08-15-2007 12:31 PM
"USB device stops working after a time" 'fix' stops cdrom device mount/readability adamben Slackware 6 04-18-2007 02:18 PM
Mouse Stops Working nodumping14 Linux - General 3 12-02-2003 03:20 PM


All times are GMT -5. The time now is 03:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration