LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   dropboxd stops working (http://www.linuxquestions.org/questions/slackware-14/dropboxd-stops-working-4175456860/)

narke 04-04-2013 12:00 PM

dropboxd stops working
 
I used to run a dropbox daemon got from slackbuilds (Dropbox (store, sync and share files online)). I worked fine for at least two month. But since yesterday, it stopped working. I reported following errors when I launched it from command line:

----------
process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(process:16920): Gdk-CRITICAL **: IA__gdk_cursor_new_for_display: assertion `GDK_IS_DISPLAY (display)' failed

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()

(process:16920): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(process:16920): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed

(process:16920): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(process:16920): GLib-GObject-CRITICAL **: gtype.c:2722: You forgot to call g_type_init()
-------------

I didn't know what I changed in my system, but the error keeps same even after reinstalled the package.

Does anyone have a clue from above error messages?

Thanks in advance.
-woody

willysr 04-04-2013 12:45 PM

What Slackware version did you use? 14.0 or Current?
What packages did you upgrade in the last few days?

narke 04-04-2013 10:35 PM

Quote:

Originally Posted by willysr (Post 4925152)
What Slackware version did you use? 14.0 or Current?
What packages did you upgrade in the last few days?

It's 14.0. How do I know what packages I upgraded in the last few days?

T3slider 04-04-2013 10:37 PM

Code:

$ ls -lt /var/log/packages | head
shows the last 10 packages installed/upgraded, assuming you used pkgtools (installpkg/upgradepkg) to do so.

narke 04-05-2013 07:38 AM

Quote:

Originally Posted by T3slider (Post 4925440)
Code:

$ ls -lt /var/log/packages | head
shows the last 10 packages installed/upgraded, assuming you used pkgtools (installpkg/upgradepkg) to do so.

Okay, it shows:

-rw-r--r-- 1 root root 4473 Apr 5 00:52 dropbox-1.2.49-x86-1_SBo
-rw-r--r-- 1 root root 2634 Apr 4 21:10 dropbox-client-1.6.0-i386-1alien
-rw-r--r-- 1 root root 85068 Mar 20 16:42 dia-0.97.2-i486-2_SBo
-rw-r--r-- 1 root root 34693 Feb 27 13:22 draftsight-1.2.265-i386-1_SBo
-rw-r--r-- 1 root root 14558 Feb 27 13:18 nas-1.9.3-i486-2_SBo
-rw-r--r-- 1 root root 710 Feb 4 00:07 unrar-4.0.7-i486-1_SBo
-rw-r--r-- 1 root root 6731 Jan 29 09:09 lxrandr-20111224_05a11b1-i486-1_SBo
-rw-r--r-- 1 root root 5785 Dec 13 14:42 freemind-0.9.0-noarch-1_SBo
-rw-r--r-- 1 root root 13958 Dec 4 12:31 wireshark-1.8.2-i486-1_SBo


So, is there a clue? Thanks.

allend 04-05-2013 09:53 AM

I suggest you uninstall dropbox-1.2.49-x86-1_SBo and dropbox-client-1.6.0-i386-1alien and then install dropbox 2.0.2.
This thread should help. http://www.linuxquestions.org/questi...de-4175455271/

narke 04-06-2013 09:05 PM

Quote:

Originally Posted by allend (Post 4925701)
I suggest you uninstall dropbox-1.2.49-x86-1_SBo and dropbox-client-1.6.0-i386-1alien and then install dropbox 2.0.2.
This thread should help. http://www.linuxquestions.org/questi...de-4175455271/

It's the same error after installed 2.0.2 from SlackHacks.

willysr 04-06-2013 11:02 PM

Did you have another dropbox package running?
I'm using KDE 4.10.2 on -Current and dropbox is running fine here without any problem

narke 04-07-2013 01:45 AM

Quote:

Originally Posted by willysr (Post 4926641)
Did you have another dropbox package running?
I'm using KDE 4.10.2 on -Current and dropbox is running fine here without any problem

No. 'ps ax' tells me there is no other dropbox instance. I am running on fluxbox. The strange thing is that it had been working fine for one or two month before the error came in.

Now I am think to install GNOME, probably MATE (a GNOME clone as I know). I want to ask, after that, can I expect to run the official version of dropbox without problem?

Thanks.
-narke

willysr 04-07-2013 04:45 AM

Yes, i'm using MATE at this moment and i can confirm that dropbox is running fine on MATE as well as in KDE or XFCE

allend 04-07-2013 07:15 AM

Did you uninstall the dropbox-1.2.49-x86-1_SBo and dropbox-client-1.6.0-i386-1alien packages using removepkg before installing the dropbox 2.0.2 package?
I suspect the cause of your problem is that you were using the dropbox-1.2.49-x86-1_SBo package, then added the dropbox-client-1.6.0-i386-1alien package without removing the dropbox-1.2.49-x86-1_SBo package. As the packages do not have a common name, you probably left older files on your system.
My thought would be:
1. Uninstall the dropbox 2.0.2 package using 'removepkg'.
2. Reinstall the dropbox-client-1.6.0-i386-1alien package using 'upgradepkg --reinstall' and then uninstall using 'removepkg'.
3. Reinstall the dropbox-1.2.49-x86-1_SBo package using 'upgradepkg --reinstall' and then uninstall using 'removepkg'.
4. Reinstall the dropbox 2.0.2 package using 'upgradepkg --install-new'.

willysr 04-07-2013 07:27 AM

FYI, i don't install dropbox clien from alien or SBo
The one provided in my slackhacks is suffice to do the job without any other components

narke 04-07-2013 08:05 PM

Hey, Gurus

I am so happy to report that I found out the cause. It's not because I installed any conflict package, it because I changed locale setting from en_US to zh_CN.GBK. After I set the LAND variable back to en_US, dropboxd (2.02 from SlackHacks) worked w/o problem.

Thanks for all you help! I still hope the future version of dropboxd can be more compatible with other locale settings.

-narke


All times are GMT -5. The time now is 02:44 AM.