LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-08-2005, 04:35 AM   #1
slzckboy
Member
 
Registered: May 2005
Location: uk - Reading
Distribution: slack 10.2 kde 3.4.2 kernel 2.6.15
Posts: 452

Rep: Reputation: 30
drop in performance under load


Hi all.

I have noticed a drop in performance on my pc when it is under load conditions, (i.e using transcode to convert media etc..) after doing an upgrade on my system.

I have an AMD ATHLON XP+ RUNNING AT 2.13 GHZ

1.2 GHz of ram running.

geforce4 ti 4200 graphics card.

Changes:

:went from slackware 10.0 -2.4.246 to slack 10.2 - 2.6.13.

:Running kde now instead of GNOME.

:enabled HIGHMEM support into my kernel because the system was only using 720 MHz or so of memmory.

:added wifi card and configured system as an access point.
----

Under normal conditions it works ok.

i can surf /download/ watch films compile programs etc etc withought a blib.

but b4 I could do all that and probably have couple of instances of transcode running in the background aswell and it would run fine.
Now if i am using transcode everthing else is chronically slow.
even opening a terminal window might take 3 or so minutues???!
 
Old 11-08-2005, 10:50 AM   #2
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware, FreeBSD
Posts: 483

Rep: Reputation: 92
How did you customized the kernel ? Enabled highmem support only ?
Don't start any graphical envirnoment, run transcode and on another screen/terminal check resource usage with top, f.E.
Size of memory is indicated in Bytes not Hertzes
 
Old 11-08-2005, 12:34 PM   #3
slzckboy
Member
 
Registered: May 2005
Location: uk - Reading
Distribution: slack 10.2 kde 3.4.2 kernel 2.6.15
Posts: 452

Original Poster
Rep: Reputation: 30
transcode typically uses 99.9% of resources when it is run.

this was typical b4 the upgrade.?!!


yes I enabled high mem support.

ie i checcked the box that said 4GB

as opposed to 64GB or off.


re hertz

too much electronics :0)
 
Old 11-08-2005, 03:33 PM   #4
sweetnsourbkr
Member
 
Registered: Aug 2005
Location: Bay
Distribution: Zenwalk, OpenBSD, Slackware
Posts: 167

Rep: Reputation: 30
Try disabling himem and see if the problem goes away.
 
Old 11-08-2005, 04:24 PM   #5
slzckboy
Member
 
Registered: May 2005
Location: uk - Reading
Distribution: slack 10.2 kde 3.4.2 kernel 2.6.15
Posts: 452

Original Poster
Rep: Reputation: 30
yeah.. for some reason I seem to remember reading that enabling highmem can actually de-grade performance.?!??


I will give it a $bash.
 
Old 11-08-2005, 06:47 PM   #6
bird603568
Member
 
Registered: Aug 2004
Distribution: Slackware current
Posts: 250

Rep: Reputation: 30
Well I have 2 gigs of ram, and with out HIGHMEM, you can only use a little over 800megs of ram. So if you have under a gig disable it.
 
Old 11-09-2005, 04:56 AM   #7
slzckboy
Member
 
Registered: May 2005
Location: uk - Reading
Distribution: slack 10.2 kde 3.4.2 kernel 2.6.15
Posts: 452

Original Poster
Rep: Reputation: 30
no same.

i have over a gig,just

1.2 GB.

Its got to be KDE ???

KDE seems alot more flashy than my previos gnome install from 10.0

this must eat up more resources ,no ?
 
Old 11-09-2005, 09:36 AM   #8
bird603568
Member
 
Registered: Aug 2004
Distribution: Slackware current
Posts: 250

Rep: Reputation: 30
I don't notice a difference between DLG and kde 3.4.2 But i did enable preloading and disabled a bunch of kde's daemons. Could it be the kernel? Because I noticed that 2.6.14 seems to manage my ram better than 2.6.12.5
 
Old 11-09-2005, 12:25 PM   #9
slzckboy
Member
 
Registered: May 2005
Location: uk - Reading
Distribution: slack 10.2 kde 3.4.2 kernel 2.6.15
Posts: 452

Original Poster
Rep: Reputation: 30
it could be..

I may try 2.6.14.

I loaded gnome by the way.


no joy just the same under that environment.

yup.

i think i will try another kernel.
 
Old 11-09-2005, 12:30 PM   #10
slzckboy
Member
 
Registered: May 2005
Location: uk - Reading
Distribution: slack 10.2 kde 3.4.2 kernel 2.6.15
Posts: 452

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by bird603568
But i did enable preloading and disabled a bunch of kde's daemons. .
could you kindly advise how i can control which of kde's daemons run at start up.
And scuse my ignorance,but what is preloading?

thnks in advance.
 
Old 11-10-2005, 05:58 PM   #11
slzckboy
Member
 
Registered: May 2005
Location: uk - Reading
Distribution: slack 10.2 kde 3.4.2 kernel 2.6.15
Posts: 452

Original Poster
Rep: Reputation: 30
new kernel has fixed this,,but now alsa will not re-compile.....

but thats for another thread.

u plug one hole,then u spring a leak else where ;0)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Drop connections to port 80 at firewall machine also drop at protected network? Niceman2005 Linux - Security 2 10-27-2005 09:21 AM
Redhat AS3.0 performance drop yuhuashi Red Hat 1 05-29-2005 08:15 AM
drop line jmdlcar Slackware 2 03-14-2005 12:28 AM
iptables - drop all -> allow needed OR allow all -> drop specific lucastic Linux - Security 5 12-21-2004 03:07 AM
netstat... Now can I drop? Half_Elf Linux - Security 5 07-21-2002 12:16 PM


All times are GMT -5. The time now is 01:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration