LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-19-2003, 04:04 PM   #1
jamescov
LQ Newbie
 
Registered: Aug 2003
Location: Texas USA
Distribution: SuSE 9.1 (Download Ed.)
Posts: 27

Rep: Reputation: 15
Drivers loaded at bootup


Hi everyone,

I just did an install of slackware 9.1 on my laptop. The system boots fine, but during boot up insmod is trying to load modules for devices I don't have on my computer. My question is this, What file do I need to edit in slackware to remove these invalid entries?

Thanks,
James
 
Old 10-19-2003, 04:13 PM   #2
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
You have a number of options to do this. I think that specifying all modules you want to load manually is the fastest and easiest. You can do that by listing the modules you use at that moment (lsmod) and specify them in /etc/rc.d/rc.modules by adding lines like
/sbin/modprobe name-of-the-module
After you did that, remove the execute rights of /etc/rc.d/rc.hotplug . That should do it I think.
 
Old 10-19-2003, 04:19 PM   #3
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
hotplug is probably trying to do this and there is no file that tells it "what" to load, but u can tell hotplug what NoT tO lOaD

edit /etc/hotplug/blacklist with your favorite editor (u will need to be root) and place the name of the module (without the .o or .c or whatever) on some new line anywhere in the file

make sure the line does NOT have a # before it (i did that and took me two days to figure out why the module i810_rng was still loading)


*edit: if u find that hotplug is a pain, then the above poster's way would work (just make sure u find out what modules hotplug is loading by doing lsmod and then put modprobe module module module in /etc/rc.d/rc.local; u can list the modules on one line)
also, to remove execution rights, i believe the command is chmod -x /etc/rc.d/rc.hotplug

i usually just edit rc.M and comment out the section for hotplug by placing # in front of all the commands

Last edited by TheOneAndOnlySM; 10-19-2003 at 04:22 PM.
 
Old 10-19-2003, 04:53 PM   #4
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
The right place for loading modules is not rc.local but rc.modules. You can do that in rc.local but there is a special script for it. Adding all the modules you don't want to be tested in the blacklist of hotplug could be a lot of work, I think adding the modules you do want is a much better way of doing that. And there's no need to edit rc.M because it starts scripts after testing if they are executable. If not, they will not be started. That's why I prefer to remove the execute rights of a startup script.

When using /sbin/modprobe <modulename> dependencies of that specific module will be resolved automaticly.

But there are many ways to solve certain problems. That's one of the things I like about Linux.
 
Old 10-19-2003, 04:53 PM   #5
Posty
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 62

Rep: Reputation: 15
I think I am haveing a similar problem. Whenever I boot I get some errors about a module not being able to load or something... "dmesg" gives me this, "i810_rng: RNG not detected".

Do I just add "i810_rng" to the blacklist file?
 
Old 10-19-2003, 07:17 PM   #6
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
yes Posty, this is exactly the thing hotplug was trying to load for my system

just add i810_rng to the blacklist file
 
Old 10-19-2003, 07:33 PM   #7
jamescov
LQ Newbie
 
Registered: Aug 2003
Location: Texas USA
Distribution: SuSE 9.1 (Download Ed.)
Posts: 27

Original Poster
Rep: Reputation: 15
I have looked in the files suggested, but I'm not able to find any reference to IRDA which is what I'm attempting to disable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ds: no socket drivers loaded shanenin Linux - Software 0 09-12-2004 03:20 PM
hardware drivers loaded explorer Linux - Networking 3 04-11-2004 05:36 AM
nvidia drivers loaded. I think. Flaystus Linux - Newbie 2 02-23-2004 08:34 PM
ds: no socket drivers loaded John Newbie Linux - Networking 3 11-26-2003 08:13 PM
ds: no socket drivers loaded sancho5 Linux - General 1 07-22-2001 07:59 PM


All times are GMT -5. The time now is 02:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration