LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-11-2011, 03:02 PM   #1
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,277

Rep: Reputation: 187Reputation: 187
"DOS support unavailable"


For years, and up to and including this morning, I've been running a old Windows program, The American Heritage Electronic Dictionary, in WINE.
This a.m. I installed the latest current changes and all was well. I then install all of Multilib changes and the 32compat packages and now when I try and fire up the above mentioned program I get the following error:

Code:
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
winevdm: unable to exec 'C:\AHDW\AHD3.EXE': DOS support unavailable
Any ideas on how to fix this would be appreciated.
Thanks.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 01-11-2011, 03:44 PM   #2
TheCrow33
Member
 
Registered: Aug 2009
Posts: 81

Rep: Reputation: 8
shot in the dark here, have you reinstalled wine since you did the multilib updates? I believe I had a problem with this a while ago.
 
Old 01-11-2011, 03:48 PM   #3
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,277

Original Poster
Rep: Reputation: 187Reputation: 187
Quote:
Originally Posted by TheCrow33 View Post
shot in the dark here, have you reinstalled wine since you did the multilib updates? I believe I had a problem with this a while ago.
Yes, I tried that, but thanks for the suggestion.
 
Old 01-11-2011, 04:25 PM   #4
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 877

Rep: Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827Reputation: 1827
Quote:
Originally Posted by cwizardone View Post
This a.m. I installed the latest current changes and all was well. I then install all of Multilib changes and the 32compat packages and now when I try and fire up the above mentioned program I get the following error:

Code:
preloader: Warning: failed to reserve range 00010000-00110000
preloader: Warning: failed to reserve range 00010000-00110000
winevdm: unable to exec 'C:\AHDW\AHD3.EXE': DOS support unavailable
This is very likely due to an increase in the default CONFIG_MIN_MMAP_ADDR. Previously it was set to 4096, and possibly WINE had learned to work around that restriction.

It will probably work again (after a reboot) if you create or edit /etc/sysctl.conf with this contents:
vm.mmap_min_addr=0

To make the change from the command line as root: sysctl vm.mmap_min_addr=0

Note that this will open up a whole range of possible kernel attacks that can allow local users to root your machine.
 
9 members found this post helpful.
Old 01-11-2011, 07:35 PM   #5
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,277

Original Poster
Rep: Reputation: 187Reputation: 187
Quote:
Originally Posted by volkerdi View Post
This is very likely due to an increase in the default CONFIG_MIN_MMAP_ADDR. Previously it was set to 4096, and possibly WINE had learned to work around that restriction.

It will probably work again (after a reboot) if you create or edit /etc/sysctl.conf with this contents:
vm.mmap_min_addr=0

To make the change from the command line as root: sysctl vm.mmap_min_addr=0

Note that this will open up a whole range of possible kernel attacks that can allow local users to root your machine.
That worked.
Thank you very much, Mr. Volkerding!
Greatly appreciated!
 
Old 05-20-2011, 03:55 AM   #6
masbroe
LQ Newbie
 
Registered: May 2011
Posts: 1

Rep: Reputation: Disabled
Thumbs up

Quote:
Originally Posted by volkerdi View Post
This is very likely due to an increase in the default CONFIG_MIN_MMAP_ADDR. Previously it was set to 4096, and possibly WINE had learned to work around that restriction.

It will probably work again (after a reboot) if you create or edit /etc/sysctl.conf with this contents:
vm.mmap_min_addr=0

To make the change from the command line as root: sysctl vm.mmap_min_addr=0

Note that this will open up a whole range of possible kernel attacks that can allow local users to root your machine.
Thanks Mr. Pat,
worked for me without reboot.
 
Old 05-20-2011, 05:57 AM   #7
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.1
Posts: 634
Blog Entries: 2

Rep: Reputation: 97
Quote:
Originally Posted by volkerdi View Post
note that this will open up a whole range of possible kernel attacks that can allow local users to root your machine.
ewwwww!
 
Old 05-21-2011, 12:16 AM   #8
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,277

Original Poster
Rep: Reputation: 187Reputation: 187
Not a problem if it is a standalone box.
 
Old 05-21-2011, 01:28 AM   #9
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 855

Rep: Reputation: Disabled
warning: compltetly off-topic.
Is it the real Pat Volkerding? Good Lord, it is mindblowing to know that you post in this forum. Really out of words to express my emotions. All I can really think of saying here is thankyou for slackware.
 
Old 05-21-2011, 01:29 AM   #10
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by SilverBack View Post
warning: compltetly off-topic.
Is it the real Pat Volkerding? Good Lord, it is mindblowing to know that you post in this forum. Really out of words to express my emotions. All I can really think of saying here is thankyou for slackware.
It is indeed Pat. Several of the Slackware team are regular posters here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"FUTEX WAIT EAGAIN (Resource temporarily unavailable )" jungbg Linux - Newbie 1 12-22-2009 06:07 PM
xine "Audio output unavailable. Device is busy." shellshock Linux - Software 3 05-13-2006 01:19 PM
Cedega from Fat32 (Invalid path "." given for "--use-dos-cwd") bdox Linux - Software 0 03-30-2005 12:24 PM
Cedega and Fat32 (Invalid path "." given for "--use-dos-cwd") bdox Linux - Games 0 03-26-2005 03:48 AM
SCSI Device unavailable after firmware download. Redhat or "sg" issue? jrvance Linux - Hardware 2 10-21-2003 02:41 PM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration