LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   don't work sound (http://www.linuxquestions.org/questions/slackware-14/dont-work-sound-4175458107/)

yasu 04-14-2013 10:35 AM

don't work sound
 
Hi, all.

I'm using slackware version 14.0 on lenovo X121e.
I want to listen music for cmus.

but don't work sound.

Could you please teach me the resolve.

# lspci |grep -i audio
================================
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
=========================================

kingbeowulf 04-14-2013 08:14 PM

"High Definition Audio Controller" might be your HDMI audio and not the analog audio. When you run "lspci" do you get a "multimedia" entry? It might be part of the Intel chipset or another manufacturer.

Did you check settings with alsamixer and do you get audio channels other than "null" with aplay -L and are the driver modules loaded when you run lsmod ? And I assume you plugged in speakers or unmuted the internal speakers if they have a hardware switch?

slack_rick 04-14-2013 10:22 PM

Arch linux has a very in depth wiki for troubleshooting sound https://wiki.archlinux.org/index.php/ALSA . Are you trying to use built-in speakers, analog or HDMI output?

yasu 04-17-2013 10:45 AM

Thank you for your response!

lspci command isn't nothing.

aplay command
------------------------------------------
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
----------------------------------------------

When i try to 'alsactl init' command, working sound.


All times are GMT -5. The time now is 10:22 AM.