LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-14-2013, 10:35 AM   #1
yasu
LQ Newbie
 
Registered: Jun 2009
Posts: 12

Rep: Reputation: 0
don't work sound


Hi, all.

I'm using slackware version 14.0 on lenovo X121e.
I want to listen music for cmus.

but don't work sound.

Could you please teach me the resolve.

# lspci |grep -i audio
================================
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
=========================================
 
Old 04-14-2013, 08:14 PM   #2
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 526

Rep: Reputation: 140Reputation: 140
"High Definition Audio Controller" might be your HDMI audio and not the analog audio. When you run "lspci" do you get a "multimedia" entry? It might be part of the Intel chipset or another manufacturer.

Did you check settings with alsamixer and do you get audio channels other than "null" with aplay -L and are the driver modules loaded when you run lsmod ? And I assume you plugged in speakers or unmuted the internal speakers if they have a hardware switch?
 
Old 04-14-2013, 10:22 PM   #3
slack_rick
LQ Newbie
 
Registered: Apr 2013
Location: Florida,
Distribution: Slackware 64 Current - Slackware 14 x86_64
Posts: 9
Blog Entries: 1

Rep: Reputation: Disabled
Arch linux has a very in depth wiki for troubleshooting sound https://wiki.archlinux.org/index.php/ALSA . Are you trying to use built-in speakers, analog or HDMI output?
 
1 members found this post helpful.
Old 04-17-2013, 10:45 AM   #4
yasu
LQ Newbie
 
Registered: Jun 2009
Posts: 12

Original Poster
Rep: Reputation: 0
Thank you for your response!

lspci command isn't nothing.

aplay command
------------------------------------------
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
----------------------------------------------

When i try to 'alsactl init' command, working sound.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My sound don't work, I have Kubuntu 7.10 and sound blaster 5.1 Zuror Linux - Hardware 1 04-12-2008 09:27 AM
Sound Don't work!!! Sjellest Linux - Newbie 2 04-29-2006 09:27 AM
Sound players don't work stevesk Suse/Novell 2 08-01-2005 06:35 PM
Onborad sound donīt work!!! HELP GSX Debian 26 03-08-2005 05:24 AM
Sound don't work X11 Slackware 6 07-10-2002 09:48 AM


All times are GMT -5. The time now is 05:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration