LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-20-2005, 08:09 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Does Samba ignores the mount 'quiet' option?


While configuring Samba on Box 2 to mount some NTFS partitions located on Box 1, I ran across a seemingly common error message from Konqueror. While using Konqueror to copy a file from my normal user's home directory to a shared NTFS-4 directory, Konqueror popped up a message that it could not change permissions.

I configured this particular shared NTFS Windows partition for full read/write permissions.

Suspecting that this message might be solely related to mounting permissions and not specific to Konqueror, I copied another file using the command line cp command. No error messages, so I then tried cp -p and sure enough I receive a similar error message.

Some surfing revealed that just about everybody reporting this problem does so only with FAT32 partitions. One solution offered is to include the quiet option in the mount command. I do have a shared FAT32 partition on my Windows NT4 box, and I had hoped that I could stop the error messages at least when mounting that partition. I tried the quiet option, but received the same error messages.

I also tried to no avail mounting with the noatime option.

All of this makes sense, of course, at least for "dumb" FAT32 file partitions. However, NTFS is a journaling file system and does track additional time stamps not maintained in FAT32. I would suspect that when copying files to an NTFS partition that the error messages would disappear, but that is not the case.

My mount command looks like this:

mount -t smbfs //box1/share_name /mnt/nt_share_name -o rw,quiet,credentials=/etc/samba/private/credentials,fmask=774,dmask=774,gid=users

The only way I can eliminate the messages is to mount the shared NTFS and FAT32 partitions as the user who actually does the file manipulations. Setting the gid option when mounting does not eliminate the messages. I must mount using the uid option as well if I hope to stop the nuisance.

From a personal perspective, mounting with uid is not a critical issue for me because I am the sole user and I have only two boxes in my simple network. Still, I prefer to learn and practice administrative skills as though I am maintaining numerous user accounts and boxes.

Specifically, Samba seems to be the culprit here by ignoring the quiet option. I realize that the quiet option applies only to FAT32 (vfat) partitions, but there seems to be no remedy for NTFS partitions either.

Please realize that I understand that the messages are normal and expected. I'm merely seeking a way to quiet or ignore the messages. I am having a challenging time believing that with all the people in this world using Samba that everybody tolerates and ignores this problem. Thus, I am more inclined to believe that a solution exists.

Otherwise, moving, copying, editing files, etc. all work just fine. The messages are merely a nuisance, but has anybody found any remedies?
 
Old 12-21-2005, 11:22 PM   #2
centauricw
Member
 
Registered: Dec 2005
Location: Lawrenceville GA
Distribution: Slackware, CentOS. Red Hat Enterprise Linux
Posts: 216

Rep: Reputation: 31
Windows network file shares do not work like NFS file shares. The fmask, dmask, uid and gid options are all designed to provide the necessary Linux file permissions to the this foriegn file system. They do not affect the NTFS or FAT32 partition on the remote server. The username that you used in the credentials file is the user that Windows uses to determine permissions and ownership for the NTFS partition. For example, if you used a user account that had read-only permission to the NTFS file system, you would not be able to create, modify or delete files even though you specified the rw option in the mount command because the Windows user can't either.

Nor do changing of permissions work. The Linux chmod function doesn't traslate to the Windows world and it always fails on an SMB mounted file system. The quiet option only surpresses messages generated when mounting the Windows file system but not when you operate on it, which is why you are always seeing these annoying messages.

I hope this helps.
 
Old 12-22-2005, 05:47 AM   #3
richcoosa19
Member
 
Registered: Nov 2002
Location: Rome, GA, USA
Distribution: Slackware 10.1 and Gentoo 2005.1 from Stage 1
Posts: 84

Rep: Reputation: 15
You need to add umask=0222 to your -o's I believe.
 
Old 12-22-2005, 01:26 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Original Poster
Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
The Linux chmod function doesn't translate to the Windows world and it always fails on an SMB mounted file system. The quiet option only surpresses messages generated when mounting the Windows file system but not when you operate on it, which is why you are always seeing these annoying messages.
Yes, that the chmod command does not translate is understandable. However, your answer implies that people who use Samba nonetheless tolerate these nuisance error messages. Strange. After all these years that Samba has been used, I'm surprised and scratching my head that the Samba maintainers do not provide a quiet option to suppress these messages, or simply route chmod operations on Windows shares to the bit bucket. Very strange. Then again, if I have learned anything about the 'nix way of thinking the past few years, I've learned that usability is not always a priority, which is one reason why 'nix remains relatively unpopular among the masses. Just my opinion, of course.
 
Old 12-22-2005, 10:26 PM   #5
centauricw
Member
 
Registered: Dec 2005
Location: Lawrenceville GA
Distribution: Slackware, CentOS. Red Hat Enterprise Linux
Posts: 216

Rep: Reputation: 31
It's usually good form to report back to the calling program if something doesn't work. But I wondering if the -p option is being automatically appended to your cp command by an environment variable. I generally don't see any error messages when copying to a SMB mounted share.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can mount C not D FAT: invalid media value (0x45) mount: wrong fs type, bad option Emmanuel_uk Linux - Newbie 10 11-29-2005 02:47 AM
CUPS ignores option "-o outputorder=reverse" umk Linux - Newbie 0 06-14-2005 05:51 PM
Fluxbox Menu option for 'Mount' TomalakBORG Linux - Software 9 05-18-2005 12:37 PM
Samba/Win2K printing ignores print quantity ahz10 Linux - Software 0 05-17-2005 06:36 PM
quiet mount flag? veritas Slackware 0 09-18-2003 05:19 PM


All times are GMT -5. The time now is 05:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration