LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   dmesg hda errors - What is up with these?? (http://www.linuxquestions.org/questions/slackware-14/dmesg-hda-errors-what-is-up-with-these-168945/)

Nichole_knc 04-11-2004 08:19 PM

dmesg hda errors - What is up with these??
 
The following are the errors in question. They appeared before a kernel build and after even though I thought I addressed this in the kernel config process...

hda: WDC AC33200L, ATA DISK drive * western digital HD *

hda: attached ide-disk driver.
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: 6346368 sectors (3249 MB) w/256KiB Cache, CHS=787/128/63

I current have no problems with my install BUT an error is an error. I have had no luck thus far...Any ideas??

jong357 04-11-2004 08:36 PM

Linux Kernel v2.4.25 Configuration
──────────────────────────────────────────────────────────────────────────────
┌─────────────────────── Use multi-mode by default ───────────────────────┐
│ CONFIG_IDEDISK_MULTI_MODE:

│ If you get this error, try to say Y here:

│ hda: set_multmode: status=0x51 { DriveReady SeekComplete Error }
│ hda: set_multmode: error=0x04 { DriveStatusError }

│ If in doubt, say N.








├─────────────────────────────────────────────────────────────────(100%)──┤
│ < Exit >
└─────────────────────────────────────────────────────────────────────────┘

:D
It could help... Just a guess tho... multi-mode in your kernel config is under the

ATA/IDE/MFM/RLL support --->

heading.... I assume you are using your drives ATAPI native interface instead of emulating SCSI...
Oh..... Sorry... Thought you were refering to your Cd-rom... Doesn't matter tho... Thats an All-in-one option that is not specific to any one device.....

Nichole_knc 04-11-2004 10:06 PM

Yes I have multi-mode set... I thought that may have helped also... :( nope...

jong357 04-12-2004 03:07 PM

Hmmm.... I'm fresh out of obvious ideas then.... :( Sorry. I had assumed you did that. Was just checking.

Maybe you could run some hdparm optimizations in rc.local with a -k switch... Just a wild guess.... maybe keeping some good dma settings that work with your drive will quell dmesg everytime you reboot. Wouldn't work on a cold boot tho....

/usr/sbin/hdparm -c1 -d1 -A1 -a128 -u1 -m16 -X69 /dev/hda

That's what I run. Maybe just a

/usr/sbin/hdparm -d1 -m16 -k1 /dev/hda

in rc.local would be a good test run to see if it works...


All times are GMT -5. The time now is 04:45 PM.