LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-22-2006, 10:42 PM   #1
davimint
Member
 
Registered: Jan 2006
Distribution: Slackware Current
Posts: 272

Rep: Reputation: 33
Dma & Udma


I've had this problem on every Slackware install using the 2.4 kernel since I've started using Slackware. I get a message on boot that says my DMA is turned off and this may slow down fsck process. Normal I just build a 2.6 kernel with support for SMP and it goes away. For some reason I wanted to use the 2.4 kernel for a while this time but I hate seeing the above mentioned message.

Code:
/dev/hda:

 Model=HDT722525DLAT80, FwRev=V44OA70A, SerialNo=VDL41BT4DBA2TU
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=51
 BuffType=DualPortCache, BuffSize=7674kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=268435455
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: ATA/ATAPI-7 T13 1532D revision 1:  ATA/ATAPI-2 ATA/ATAPI-3 ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6 ATA/ATAPI-7

 * signifies the current active mode

As I just posted above it looks like my harddrive supports UDMA and does not use the DMA mode. I guess I get that message because UDMA is what my drive supports.

Does a harddrive support both DMA & UDMA or do I have an issue that needs to be fixed ?

Can I make Slackware stop giving me the message if everything is ok?

Any help in explaining this would be great since I'm not hardware savvy.

Thanks.

Last edited by davimint; 10-22-2006 at 11:04 PM.
 
Old 10-23-2006, 01:44 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
UDMA is Ultra DMA, eh?

So as root maybe you can turn on DMA then put the line that works
for your box into /etc/rc.d/rc.local?
 
Old 10-23-2006, 07:33 AM   #3
davimint
Member
 
Registered: Jan 2006
Distribution: Slackware Current
Posts: 272

Original Poster
Rep: Reputation: 33
Yes, but why the message on boot ? Is there an option that needs to be built in the kernel on the 2.4.33.3. bareacpi.i kernel provided with slackware that was missed for my hardware or what ?
Here's some more info.
Code:
bash-3.1# hdparm -d1 /dev/hda

/dev/hda:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)
Also, the output on hdparm -Tt /dev/hda on this partition is
Timing cahed reads 1470.00 MB/Sec
Timing buffered disk reads: 2.80 MB/sec

compared to another partition on this same computer with a custom built kernel as:
Timing cach reads: 1467.69 MB/sec
Timing buffered disk reads: 66.57 MB/sec

As you can see the buffered disk is way off in speed.

Last edited by davimint; 10-23-2006 at 07:59 AM.
 
Old 10-23-2006, 08:35 AM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,392
Blog Entries: 3

Rep: Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480Reputation: 1480
Quote:
Originally Posted by davimint
I've had this problem on every Slackware install using the 2.4 kernel since I've started using Slackware. I get a message on boot that says my DMA is turned off and this may slow down fsck process. Normal I just build a 2.6 kernel with support for SMP and it goes away. For some reason I wanted to use the 2.4 kernel for a while this time but I hate seeing the above mentioned message.

Code:
/dev/hda:

 Model=HDT722525DLAT80, FwRev=V44OA70A, SerialNo=VDL41BT4DBA2TU
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=51
 BuffType=DualPortCache, BuffSize=7674kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=268435455
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: ATA/ATAPI-7 T13 1532D revision 1:  ATA/ATAPI-2 ATA/ATAPI-3 ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6 ATA/ATAPI-7

 * signifies the current active mode

As I just posted above it looks like my harddrive supports UDMA and does not use the DMA mode. I guess I get that message because UDMA is what my drive supports.

Does a harddrive support both DMA & UDMA or do I have an issue that needs to be fixed ?

Can I make Slackware stop giving me the message if everything is ok?

Any help in explaining this would be great since I'm not hardware savvy.

Thanks.
Hi,

First, your drive showes that the support for all the displayed drive parameters of the hdparm. The * denotes the the active mode.

Man hdparm to understand the switches.

For the 'i' switch from 'man hdparm'

Quote:
-i Display the identification info that was obtained from the drive at boot time, if available. This is a feature of modern IDE drives, and may not be supported by older devices. The data returned may or may not be current, depending on activity since booting the system.
Code:
hardparm -I /dev/hda            #get user friendly output
You should be able to understand this output better.

The 2.4.33 kernel supports most popular and standard ide, you might have to compile your own to use your ide controller if the problem persists.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4: Best performance & DMA Jose Rivas Fedora 0 10-06-2006 02:14 PM
Slackware10.2 &dma unifiedquarks Slackware 3 12-14-2005 02:46 AM
dma timeout expiry - slack 9.1, via vt8235 on abit kd7, maxtor udma skarim Linux - Hardware 1 10-11-2003 11:34 AM
Suse 8.2 change my DMA setting on my DVD-R drive to off & IDE DMA MODE NOT SHOWING IT maximalred Linux - General 0 08-23-2003 05:58 AM
DMA & Slow hard driver performance Stevetgn Linux - Newbie 5 06-24-2003 07:30 PM


All times are GMT -5. The time now is 10:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration