LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-10-2004, 07:14 PM   #1
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Unhappy display power management in kde 3.1 on slackware 9.1


this box had mandrake 9.1 before, and the display's power managment on kde 3.1 worked fine (if it was set to suspend the monitor after 30 minutes of inactivity, it would)...

i installed slackware 9.1 and it seems the settings for the display's power management (in the display power control section of kde's control center) are having no effect...

the monitor just stays on like normal...


does anybody know what could be causing this???

thanks for your help guys!!!



Last edited by win32sux; 04-10-2004 at 07:27 PM.
 
Old 04-10-2004, 08:59 PM   #2
auditek747
Member
 
Registered: Feb 2004
Location: Ohio, USA
Distribution: Arch Linux
Posts: 464

Rep: Reputation: 30
Are you loading the "APM" module at boot?
 
Old 04-11-2004, 05:50 PM   #3
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
hello auditek747, thanks for replying...

i'm not loading the APM module, i am using ACPI, and the acpid daemon is running...

doing a "modprobe apm" generates errors:

/lib/modules/2.4.24/kernel/arch/i386/kernel/apm.o.gz: init_module: No such device
/lib/modules/2.4.24/kernel/arch/i386/kernel/apm.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.24/kernel/arch/i386/kernel/apm.o.gz: insmod /lib/modules/2.4.24/kernel/arch/i386/kernel/apm.o.gz failed
/lib/modules/2.4.24/kernel/arch/i386/kernel/apm.o.gz: insmod apm failed

but i guess these errors are due to my kernel/board being acpi... right???

the mandrake that had this display power management working was also using acpi...
 
Old 04-11-2004, 10:21 PM   #4
auditek747
Member
 
Registered: Feb 2004
Location: Ohio, USA
Distribution: Arch Linux
Posts: 464

Rep: Reputation: 30
Hey there,
I run Slack 9.1 on my desktop and laptop both. The only time I tried acpi was on my lap and I couldn't get it working right. (though I didn't try very hard)
Currently I boot the non acpi kernel on both machines and have uncommented the /sbin/modprobe apm line in /etc/rc.d/rc.modules.
This gives me display power management in KDE, autoshutdown, and even the battery monitor and some fan control in my old Gateway laptop.
As far as acpi goes, I noticed /etc/X11/XF86Config has options for dpms. Mine are commented out by default but perhaps acpi needs them uncommented. I don't know if this is the case but it's something to try.
If your only current concern though is dpms in KDE, then apm will give it to you.

see ya
 
Old 04-12-2004, 03:36 AM   #5
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
okay i just tried using the "bare.i" kernel instead of the "bareacpi.i" i was running...

i uncommented "/sbin/modprobe apm" in my "/etc/rc.d/rc.modules", made "/etc/rc.d/rc.acpid" non-executable, and i disabled acpi in my bios...

the system loaded the new kernel and the apm module without errors...

however, the problem remains... kde's dpms has no effect...

=(


this is starting to get freaky...


oh, and before switching kernels, i uncommented one of the dpms lines in my "/etc/X11/XF86Config" and no effect either... i'll try doing that (and other stuff, including whatever else you can suggest) with this regular ide kernel tomorrow...

i'm so sleepy right now...

=)


thanks for the support you're givin' me auditek747... i really appreciate it...


Last edited by win32sux; 04-12-2004 at 03:39 AM.
 
Old 04-12-2004, 09:12 AM   #6
tigerflag
Member
 
Registered: Aug 2002
Location: Phoenix, AZ
Distribution: PCLinuxOS 2012.08
Posts: 428

Rep: Reputation: 30
I had the same problem, using the bare.i kernel with APM module uncommented, etc... Here's what worked:

edit your /etc/X11/XF86Config file as follows:

Graphics Device section > Section Device

add the line:

Option: "DPMS"

Mine looks like:

Section "Device"
Identifier "NVIDIA GeForce"
Driver "nvidia"
Option "DPMS"
#VideoRam 32768
# Insert Clocks lines here if appropriate
EndSection

HTH,
Siri Amrit

Last edited by tigerflag; 04-12-2004 at 09:14 AM.
 
Old 04-12-2004, 09:53 AM   #7
auditek747
Member
 
Registered: Feb 2004
Location: Ohio, USA
Distribution: Arch Linux
Posts: 464

Rep: Reputation: 30
Hey,
Tigerflag is right! My XF86Config is the same, I missed that... for shame.
I hope that works for you!
I will be getting the new Slack when it comes around, maybe I'll try acpi again when I install.


see ya
 
Old 04-12-2004, 01:18 PM   #8
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
IT WORKED!!!

i added that line (Option "DPMS") to my card's entry (i also use official nvidia drivers, by the way) in my "/etc/X11/XF86Config" and my monitor is now suspending properly...

THANKS SO MUCH YOU GUYS!!! I AM FOREVER GRATEFUL.!!!

=)
 
Old 04-13-2004, 09:13 AM   #9
tigerflag
Member
 
Registered: Aug 2002
Location: Phoenix, AZ
Distribution: PCLinuxOS 2012.08
Posts: 428

Rep: Reputation: 30
Glad it helped :-) It was some genius in this forum that originally posted that trick. Display power management was the only thing I couldn't get to work, that had me leaning towards going back to Mandrake. Needless to say, I'm backing up this configuration file and some others from /etc before I try an upgrade...

Siri Amrit
 
Old 04-13-2004, 10:30 AM   #10
auditek747
Member
 
Registered: Feb 2004
Location: Ohio, USA
Distribution: Arch Linux
Posts: 464

Rep: Reputation: 30
This is a pretty good forum.
The search button alone has answered just about every question I've ever had!
 
Old 05-16-2004, 10:07 AM   #11
rimcrazy
Member
 
Registered: Dec 2003
Location: Overgaard, AZ
Distribution: Suse 10.0, FC5, RHEL4
Posts: 32

Rep: Reputation: 15
Quote:
Originally posted by tigerflag
Glad it helped :-) It was some genius in this forum that originally posted that trick. Display power management was the only thing I couldn't get to work, that had me leaning towards going back to Mandrake. Needless to say, I'm backing up this configuration file and some others from /etc before I try an upgrade...

Siri Amrit
Thanks much. This worked on my Inspiron 5K laptop. I just loaded Suse 9.1 and could not figure out why the monitor would not shut off after I enabled everything. Worked like a champ.

Phil
 
Old 02-07-2005, 06:58 AM   #12
rettich
LQ Newbie
 
Registered: Feb 2005
Posts: 2

Rep: Reputation: 0
Thx!!

Tried many things to get DPMS working. The strange thing is that DPMS worked out of the box with Suse 9.0 not with Suse 9.1

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
display power management: yes or no? navarre9 Linux - Laptop and Netbook 4 09-23-2004 07:34 AM
Gnome display power management broken in suse 9. 1 nbcthreat Linux - Software 2 07-11-2004 09:30 PM
Display Power Management problem on Slack 10! stef52 Slackware 2 07-01-2004 04:30 PM
Display Power Management won't work TazG Linux - Hardware 4 06-18-2004 08:58 AM
KDE 3.1 power management jonfa Linux - General 2 02-24-2004 12:37 PM


All times are GMT -5. The time now is 03:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration