LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-27-2011, 05:46 PM   #1
patostevens
Member
 
Registered: Dec 2007
Location: Kennewick,WA
Distribution: Slackware 14
Posts: 170

Rep: Reputation: 21
display chinese characters in file browser


Using Fluxbox, have tried this in XFCE and KDE. Chinese characters display properly in whatever browser I use online. I do need to see some in the file manager and this is not working. I have installed the following chinese display files from Slack -
kde-l10n-zh_CN-4.4.3-noarch-1.txz
kde-l10n-zh_TW-4.4.3-noarch-1.txz
wqy-zenhei-font-ttf-0.8.38_1-noarch-1.txz

No results so far. What am I missing here?

Last edited by patostevens; 01-29-2011 at 09:52 PM.
 
Old 01-27-2011, 05:49 PM   #2
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,238

Rep: Reputation: 1299Reputation: 1299Reputation: 1299Reputation: 1299Reputation: 1299Reputation: 1299Reputation: 1299Reputation: 1299Reputation: 1299
Have you edited /etc/profile.d/lang.sh and set your $LANG variable to something other than en_US? en_US.UTF-8, perhaps?
 
Old 01-27-2011, 06:46 PM   #3
patostevens
Member
 
Registered: Dec 2007
Location: Kennewick,WA
Distribution: Slackware 14
Posts: 170

Original Poster
Rep: Reputation: 21
Thanks Dugan. I did as you suggested and now am getting a few chinese characters and then a lot of black diamonds with a question mark in the center of them. Better than before but didn't quite cure the problem.
 
Old 01-27-2011, 10:02 PM   #4
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Generally Qt programs have very good support for different character sets. It could be that you need to find a font with better Chinese support. Try KDE's system settings to see if changing things works. kde-l10n-zh only gives you KDE in the Chinese language, you don't need it to actually see Chinese text or filenames.
 
Old 01-28-2011, 09:56 AM   #5
patostevens
Member
 
Registered: Dec 2007
Location: Kennewick,WA
Distribution: Slackware 14
Posts: 170

Original Poster
Rep: Reputation: 21
I probably wasn't clear enough to start with. My specific need is to be able to see chinese filenames with the native characters in them. (Got to do with some files for a Kindle.) I have tried running kde and using dolphin and got no different results.
 
Old 01-28-2011, 07:52 PM   #6
patostevens
Member
 
Registered: Dec 2007
Location: Kennewick,WA
Distribution: Slackware 14
Posts: 170

Original Poster
Rep: Reputation: 21
Tried the system settings in KDE - no luck. All I need to do is see some filenames in the file manager. Any suggestions?
 
Old 01-29-2011, 01:02 AM   #7
linuxs64
Member
 
Registered: Jun 2010
Posts: 93

Rep: Reputation: 39
edit /etc/profile.d/lang.sh

Quote:
# en_US is the Slackware default locale:
# export LANG=en_US
export LANG=en_US.UTF-8
You need to logout and log in to see the effect.

I don't use KDE, maybe try another file manager such as thunar. It works in thunar using what I've described above.
 
Old 01-29-2011, 01:14 AM   #8
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 410

Rep: Reputation: 45
Are your Chinese-named files located in a EXT or a ntfs partition? If they are in ntfs, please add "locale=zh_CN.UTF-8" to /etc/fstab(assume your desktop encoding is UTF-8)

Good Luck.

Last edited by grissiom; 01-29-2011 at 01:14 AM. Reason: fix typo
 
Old 01-29-2011, 09:41 AM   #9
patostevens
Member
 
Registered: Dec 2007
Location: Kennewick,WA
Distribution: Slackware 14
Posts: 170

Original Poster
Rep: Reputation: 21
linuxs64: did log out/in. Slight improvement as noted in my second post in this thread.

grissiom: the files are on a regular linux partition - no NTFS.
 
Old 01-29-2011, 09:57 AM   #10
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
What font are you using in KDE? Could you past a couple of the problematic file names here so we can try to reproduce the problem?
 
Old 01-29-2011, 06:56 PM   #11
patostevens
Member
 
Registered: Dec 2007
Location: Kennewick,WA
Distribution: Slackware 14
Posts: 170

Original Poster
Rep: Reputation: 21
Here is a list of two of the directory names
pat[~]$ dir /home/pat/Duokan/
12-31++ݾ 1231ŷ汾

In any browser, these names are showing in chinese characters. It's just when it hits my system that the display goes south.
 
Old 01-29-2011, 08:51 PM   #12
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Perhaps in copying the file from its source the filename became corrupted due to conversion problems coming from a filesystem not using unicode?

Can you create a new file with Chinese characters? I just created a new file called "汉语⁄漢語" (which is Chinese for Chinese apparently!) in Dolphin and on the commandline using urxvt. No problems.
 
Old 01-29-2011, 09:51 PM   #13
patostevens
Member
 
Registered: Dec 2007
Location: Kennewick,WA
Distribution: Slackware 14
Posts: 170

Original Poster
Rep: Reputation: 21
That sounds likely. I think this guy's file names are just corrupted. Oh well - thanks for all the effort and ideas.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
display Chinese characters in Firefox under Fedora flyonsnow Linux - Newbie 2 06-17-2009 04:56 PM
evince and xpdf cannot display Chinese characters... surfboarder Linux - Newbie 1 05-28-2009 07:27 PM
Is it possible to display Chinese characters in Fedora English environment? yilang Fedora 10 05-10-2006 10:02 AM
How to make Chinese characters display correctly in Gentoo? fossilet Linux - Distributions 4 10-31-2004 08:21 AM
Konqueror does not display Chinese characters correctly whitefox Slackware 3 03-01-2004 08:40 PM


All times are GMT -5. The time now is 10:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration