LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-20-2006, 06:26 PM   #1
Cyric
Member
 
Registered: Sep 2004
Location: NC, USA
Distribution: Slackware 10
Posts: 109

Rep: Reputation: 15
Disabling GUI


Hello, I was wondering if there was a way to disable the gui during startup. My screen is really wacky looking all of a sudden, and I cant seem to get it back to normal.
 
Old 06-20-2006, 06:57 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
as root you can usually do init 3. If you want to change the default runlevel at boot, just change the init in /etc/inittab. http://www.redhat.com/docs/manuals/l...down-sysv.html
Code:
id:5:initdefault:
Note that in Debian, all runlevels between 2 and 5 are the same unless you customize them. It doesn't adhere to the general init levels in the link I provided.

Last edited by pljvaldez; 06-20-2006 at 06:58 PM.
 
Old 06-20-2006, 07:00 PM   #3
Cyric
Member
 
Registered: Sep 2004
Location: NC, USA
Distribution: Slackware 10
Posts: 109

Original Poster
Rep: Reputation: 15
Well, therein lies the problem. My screen is so screwed up, I cant see to log in, or do anything period. I need to know if there is maybe a button you can hold during startup or something to keep the gui from running in the first place.
 
Old 06-20-2006, 07:01 PM   #4
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Slackware usesed init 4 for GUI, but init 3 will get you to the console as pljvaldez said.

regards,
...aaron
 
Old 06-20-2006, 07:03 PM   #5
xpromisex
Member
 
Registered: Apr 2004
Location: Statesboro, GA
Distribution: Arch Linux 2007.05 "Duke" (Kernel 2.6.21)
Posts: 447

Rep: Reputation: 30
if you hit Ctrl + Alt + F1 (or and F2 - F6) you should be able to get to a tty.
 
Old 06-20-2006, 07:05 PM   #6
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
SLackware reserves F6 for a tty in init 4. ctrl+alt+F6 will get you to a console, then change your run level to init 3 in your /etc/inittab.

..aaron

**edit**
sometimes it will be a little buggy, try hitting ctrl+c a few times after you go to tty6

Last edited by drkstr; 06-20-2006 at 07:06 PM.
 
Old 06-20-2006, 08:03 PM   #7
Cyric
Member
 
Registered: Sep 2004
Location: NC, USA
Distribution: Slackware 10
Posts: 109

Original Poster
Rep: Reputation: 15
Thanks guys, that did the trick.
 
Old 06-20-2006, 08:26 PM   #8
Cyric
Member
 
Registered: Sep 2004
Location: NC, USA
Distribution: Slackware 10
Posts: 109

Original Poster
Rep: Reputation: 15
Ok, one more dumb question. Now that I have disable the gui, how can I tell if I am connected to the internet?
 
Old 06-20-2006, 08:30 PM   #9
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
a common test would be to use the 'ping' command passing either an ip address or hostname (ei linuxquestions.org) as a parameter. you may need to run the command as root. the command will tell you the success rate and thus your connectivity.
 
Old 06-20-2006, 08:34 PM   #10
cereal83
Member
 
Registered: Feb 2004
Location: Canada
Distribution: Slackware
Posts: 478

Rep: Reputation: 30
edit /etc/inittab and change the run level from 4 to 3

then edit whatever you want and change it back from 3 to 4 when it is normal again

If your xwindows is all screwed up, you can try running xconfig and see if that fixes it but make sure to backup /etc/X11/xorg.conf first
 
Old 06-20-2006, 08:38 PM   #11
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
you can also try a console web browser. 'links' and 'lynx' both work well.

...aaron
 
Old 06-20-2006, 09:58 PM   #12
Cyric
Member
 
Registered: Sep 2004
Location: NC, USA
Distribution: Slackware 10
Posts: 109

Original Poster
Rep: Reputation: 15
Thanks, that worked. One more quiestion and I will be done for now, lol. No one can seem to connect to me, anymore. I have beem running a few websites and small online games without any problems. Had some downtime due to a hardware issue. Now I cant get any connections for some reason. I am on a router, and everyone one the same router connects just fine, but no one else can.
 
Old 06-20-2006, 10:02 PM   #13
cereal83
Member
 
Registered: Feb 2004
Location: Canada
Distribution: Slackware
Posts: 478

Rep: Reputation: 30
Do you get an ip addy from dhcp? are you sure it's giving you one? Make sure ip info is correct
 
Old 06-20-2006, 10:14 PM   #14
Cyric
Member
 
Registered: Sep 2004
Location: NC, USA
Distribution: Slackware 10
Posts: 109

Original Poster
Rep: Reputation: 15
Yes, I have an ip, I have the ports I want to use forwarded for that ip as well.
 
Old 06-20-2006, 10:36 PM   #15
cereal83
Member
 
Registered: Feb 2004
Location: Canada
Distribution: Slackware
Posts: 478

Rep: Reputation: 30
can you do "route -n" and post it here?

Can you ping the router?
 
  


Reply

Tags
disable, gui


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Ubuntu GUI] Changing GUI from Gnome to wmaker MangaManiac Linux - Laptop and Netbook 8 05-08-2005 03:17 PM
KDE gui vs. Gnome GUI Curt6000 Linux - Newbie 11 11-10-2004 01:37 PM
disabling behind the firewall asimhafeez Linux - Security 2 06-16-2004 03:35 AM
Isn't Windows 95 or 98 a better GUI solution for old machines than an old Linux GUI lynchmob09 General 10 04-20-2004 01:24 AM
Disabling Beeper serenity999 Linux - General 2 10-20-2003 03:38 PM


All times are GMT -5. The time now is 05:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration