LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Disabling GUI (http://www.linuxquestions.org/questions/slackware-14/disabling-gui-456730/)

Cyric 06-20-2006 06:26 PM

Disabling GUI
 
Hello, I was wondering if there was a way to disable the gui during startup. My screen is really wacky looking all of a sudden, and I cant seem to get it back to normal.

pljvaldez 06-20-2006 06:57 PM

as root you can usually do init 3. If you want to change the default runlevel at boot, just change the init in /etc/inittab. http://www.redhat.com/docs/manuals/l...down-sysv.html
Code:

id:5:initdefault:
Note that in Debian, all runlevels between 2 and 5 are the same unless you customize them. It doesn't adhere to the general init levels in the link I provided.

Cyric 06-20-2006 07:00 PM

Well, therein lies the problem. My screen is so screwed up, I cant see to log in, or do anything period. I need to know if there is maybe a button you can hold during startup or something to keep the gui from running in the first place.

drkstr 06-20-2006 07:01 PM

Slackware usesed init 4 for GUI, but init 3 will get you to the console as pljvaldez said.

regards,
...aaron

xpromisex 06-20-2006 07:03 PM

if you hit Ctrl + Alt + F1 (or and F2 - F6) you should be able to get to a tty.

drkstr 06-20-2006 07:05 PM

SLackware reserves F6 for a tty in init 4. ctrl+alt+F6 will get you to a console, then change your run level to init 3 in your /etc/inittab.

..aaron

**edit**
sometimes it will be a little buggy, try hitting ctrl+c a few times after you go to tty6

Cyric 06-20-2006 08:03 PM

Thanks guys, that did the trick.

Cyric 06-20-2006 08:26 PM

Ok, one more dumb question. Now that I have disable the gui, how can I tell if I am connected to the internet?

nadroj 06-20-2006 08:30 PM

a common test would be to use the 'ping' command passing either an ip address or hostname (ei linuxquestions.org) as a parameter. you may need to run the command as root. the command will tell you the success rate and thus your connectivity.

cereal83 06-20-2006 08:34 PM

edit /etc/inittab and change the run level from 4 to 3

then edit whatever you want and change it back from 3 to 4 when it is normal again

If your xwindows is all screwed up, you can try running xconfig and see if that fixes it but make sure to backup /etc/X11/xorg.conf first

drkstr 06-20-2006 08:38 PM

you can also try a console web browser. 'links' and 'lynx' both work well.

...aaron

Cyric 06-20-2006 09:58 PM

Thanks, that worked. One more quiestion and I will be done for now, lol. No one can seem to connect to me, anymore. I have beem running a few websites and small online games without any problems. Had some downtime due to a hardware issue. Now I cant get any connections for some reason. I am on a router, and everyone one the same router connects just fine, but no one else can.

cereal83 06-20-2006 10:02 PM

Do you get an ip addy from dhcp? are you sure it's giving you one? Make sure ip info is correct

Cyric 06-20-2006 10:14 PM

Yes, I have an ip, I have the ports I want to use forwarded for that ip as well.

cereal83 06-20-2006 10:36 PM

can you do "route -n" and post it here?

Can you ping the router?


All times are GMT -5. The time now is 03:41 PM.