LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Disabling GkrellM autostart. (http://www.linuxquestions.org/questions/slackware-14/disabling-gkrellm-autostart-4175485695/)

Arcosanti 11-24-2013 02:47 AM

Disabling GkrellM autostart.
 
Where does GkrellM put it's startup at? I've looked in /etc/rd.d and in XFCE's autostart up area and can't find GkrellM. I no longer need it running automatically anymore. I was using it to monitor my processor and hard drive temps. Now I have XFCE's sensors plugin doing that and so I no longer need GkrellM for that anymore.

Didier Spaier 11-24-2013 05:29 AM

I'd do this to find out (as root):
Code:

grep -r gkrellm /etc
If you don't need it at all:
Code:

removepkg gkrellm

Arcosanti 11-24-2013 01:34 PM

Unfortunately grep did not find anything in /etc and I couldn't find it anywhere else, so I went ahead and removed the package. I wasn't really wanting to do that as it can be useful for other things. Perhaps, I'll just compile my own from source and install it.

jmccue 11-24-2013 02:25 PM

Gkrellm does not have a 'startup' script. You did not explicitly state your window manger/desktop, but I assume it is xfce. If I had to guess there is a startup "something" created in/by your DE that kicks it off. I think KDE will autostart any program that was executing when you exit out. So maybe the same thing happens in xfce.

John

Richard Cranium 11-24-2013 04:02 PM

XFCE normally runs with session management, so whatever was running when you quit will be started the next time you run xfce.

Try looking in Applications Menu -> Settings -> Sessions and Startup -> Session. If you see gkrellm in the list, click on it and then click the "Quit Program" button.

Arcosanti 11-26-2013 07:02 PM

Quote:

Originally Posted by Richard Cranium (Post 5069958)
Try looking in Applications Menu -> Settings -> Sessions and Startup -> Session. If you see gkrellm in the list, click on it and then click the "Quit Program" button.

That was one place I didn't think to look. That probably was it too. I'll reinstall GkrellM and make sure it is not there. Thanks.

Edit:

I must have already compiled and installed GKrellM on my computer not realizing that it was already installed as a Slackware package. Since I had uninstalled the Slackware package, I was not expecting GkrellM to come up, but it did. I found out that it was XFCE's saved sessions that was starting it in the first place, so I had it removed from there. Now it isn't comming up anymore.


All times are GMT -5. The time now is 09:23 PM.