LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-16-2007, 06:06 PM   #1
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 397

Rep: Reputation: 33
Disabling File System Checking


I have multiple partitions set up on my Slackware 11 machine. I have on for the root partition (hda3), one for /boot (hda2), and one for /home (hda4). Whenever I boot using the 2.6.19.2 kernel, I receive a message for both hda2 and hda4 stating the following:

warning: CONFIG_REISERFS_CHECK is set ON

Within fstab, they are both set to 1 2. Is this where I would disable this check for these partitions? Is there somewhere else to disable this? Is this harmful to leave it as is? Thanks for any responses.
 
Old 02-16-2007, 08:03 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,679
Blog Entries: 54

Rep: Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955
Sounds like a kernel compile time switch. There should be a next line in the logs explaning this switch: "warning: - it is slow mode for debugging."
 
Old 02-17-2007, 02:08 PM   #3
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 397

Original Poster
Rep: Reputation: 33
Yes, this message follows after the one pertaining to the CONFIG_REISERFS_CHECK message during boot-up. Is this something that needs to be addressed and, if so, what should I do? This is the first time that I have enabled separate partitions for Slackware for /boot and /home, and am unsure what the importance of this is. I do not receive these messages for the root drive. Thanks.
 
Old 02-18-2007, 06:59 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,679
Blog Entries: 54

Rep: Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955Reputation: 2955
Is this something that needs to be addressed
Well, it says "it is slow mode for debugging."


what should I do?
Recompile kernel, leave option out?
 
Old 02-18-2007, 08:17 PM   #5
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 397

Original Poster
Rep: Reputation: 33
I'm just wondering why I receive these messages only for partitions other than the root partition. When I was just using one swap and one root partition, I never experienced these messages before. So if I disable reiserfs file checking completely within the kernel, will this have any adverse affect on the system? I can most likely just run reiserfstune occasionally if needed, which is what I've done before anyway.
 
Old 02-18-2007, 08:43 PM   #6
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 397

Original Poster
Rep: Reputation: 33
OK, I have disabled this option within the kernel and recompiled. After reading the notes regarding the debugging option, it is recommended to be disabled for the majority of users. I suppose that I have overlooked this in the past, as I don't recall receiving any sorts of messages when using only one partition, other than the swap. I learn something new about Linux, it seems, each day
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Read-only file system after enabling/disabling root benn333 Ubuntu 2 02-25-2007 01:42 PM
checking XFS file system sikkalgopal Linux - Newbie 1 08-21-2006 05:46 AM
Mandrake 10.1 hangs at "Checking root file system" while booting ananya Mandriva 1 03-01-2006 07:03 PM
Detect storage device by checking mounted file system to Linux syseeker Programming 4 02-06-2006 11:14 AM
checking file system is long av62 Linux - Software 6 05-12-2003 06:17 AM


All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration