LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-16-2012, 01:04 AM   #1
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Slackware64
Posts: 1,700

Rep: Reputation: 76
Disabled touchpad while typing?


I have Slack64 14 running on my Asus X54C laptop (everything except two finger right clicking on the touchpad worked out of the box and that was solved with the addition of the kcm_touchpad package from slackbuilds).
The problem I'm getting is the familiar one of accidentally touching the touchpad while typing and having the cursor move to an unwanted part of the screen.

There doesn't appear to be a "disable whilst typing" option. Someone on a different forum directed me to an Ubuntu package called "touchpad-indicator". The contents of the source code is a bunch of stuff ending in .py
Not having ever run anything of this nature I'm somewhat at a loss as to how to get it working.
I found a mandriva rpm for the package and converted it using rpm2tgz and installed it. It shows up in the menu but won't launch. The directory is in /usr/share/touchpad-indicator and contains lots of what I presume is python type stuff.

I have to type up part of a 12,000 word thesis on this laptop and if I have to keep deleting text that's in the wrong place I'm going to go nuts.
Any pointers or ideas would be gratefully received.
 
Old 11-16-2012, 01:30 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,314

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
with my synaptics touchpad I do it with synclient (but I have an external usb mouse)
Code:
synclient TouchpadOff=1
as the mouse will be turned off, you can launch this in a terminal and switch back with alt-tab to it to re-enable
Code:
synclient TouchpadOff=0
 
1 members found this post helpful.
Old 11-16-2012, 01:43 AM   #3
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Slackware64
Posts: 1,700

Original Poster
Rep: Reputation: 76
I have a USB mouse I can use (though prefer not to) but the code works fine.

It's a fix of sorts.

Thankyou
 
Old 11-16-2012, 02:03 AM   #4
emgee_1
Member
 
Registered: Aug 2009
Location: Nijmegen, The Netherlands
Distribution: Slackware 14
Posts: 38

Rep: Reputation: 6
I use the following little script (in my openbox autostart file:


Code:
#!/bin/sh
syndaemon -i 6 -d
syndaemon has a man file

Code:
syndaemon(1)                                                      syndaemon(1)

NAME
       syndaemon  - a program that monitors keyboard activity and disables the
       touchpad when the keyboard is being used.

SYNOPSIS
       syndaemon [-i idle-time] [-m poll-inverval]  [-d]  [-p  pid-file]  [-t]
       [-k] [-K] [-R]

DESCRIPTION
       Disabling  the  touchpad  while typing avoids unwanted movements of the
       pointer that could lead to giving focus to the wrong window.
Marcel
 
3 members found this post helpful.
Old 11-16-2012, 03:18 AM   #5
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Slackware64
Posts: 1,700

Original Poster
Rep: Reputation: 76
I use the following little script (in my openbox autostart file:


Code:
#!/bin/sh
syndaemon -i 6 -d

That is about perfect. Just what I was looking for.

Many thanks.
 
Old 11-16-2012, 03:53 AM   #6
lkraemer
Member
 
Registered: Aug 2008
Posts: 111

Rep: Reputation: 10
Checkout the following:

Code:
man synclient
synclient -l

Larry
 
1 members found this post helpful.
Old 11-16-2012, 01:32 PM   #7
corvid
LQ Newbie
 
Registered: May 2011
Posts: 16

Rep: Reputation: Disabled
How interesting... I'd been using xinput --set-prop all this time...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 11.10 touchpad disabled after login CW_OP Ubuntu 0 06-06-2012 09:42 PM
[SOLVED] touchpad interfering with typing in Squeeze (Debian) Gnome. edbarx Linux - Laptop and Netbook 6 02-26-2012 05:52 AM
touchpad disabled in gnome 3 Mr Mutundis Fedora 5 09-14-2011 07:24 PM
Touchpad disable/enable typing. zuriel45 Linux - Software 2 01-21-2011 08:42 AM
Disabling Touchpad while typing. nardz Linux - Desktop 4 01-24-2008 04:33 AM


All times are GMT -5. The time now is 11:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration