LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-21-2013, 01:54 AM   #1
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,555

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
Disable Touchpad on Dell Vostro ?


Hi,

The title says it all. How do I disable the touchpad on a Dell Vostro laptop? I'm using an USB optical mouse, and everytime I do so much as brush over the touchpad, the mouse cursor goes into WARP MODE like Han Solo's Millennium Falcon only to reappear on some random and completely unexpected location on the screen.

Any suggestions?

Cheers,

Niki
 
Old 01-21-2013, 04:28 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,305

Rep: Reputation: 552Reputation: 552Reputation: 552Reputation: 552Reputation: 552Reputation: 552
Messy to disable it. Check in your window manager. On all of them above dead primitive you can adjust the sensitivity. I have/had the same issue here.
 
Old 01-21-2013, 05:55 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,582
Blog Entries: 2

Rep: Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037
I use this little script to turn the Synaptics touchpad in my laptop on/off:
Code:
#!/bin/zsh                                                                      
                                                                                
synclient TouchpadOff=$(synclient -l|grep -c 'TouchpadOff.*=.*0')
 
Old 01-21-2013, 06:30 AM   #4
dh_
LQ Newbie
 
Registered: Jan 2013
Posts: 6

Rep: Reputation: Disabled
Easy way would be to type “removepkg xf86-input-synaptics”.
 
Old 01-21-2013, 09:30 AM   #5
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
You can take a look at flSynclient in Slackbuilds. It has a simple On Off function for your synaptics touchpad. I use it on my netbook.
 
Old 01-21-2013, 11:10 AM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,189

Rep: Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023
Here (Lenovo Thinkpad T61) "rmmod psmouse" works, so I put that in /etc/rc.d/rc.local. Or you could blacklist psmouse. Adapt accordingly if your touchpad is claimed by another kernel module.

Last edited by Didier Spaier; 01-21-2013 at 11:13 AM.
 
  


Reply

Tags
touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 15 on Dell Vostro 1510: Touchpad not detected tom6_uk Linux - Laptop and Netbook 2 11-10-2011 07:20 AM
Mandriva 2010 on Dell Vostro V13 - ACPI issue, Battery & Touchpad not detected ongte Mandriva 2 01-29-2010 12:13 AM
Ubuntu on Dell Vostro nbhat Ubuntu 8 11-29-2009 01:57 AM
Touchpad disable button permanently disables touchpad until reboot William (Dthdealer) Linux - Hardware 12 08-01-2009 10:51 PM
Dell Vostro 400 missluci General 4 03-16-2008 02:54 PM


All times are GMT -5. The time now is 07:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration