LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-28-2005, 01:53 AM   #1
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Rep: Reputation: 15
Direct Rendering and fglrx


This problem was not solved from reading all the other threads so I will go ahead. I can't seem to get direct rendering to work this time around. I recently reinstalled slackware and previously it worked fine.

The fglrx drivers in the xorg.0.log show direct rendering as enabled yet when I run glxgears it returns a no and obviously it doesn't work.

When I run fgl_glxgears it simply returns an error of BadLength and crashes. That seems to be a VERY bad thing.

Anyone have any advice?
 
Old 04-28-2005, 03:10 AM   #2
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,

can post the following output, please
Code:
grep "Load" /etc/X11/xorg.conf
regards

slackie1000
 
Old 04-28-2005, 03:20 AM   #3
AndyMCR
Member
 
Registered: Apr 2005
Location: Manchester, UK
Distribution: Slackware Current
Posts: 39

Rep: Reputation: 15
Is it an ATI card? If so:, try this:

The display driver requires POSIX shared memory to be enabled on the system in order to run these applications correctly. This feature should be enabled by default on most current Linux distributions, but may be disabled intentionally by some system administrators or not included in older distributions.

To enable POSIX shared memory on your system, perform the following as root:

1. Add to following line to /etc/fstab (if it isn't there already):

tmpfs /dev/shm tmpfs defaults 0 0

2. Mount POSIX shared memory as follows:

mount /dev/shm

3. Issue the following command to check that it mounted properly:

mount | grep "shm"

4. If the mount was successful, then the following output (or similar) should appear:

tmpfs on /dev/shm type tmpfs (rw)

At this point, POSIX shared memory is enabled. Your 3D applications should run properly and the error message above should no longer occur.

Worked for me on Slack -currrent,

Andy.
 
Old 04-28-2005, 03:58 AM   #4
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Original Poster
Rep: Reputation: 15
Load "dbe" # Double buffer extension
Load "type1"
Load "freetype"
Load "glx" # libglx.a
Load "dri" # libdri.a

Theres the output from running that command.

Indeed POSIX shared memory wasn't mounted so I did so but still there is no direct rendering.

Its work mention that when I run the command glxinfo, I get a segmentation fault. Always love those one programs like glxinfo...
 
Old 04-28-2005, 04:24 AM   #5
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi there,

which driver are you using in the device section of you xorg.conf file?

regards

slackie1000
 
Old 04-28-2005, 11:35 AM   #6
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Original Poster
Rep: Reputation: 15
If you read the thread title it says fglrx.
 
Old 04-28-2005, 12:15 PM   #7
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
Quote:
Originally posted by drakethegreat
If you read the thread title it says fglrx.
no reason to be rude...

take a look here.
the how-to belong to other distro but i think can give some input..
regards
slackie1000
 
Old 04-28-2005, 02:16 PM   #8
Skazi
Member
 
Registered: Aug 2004
Location: Minneapolis, MN, USA
Distribution: Slackware 13.1
Posts: 82

Rep: Reputation: 15
I just went through this again. From a fresh install of Slack 10.1 (2.4 kernel), and the latest drivers from ATI, these were the most important things for me to get it to work:

1. Disable DRI (DRM) in the kernel, recompile. As shipped, slack has it turned on.
2. Set UseinternalAGP to "no" in the xorg.conf that fglrxconfig produces. Also, make sure the agpgart module is loaded (or built into the kernel) before startx.

Other than those 2 points, I pretty much just followed the standard procedure outined in countless threads.

Hope that helps

nforce2 chipset
ATI Radeon 9800 Pro
 
Old 04-28-2005, 02:21 PM   #9
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Original Poster
Rep: Reputation: 15
Sorry if I sounded rude, was just trying to point out that I had posted it in the topic. Text doesn't display tone of voice unfortunately.

Anyways I went to that thread and I already have fglrx loaded as a module in the kernel and the configuration was setup using fglrxconfig which I am currently using. I didn't see anything in that thread about a failure of direct rendering. Maybe I overlooked it though.
 
Old 04-28-2005, 02:30 PM   #10
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Original Poster
Rep: Reputation: 15
Ok well I saw stuff regarding my problem with direct rendering but none of it helped me out. I found this in dmesg and I think it may be the issue at hand:

[fglrx] Internal AGP support requested, but kernel AGP support active.
[fglrx] Have to use kernel AGP support to avoid conflicts.

Why is fglrx haven't to use the kernel AGP support? That is most likely the problem. How would one go about fixing this conflict so to speak?
 
Old 04-28-2005, 04:28 PM   #11
dunric
Member
 
Registered: Jul 2004
Distribution: Slackware, FreeBSD
Posts: 483

Rep: Reputation: 92
Quote:
Originally posted by drakethegreat
Ok well I saw stuff regarding my problem with direct rendering but none of it helped me out. I found this in dmesg and I think it may be the issue at hand:

[fglrx] Internal AGP support requested, but kernel AGP support active.
[fglrx] Have to use kernel AGP support to avoid conflicts.

Why is fglrx haven't to use the kernel AGP support? That is most likely the problem. How would one go about fixing this conflict so to speak?
Man, either disable use of internal AGP handler of fglrx driver in xorg.conf in section for your ATI card (Option "UseInternalAGPGART" "no") or unload agpgart kernel module (
Code:
modprobe -r agpgart
) before starting X. If AGP support is built in your kernel, you have to go with the first option.
 
Old 04-28-2005, 07:43 PM   #12
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Original Poster
Rep: Reputation: 15
Ok I can remove the module but my question is why would be loaded if I have it set to no? Thats what is confusing me...
 
Old 04-28-2005, 08:18 PM   #13
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Original Poster
Rep: Reputation: 15
I'm no longer getting that message about the kernel agpgart when I run startx but there is still a agpgart module loading and I still don't have direct rendering. Like I said, that option in the xorg.conf file is set to no and always has been so I'm confused about wtf is going on with this module.
 
Old 04-28-2005, 10:00 PM   #14
Skazi
Member
 
Registered: Aug 2004
Location: Minneapolis, MN, USA
Distribution: Slackware 13.1
Posts: 82

Rep: Reputation: 15
Since you set the internal param to no, you need the agpgart module loaded. Which is why it probably shows up when you startx.

Maybe try one last thing: get out of X, 'modprobe agpgart' to make sure it is loaded. Then startx.

If you still don't have direct rendering (how are you confirming this?), look through /var/log/Xorg.0.log for any (EE), and let us know the errors you are getting.

The best way I know to confirm direct rendering is 'fglrxinfo'. It should output ATI as vendor.
 
Old 04-28-2005, 11:11 PM   #15
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Original Poster
Rep: Reputation: 15
I did all the things you mentioned. I'm checking the status using glxinfo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Direct Rendering: No MegaByll Red Hat 7 10-20-2006 10:42 AM
Direct Rendering mapster Mandriva 3 03-30-2005 08:22 AM
No direct rendering after uninstalling fglrx BedriddenTech Linux - Software 0 10-02-2004 04:35 PM
Direct Rendering jared Linux - General 6 06-05-2003 03:51 PM
Help with direct rendering HellBound Linux - General 3 08-27-2002 04:44 PM


All times are GMT -5. The time now is 10:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration