LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-21-2013, 05:25 PM   #1
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Rep: Reputation: 84
Difficulties getting alsa pre-amp working to raise the volume on my laptop


Even with the volume set at maximum, the speakers on my laptop are not as loud as they should be. I have been trying to get them louder with the alsa pre-amp method Alien Bob suggests in his blog here:

http://alien.slackbook.org/blog/addi...-sound-levels/

I have tried every variation of the code presented in the blog, including replacing "plug" with "hw" in both versions of code given. The very first time I tried with the first block of code, I found that the "Pre-Amp" setting showed up in alsamixer, but I could not adjust it. I tried as a normal user and then as root, but the setting would not budge.

I then tried all the other variations, but after that first time, the Pre-Amp setting wouldn't even show up in alsamixer. So I went back to the original block of code

(this one)
Code:
    pcm.!default {
            type hw
            card 0
    }
    ctl.!default {
            type hw
            card 0
    }
    pcm.!default {
            type plug
            slave.pcm “softvol”
    }
    pcm.softvol {
            type softvol
            slave {
                    pcm “dmix”
            }
            control {
                    name “Pre-Amp”
                    card 0
            }
            min_dB -5.0
            max_dB 20.0
            resolution 6
    }
which is the one that had created the setting the first time (even though I could not change it), and this time, the setting wasn't even there. I tried a whole bunch of different things including removing /etc/asound.state and /var/lib/alsa/asound.state and rebooting 20 different times before I realized that in order for the Pre-Amp setting to show up, I had to be actively playing sound. I started a youtube video and there it was. But still, I am not able to change the setting.

I am looking around for more references to this issue, but unfortunately, the unofficial alsa wiki referenced in Alien's post is not there anymore. If anyone knows what I am doing wrong or can suggest something I haven't tried, I would be grateful.

Thanks.
 
Old 08-21-2013, 05:39 PM   #2
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Original Poster
Rep: Reputation: 84
Wow. It just started working. I started a media player, then started alsamixer. The Pre-amp setting then showed up, but could not be changed. Then I exited the media player and it worked.

I had thought before that pausing the player would be enough if something was blocking me from accessing this setting, but it turns out I had to exit it completely. I should have thought of that before. Sorry for the false alarm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LVM Mount Physical Volume/Logical Volume without a working Volume Group mpivintis Linux - Newbie 10 01-11-2014 07:02 AM
Network & volume not working in Suse 10,0 elgan Linux - Newbie 2 01-30-2010 09:48 AM
volume key on Lenovo Thinkpad SL300 laptop not working anoosh3000 Linux - Laptop and Netbook 3 09-01-2009 06:30 PM
Can't raise volume in Alsamixer? SonoranFun Linux - Software 3 02-15-2006 03:03 PM
SB Live & alsa - Can't Control Volume Levels NeccoWolf Linux - Hardware 5 10-08-2004 11:11 PM


All times are GMT -5. The time now is 11:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration