LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-26-2004, 04:42 AM   #1
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
different kernels


hello i am currently running redhat 9 as well as slack 10 and suse9.1 pro now to boot redhat9 and slack i use a boot disk suse would start automatically if i left it to.well when i boot slack from my floppy at the beggining i am given the choice to add a command and tell it to boot say hda1 or hda2 the only problem is when i tell it to boot redhat, redhat starts up ok no problem but it has been started with the wrong kernel version so i cant go on the net so i want to know how do i change the kernel version of slack do i have to reinstall or is there a command i can use at the beggining to tell it to load a different kernel because i remember when i installed slack there was a massive choice of kernels to choose from hope this make at least a small amount of sense any questions please ask thanks
nige
 
Old 09-26-2004, 10:08 AM   #2
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
Please post your lilo.conf from your Slackware installation.

It seems that you set up some parameters wrong. Specificaly I suspect
root = /dev/hdX for RedHat.
 
Old 09-26-2004, 03:29 PM   #3
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Original Poster
Rep: Reputation: 30
hello carboncopy thanks for your reply my lilo.conf looks like this
"# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/fd0
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda3
label = Linux
read-only
# Linux bootable partition config endsthanks for your time
nige
 
Old 09-26-2004, 04:39 PM   #4
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
your boot disk contains an image of your slackware kernel (2.6.26 default) so you should setup lilo to boot from hda (where a=pri. master):
Code:
boot = /dev/hda
then add your other patitions containing their own kernels (in /boot/vmlinuz) after the slack one:
Code:
# Linux bootable partition config begins

# slack
image = /boot/vmlinuz
root = /dev/hda3
label = Slack
read-only

# redhat
image = /boot/vmlinuz
root = /dev/hda1
label = Redhat
read-only

# suse
image = /boot/vmlinuz
root = /dev/hda2
label = Suse
read-only
Check the configs of you other os's to make sure these settings are correct.
Once modified, run "lilo" and reboot.
 
Old 09-26-2004, 10:31 PM   #5
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 377

Rep: Reputation: 31
I'm booting both Slack10 and Mandrake10, in order to choose which of the two kernels in Mandrake I had to look into /boot in mdk and choose one of the initrd img to put in lilo. It works.
First did: mkdir /mnt/mdk10
then did lilo as follows:
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda1
label = Slackware10
read-only
image=/mnt/mdk10//boot/vmlinuz
label=Mandrake10
root=/dev/hda5
initrd=/mnt/mdk10//boot/initrd-2.6.3-7mdk.img
append="devfs=mount hdd=ide-scsi"
read-only
# Linux bootable partition config ends

then lilo -v

Good luck
 
Old 09-27-2004, 02:18 PM   #6
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Original Poster
Rep: Reputation: 30
hello when i try to open /boot i get error message "cant open file "/boot/vmlinuz-2.4.20-8"because it contains invalid utf-8 data.
probably you are trying to open a binary file" am i right that it is my /boot i need to configure and not lilo.conf sory for not completely understanding
thanks nige
 
Old 09-27-2004, 02:23 PM   #7
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Quote:
Originally posted by master
hello when i try to open /boot i get error message "cant open file "/boot/vmlinuz-2.4.20-8"because it contains invalid utf-8 data.
probably you are trying to open a binary file" am i right that it is my /boot i need to configure and not lilo.conf sory for not completely understanding
thanks nige
The only file you should need to edit is /etc/lilo.conf

Carefully add the lines to the slackware lilo.conf which appear in redhat's and suse's /etc/lilo.conf.
I doesn't really matter which distribution you do it on either, so long as they are all using lilo and not grub to boot with.
 
Old 09-27-2004, 02:23 PM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Nope, the file you need to edit is /etc/lilo.conf

What WilliamS said, is that you should mount your Red Hat partition and look into it's /boot folder to see which is th ekernel image it uses to boot and add it to lilo
 
Old 09-27-2004, 03:27 PM   #9
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Original Poster
Rep: Reputation: 30
one more thing please suse uses lilo mandrake uses lilo but red hat uses grub any idea on how to change it please
thanks nige
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Old Kernels blacksunshine Linux - Software 1 09-27-2004 10:23 PM
4 different kernels? ampex189 Linux - General 4 03-26-2004 02:16 AM
Other Kernels Nic-MDKman Linux - General 6 02-07-2004 06:37 AM
RH 8 kernels and their relation to 'stock' kernels psweetma Linux - Distributions 1 03-29-2003 10:46 PM
kernels watashiwaotaku7 General 2 12-26-2002 08:42 PM


All times are GMT -5. The time now is 06:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration